summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Michael Mulesa2021-09-21 22:42:06 +1000
committerJohn-Michael Mulesa2021-09-21 22:42:06 +1000
commit7f4a0b61a579754336afdaf145bb73c6d5f7b234 (patch)
treef6f4b5cf7b42c2b3f4b6118a0b074bc4415cbf0d
downloadaur-7f4a0b61a579754336afdaf145bb73c6d5f7b234.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD53
-rw-r--r--dirtrally2.desktop8
-rw-r--r--dirtrally2.install3
-rw-r--r--dirtrally2.sh9
5 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb9431cf0abb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = dirtrally2-wine-steam
+ pkgdesc = DiRT Rally 2.0 using WINE with data via Steam
+ pkgver = 1.18
+ pkgrel = 1
+ url = https://store.steampowered.com/app/690790/DiRT_Rally_20/
+ install = dirtrally2.install
+ arch = x86_64
+ license = custom
+ makedepends = steamcmd
+ makedepends = icoutils
+ depends = wine
+ depends = winetricks
+ source = dirtrally2.sh
+ source = dirtrally2.desktop
+ source = Goldberg_Lan_Steam_Emu_master--a24a9c26.zip::https://gitlab.com/Mr_Goldberg/goldberg_emulator/-/jobs/1590301114/artifacts/download
+ sha256sums = 54efc57383072f7464aa892d2042d598b43f78fe9395953edc5ab6be9912b86a
+ sha256sums = 6e861a168f8d5418646a12e8596cebe01b0f1f0ab6fbd542bff298c3d7c4988b
+ sha256sums = 3bfe422a3daf85a02fe6458e4351a4f40f29f513ec8df2c838c7e197844e51cb
+
+pkgname = dirtrally2-wine-steam
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb953a73624e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: John-Michael Mulesa <jmulesa [at] gmail.com>
+
+pkgname=dirtrally2-wine-steam
+_pkgname=dirtrally2
+pkgver=1.18
+pkgrel=1
+_steamid=690790
+arch=('x86_64')
+makedepends=('steamcmd' 'icoutils')
+depends=('wine' 'winetricks')
+source=("${_pkgname}.sh" "${_pkgname}.desktop"
+ "Goldberg_Lan_Steam_Emu_master--a24a9c26.zip::https://gitlab.com/Mr_Goldberg/goldberg_emulator/-/jobs/1590301114/artifacts/download")
+pkgdesc="DiRT Rally 2.0 using WINE with data via Steam"
+license=('custom')
+install=dirtrally2.install
+url='https://store.steampowered.com/app/690790/DiRT_Rally_20/'
+sha256sums=('54efc57383072f7464aa892d2042d598b43f78fe9395953edc5ab6be9912b86a'
+ '6e861a168f8d5418646a12e8596cebe01b0f1f0ab6fbd542bff298c3d7c4988b'
+ '3bfe422a3daf85a02fe6458e4351a4f40f29f513ec8df2c838c7e197844e51cb')
+
+prepare() {
+ mkdir -p $srcdir/${_pkgname}
+
+ # Use steamcmd to get data.
+ printf "Enter your Steam username:"
+ read steam_username
+ steamcmd +@sSteamCmdForcePlatformType windows +@ShutdownOnFailedCommand 1 +force_install_dir $srcdir/${_pkgname} +login $steam_username "+app_update ${_steamid} validate" +quit
+ wrestool -x -t -14 -o . ${_pkgname}/${_pkgname}.exe
+ icotool -x -o . *.ico
+}
+
+package() {
+ mkdir -p $pkgdir/opt/${_pkgname}
+
+ # Move required files to pkgdir
+ cp -r $srcdir/${_pkgname}/* $pkgdir/opt/${_pkgname}/
+ rm -rf $pkgdir/opt/${_pkgname}/steamapps
+ $srcdir/linux/tools/find_interfaces.sh $pkgdir/opt/${_pkgname}/steam_api64.dll > $pkgdir/opt/${_pkgname}/steam_interfaces.txt || true
+ cp $srcdir/steam_api64.dll $pkgdir/opt/${_pkgname}/
+ echo "${_steamid}" > $pkgdir/opt/${_pkgname}/steam_appid.txt
+
+ # Install desktop file.
+ install -D -m 644 $srcdir/${_pkgname}.desktop \
+ $pkgdir/usr/share/applications/${_pkgname}.desktop
+
+ # Install icon file.
+ install -D -m 644 $srcdir/dirtrally2.exe_*_256x256x32.png \
+ $pkgdir/usr/share/pixmaps/${_pkgname}.png
+
+ # Install bash startup script.
+ install -D -m 755 $srcdir/${_pkgname}.sh \
+ $pkgdir/usr/bin/${_pkgname}
+}
diff --git a/dirtrally2.desktop b/dirtrally2.desktop
new file mode 100644
index 000000000000..f28b834d38c3
--- /dev/null
+++ b/dirtrally2.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=DiRT Rally 2.0
+Comment=DiRT Rally 2.0 WINE
+Exec=/usr/bin/dirtrally2
+Icon=dirtrally2
+Terminal=false
+Type=Application
+Categories=Application;Game;
diff --git a/dirtrally2.install b/dirtrally2.install
new file mode 100644
index 000000000000..2aa0d9fe8645
--- /dev/null
+++ b/dirtrally2.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "On the first run, game startup may take significantly longer while the wine prefix is prepared."
+}
diff --git a/dirtrally2.sh b/dirtrally2.sh
new file mode 100644
index 000000000000..ad6c48daf3c8
--- /dev/null
+++ b/dirtrally2.sh
@@ -0,0 +1,9 @@
+#!/bin/bash
+export WINEPREFIX="$HOME"/.dirtrally2/wine
+if [ ! -d "$HOME"/.dirtrally2 ] ; then
+ mkdir -p "$HOME"/.dirtrally2/wine
+ wineboot -u
+ winetricks dxvk
+fi
+cd /opt/dirtrally2
+/usr/bin/wine dirtrally2.exe