summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-30 08:51:06 -0600
committerMark Wagie2021-10-30 08:51:06 -0600
commit7f5754dc529b4bef7f6c9598b7d1629186c1ecf7 (patch)
treed5ae59db0bd13c3a64c08de8229f91a379692ac9
parent9fce997228ed45435f3b6cf8a9430129a01944bb (diff)
downloadaur-7f5754dc529b4bef7f6c9598b7d1629186c1ecf7.tar.gz
PKGBUILD improvements
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD7
2 files changed, 3 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c96642deca03..add827986f77 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,4 +19,3 @@ pkgbase = gnome-session-properties
sha256sums = a06118f85b26ef13d82f666f8a86cae1fb3e9ca12cd45703ef4dd9ecadfa3aab
pkgname = gnome-session-properties
-
diff --git a/PKGBUILD b/PKGBUILD
index 71a01ffd86de..1e1bb9841052 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,6 @@ url="https://www.gnome.org"
license=('GPL2')
depends=('gtk3' 'hicolor-icon-theme' 'dbus-glib')
makedepends=('gnome-common' 'gtk-doc' 'intltool')
-#options=('!emptydirs')
source=("https://download-fallback.gnome.org/sources/gnome-session/${pkgver%.*}/gnome-session-${pkgver}.tar.xz"
'https://raw.githubusercontent.com/chenxiaolong/AUR-Files/b8632ea084b21e5fdef70a5ba7787c5567403146/gnome-session-properties/0001-Remove-unneeded-stuff.patch'
'https://raw.githubusercontent.com/chenxiaolong/AUR-Files/b8632ea084b21e5fdef70a5ba7787c5567403146/gnome-session-properties/0002-Fix-GTK-3.14-incompatibilities.patch')
@@ -21,6 +20,9 @@ prepare() {
cd "gnome-session-${pkgver}"
patch -p1 -i ../0001-Remove-unneeded-stuff.patch
patch -p1 -i ../0002-Fix-GTK-3.14-incompatibilities.patch
+
+ sed -ri '/^Icon/ s/session-/gnome-session-/g' \
+ "data/$pkgname.desktop.in.in"
}
build() {
@@ -38,7 +40,4 @@ package() {
for f in ${files}; do
mv "${f}" "${f/apps\/session-/apps\/gnome-session-}"
done
-
- sed -ri '/^Icon/ s/session-/gnome-session-/g' \
- "${pkgdir}/usr/share/applications/gnome-session-properties.desktop"
}