summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Hayot2018-04-28 11:00:07 +0200
committerGuillaume Hayot2018-04-28 11:00:07 +0200
commit7f5e5e6daa8ee086b849ff4bc3c4302beb4315b9 (patch)
tree42ef64b021d59af50abf8a059851958b3a490a3d
parent5bc822f076d20c282a59414e724fabab30d46f6c (diff)
downloadaur-7f5e5e6daa8ee086b849ff4bc3c4302beb4315b9.tar.gz
Fix build
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 3 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 868b034bc4c9..3b79c6c96f01 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,6 +10,7 @@ pkgbase = libpurple-carbons-git
depends = libpurple
depends = glib2
depends = libxml2
+ conflicts = libpurple-carbons
source = carbons::git+https://github.com/gkdr/carbons.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e679c5581a48..bbfa51e1e1c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,6 +11,7 @@ url="https://github.com/gkdr/carbons"
license=('GPL')
depends=('libpurple' 'glib2' 'libxml2')
makedepends=('git')
+conflicts=('libpurple-carbons')
source=("$_pkgname::git+https://github.com/gkdr/carbons.git")
sha256sums=('SKIP')
@@ -28,14 +29,9 @@ prepare() {
git submodule update --init --recursive
}
-build() {
- cd "$srcdir/$_pkgname"
- make
-}
-
package() {
cd "$srcdir/$_pkgname"
- make prefix="$pkgdir/usr/" install
+ make install PURPLE_PLUGIN_DIR="$pkgdir/usr/lib/purple-2"
}
# vim:set ts=2 sw=2 et: