summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2019-06-25 16:07:22 +0800
committerJingbei Li2019-06-25 16:58:08 +0800
commit7f638154d2cd4e426e11c92d826817bb4b50715e (patch)
treee8dab27bfeb53c7581e2dc1282cc976ded9b6f82
parent0d3c8b8b01bc2f25ee7ddd7b4e190242f139b244 (diff)
downloadaur-7f638154d2cd4e426e11c92d826817bb4b50715e.tar.gz
build against gcc8's headers
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--build.sh (renamed from build_python.sh)4
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0b55a1e3a4d..9192ec2ddb46 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = python-scipy-mkl
pkgdesc = SciPy is open-source software for mathematics, science, and engineering.
pkgver = 1.3.0
- pkgrel = 1
+ pkgrel = 2
url = http://www.scipy.org/
arch = x86_64
license = BSD
- checkdepends = python-pytest
+ makedepends = gcc8
makedepends = python-setuptools
depends = intel-compiler-base
depends = intel-fortran-compiler
@@ -15,7 +15,9 @@ pkgbase = python-scipy-mkl
provides = python-scipy=1.3.0
conflicts = python-scipy
source = https://github.com/scipy/scipy/releases/download/v1.3.0/scipy-1.3.0.tar.gz
+ source = build.sh
sha512sums = 11dfe6027061efb176811d1d2c8b60ee53157f6fff59baa312b3b6a84461123e12f044d5d138d04b1162612d35c6cc34837208d56cdf79c294862ef90c62ea1d
+ sha512sums = 1ad168482bd4774e47af009f888a549233defe5593b7464f3f5577a25ebec180905c948ebf3936c33ac49f2ea8cba5dcd060f8b86adb99ed2f1fc41fd2bf82bf
pkgname = python-scipy-mkl
diff --git a/PKGBUILD b/PKGBUILD
index 44639d1c70e3..2acdc910fcc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname='python-scipy-mkl'
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="SciPy is open-source software for mathematics, science, and engineering."
arch=('x86_64')
url="http://www.scipy.org/"
@@ -16,18 +16,19 @@ license=('BSD')
depends=('intel-compiler-base' 'intel-fortran-compiler' 'intel-mkl' 'python-numpy')
provides=("python-scipy=$pkgver")
conflicts=('python-scipy')
-makedepends=('python-setuptools')
-checkdepends=('python-pytest')
+makedepends=('gcc8' 'python-setuptools')
+#checkdepends=('python-pytest')
optdepends=('python-pillow: for image saving module')
-source=("https://github.com/scipy/scipy/releases/download/v${pkgver}/scipy-${pkgver}.tar.gz")
-sha512sums=('11dfe6027061efb176811d1d2c8b60ee53157f6fff59baa312b3b6a84461123e12f044d5d138d04b1162612d35c6cc34837208d56cdf79c294862ef90c62ea1d')
+source=("https://github.com/scipy/scipy/releases/download/v${pkgver}/scipy-${pkgver}.tar.gz" 'build.sh')
+sha512sums=('11dfe6027061efb176811d1d2c8b60ee53157f6fff59baa312b3b6a84461123e12f044d5d138d04b1162612d35c6cc34837208d56cdf79c294862ef90c62ea1d'
+ '1ad168482bd4774e47af009f888a549233defe5593b7464f3f5577a25ebec180905c948ebf3936c33ac49f2ea8cba5dcd060f8b86adb99ed2f1fc41fd2bf82bf')
build() {
export LDFLAGS="-Wall -shared"
+ export __INTEL_PRE_CFLAGS="-I/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/include/c++ -I/usr/lib/gcc/x86_64-pc-linux-gnu/8.3.0/include/c++/x86_64-pc-linux-gnu/"
- # build for python3
cd scipy-${pkgver}
- python3 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem
+ sh ${srcdir}/build.sh
}
#check() {
diff --git a/build_python.sh b/build.sh
index d1f26ad9e682..55f92a491875 100644
--- a/build_python.sh
+++ b/build.sh
@@ -4,7 +4,7 @@
# The set environment variable, however, precludes compiling C++ code
# So, if the build process fails, it is re-run without the environment variable und continues until failing again etc.
set +e
-build="$1 setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem"
+build="python setup.py config --compiler=intelem --fcompiler=intelem build_clib --compiler=intelem --fcompiler=intelem build_ext --compiler=intelem --fcompiler=intelem -j$(nproc)"
method1() {
echo Retry: $retry Method: 1
@@ -19,5 +19,5 @@ method2() {
# It will end at 'Retry: 5 Method: 2' for scipy 1.1.0 and intel-parallel-studio-xe 2018.3.222
for retry in $(seq 10); do
method1 && break
- method2 && break
+ #method2 && break
done