summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorViktor Drobot2021-07-25 12:40:41 +0300
committerViktor Drobot2021-07-25 12:40:41 +0300
commit7f70d610efd2d64741cd0562ac8565dd15661907 (patch)
tree5e8c9bd81d1dfb2a93abdcff6eece09011189fbb
parent417e11d78eda48a9330732a1191a89a85c453e10 (diff)
downloadaur-7f70d610efd2d64741cd0562ac8565dd15661907.tar.gz
Update
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD37
2 files changed, 32 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f57610fe5dd..1ff9574a132c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,21 @@
pkgbase = r-bit
- pkgdesc = A Class for Vectors of 1-Bit Booleans
- pkgver = 1.1.14
+ pkgdesc = Classes and Methods for Fast Memory-Efficient Boolean Selections
+ pkgver = 4.0.4
pkgrel = 1
url = https://cran.r-project.org/package=bit
+ arch = i686
arch = x86_64
license = GPL2
- depends = r
- replaces = r-cran-bit
- source = https://cran.r-project.org/src/contrib/bit_1.1-14.tar.gz
- md5sums = e62b50777478fe4dd624955cfd609fcc
+ license = GPL3
+ depends = r>=2.9.2
+ optdepends = r-testthat
+ optdepends = r-roxygen2
+ optdepends = r-knitr
+ optdepends = r-rmarkdown
+ optdepends = r-microbenchmark
+ optdepends = r-bit64
+ optdepends = r-ff
+ source = https://cran.r-project.org/src/contrib/bit_4.0.4.tar.gz
+ sha256sums = e404841fbe4ebefe4ecd4392effe673a8c9fa05f97952c4ce6e2f6159bd2f168
pkgname = r-bit
-
diff --git a/PKGBUILD b/PKGBUILD
index c910c7f963d3..9203f8c882b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
-# Maintainer: Alex Branham <branham@utexas.edu>
+# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Contributor: Alex Branham <branham@utexas.edu>
+
_cranname=bit
-_cranver=1.1-14
-_pkgtar=${_cranname}_${_cranver}.tar.gz
-pkgname=r-bit
+_cranver=4.0.4
+pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
pkgrel=1
-pkgdesc="A Class for Vectors of 1-Bit Booleans"
-arch=('x86_64')
+pkgdesc="Classes and Methods for Fast Memory-Efficient Boolean Selections"
+arch=(i686 x86_64)
url="https://cran.r-project.org/package=${_cranname}"
-license=('GPL2')
-depends=('r' )
-
-
-
-source=("https://cran.r-project.org/src/contrib/${_pkgtar}")
-md5sums=('e62b50777478fe4dd624955cfd609fcc')
-replaces=('r-cran-bit')
+license=(GPL2 GPL3)
+depends=('r>=2.9.2')
+optdepends=(r-testthat r-roxygen2 r-knitr r-rmarkdown r-microbenchmark r-bit64 r-ff)
+source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+sha256sums=('e404841fbe4ebefe4ecd4392effe673a8c9fa05f97952c4ce6e2f6159bd2f168')
-build(){
- R CMD INSTALL ${_pkgtar} -l $srcdir
+build() {
+ R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
}
+
package() {
- install -d "$pkgdir/usr/lib/R/library"
- cp -r "$srcdir/$_cranname" "$pkgdir/usr/lib/R/library"
-}
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+}