summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2015-07-21 10:13:52 +0300
committerMantas Mikulėnas2015-07-21 10:13:52 +0300
commit7f712f7e7da4040db2e8c45ea88b80fe27785e60 (patch)
tree0bcdef6f5b791ac8f93d19bd121fd206c9ed9cc1
downloadaur-7f712f7e7da4040db2e8c45ea88b80fe27785e60.tar.gz
initial import
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD41
-rw-r--r--auth_kerb.conf25
-rw-r--r--mod_auth_kerb.patch11
-rw-r--r--mod_auth_kerb_compile.patch11
5 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3510e306f3b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mod_auth_kerb
+ pkgdesc = A Kerberos authentication module for the Apache Http Server
+ pkgver = 5.4
+ pkgrel = 4
+ url = http://sourceforge.net/projects/modauthkerb/files/mod_auth_kerb/mod_auth_kerb-5.4/mod_auth_kerb-5.4.tar.gz/download
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = apache>=2.0
+ depends = heimdal
+ source = http://downloads.sourceforge.net/project/modauthkerb/mod_auth_kerb/mod_auth_kerb-5.4/mod_auth_kerb-5.4.tar.gz
+ source = auth_kerb.conf
+ source = mod_auth_kerb.patch
+ source = mod_auth_kerb_compile.patch
+ md5sums = 642b81763ad3ca81dba359cb952da5e3
+ md5sums = 399f8ab44947ac79f23f718c4ca9a527
+ md5sums = 3a4ed51a6bfb949fc588148074e1df5a
+ md5sums = 051f97f87667c92db00f34d20404261d
+
+pkgname = mod_auth_kerb
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2eb68fe72d2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: Nahum Shalman <nshalman at elys dot com>
+# Maintainer: Brad Arrington <bradla8 at yahoo.com>
+
+pkgname=mod_auth_kerb
+pkgver=5.4
+pkgrel=4
+pkgdesc="A Kerberos authentication module for the Apache Http Server"
+arch=('i686' 'x86_64')
+#url="http://sourceforge.net/projects/mod_auth_kerb/"
+url="http://sourceforge.net/projects/modauthkerb/files/mod_auth_kerb/mod_auth_kerb-5.4/mod_auth_kerb-5.4.tar.gz/download"
+license=('custom')
+groups=()
+depends=('apache>=2.0' 'heimdal')
+makedepends=()
+optdepends=()
+conflicts=()
+replaces=()
+options=()
+install=
+source=(http://downloads.sourceforge.net/project/modauthkerb/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz auth_kerb.conf mod_auth_kerb.patch mod_auth_kerb_compile.patch)
+noextract=()
+md5sums=('642b81763ad3ca81dba359cb952da5e3'
+ '399f8ab44947ac79f23f718c4ca9a527'
+ '3a4ed51a6bfb949fc588148074e1df5a'
+ '051f97f87667c92db00f34d20404261d')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ #patch -p0 < $startdir/$pkgname.patch
+ patch -p1 < $startdir/mod_auth_kerb_compile.patch
+ ./configure --without-krb4 --with-apache=$startdir/pkg
+
+ mkdir -p $startdir/pkg/usr/lib/httpd/modules
+ mkdir -p $startdir/pkg/etc/httpd/conf
+ mkdir -p $startdir/pkg/usr/share/licenses/$pkgname/
+
+ make || return 1
+ install -m 755 src/.libs/$pkgname.so $startdir/pkg/usr/lib/httpd/modules || return 1
+ install -m 644 $startdir/src/auth_kerb.conf $startdir/pkg/etc/httpd/conf/auth_kerb.conf.sample || return 1
+ install -m 644 LICENSE $startdir/pkg/usr/share/licenses/$pkgname/ || return 1
+}
diff --git a/auth_kerb.conf b/auth_kerb.conf
new file mode 100644
index 000000000000..b59327011721
--- /dev/null
+++ b/auth_kerb.conf
@@ -0,0 +1,25 @@
+#
+# The mod_auth_kerb module implements Kerberos authentication over
+# HTTP, following the "Negotiate" protocol.
+#
+
+LoadModule auth_kerb_module modules/mod_auth_kerb.so
+
+#
+# Sample configuration: Kerberos authentication must only be
+# used over SSL to prevent replay attacks. The keytab file
+# configured must be readable only by the "apache" user, and
+# must contain service keys for "HTTP/www.example.com", where
+# "www.example.com" is the FQDN of this server.
+#
+
+#<Location /private>
+# SSLRequireSSL
+# AuthType Kerberos
+# AuthName "Kerberos Login"
+# KrbMethodNegotiate On
+# KrbMethodK5Passwd Off
+# KrbAuthRealms EXAMPLE.COM
+# Krb5KeyTab /etc/httpd/conf/keytab
+# require valid-user
+#</Location>
diff --git a/mod_auth_kerb.patch b/mod_auth_kerb.patch
new file mode 100644
index 000000000000..81e24f845c83
--- /dev/null
+++ b/mod_auth_kerb.patch
@@ -0,0 +1,11 @@
+--- Makefile.in 2008-12-02 09:07:10.000000000 -0500
++++ Makefile.in.good 2009-12-30 16:04:23.237700892 -0500
+@@ -13,7 +13,7 @@
+ all: src/mod_auth_kerb.so
+
+ src/mod_auth_kerb.so: src/mod_auth_kerb.c $(SPNEGO_SRCS)
+- ./apxs.sh "${CPPFLAGS}" "${LDFLAGS}" "${SPNEGO_SRCS}" "${APXS}" "-c" "src/mod_auth_kerb.c"
++ apxs -c ${CPPFLAGS} ${LDFLAGS} mod_auth_kerb.so
+
+ install:
+ ./apxs.sh "${CPPFLAGS}" "${LDFLAGS}" "${SPNEGO_SRCS}" "${APXS}" "-c -i" "src/mod_auth_kerb.c"
diff --git a/mod_auth_kerb_compile.patch b/mod_auth_kerb_compile.patch
new file mode 100644
index 000000000000..689cd4095480
--- /dev/null
+++ b/mod_auth_kerb_compile.patch
@@ -0,0 +1,11 @@
+diff -urN mod_auth_kerb-5.4/src/mod_auth_kerb.c mod_auth_kerb-5.4a/src/mod_auth_kerb.c
+--- mod_auth_kerb-5.4/src/mod_auth_kerb.c 2008-12-04 03:14:03.000000000 -0700
++++ mod_auth_kerb-5.4a/src/mod_auth_kerb.c 2011-01-25 17:35:31.466666669 -0700
+@@ -89,6 +89,7 @@
+ #include <krb5.h>
+ #ifdef HEIMDAL
+ # include <gssapi.h>
++# include <gssapi/gssapi_krb5.h>
+ #else
+ # include <gssapi/gssapi.h>
+ # include <gssapi/gssapi_generic.h>