summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaimar Bühmann2016-02-18 22:13:48 +0100
committerRaimar Bühmann2016-02-18 22:13:48 +0100
commit7f99b64d16ec545f23b25a0ac9e75bfbd67f7231 (patch)
tree16f20201fa3c912241562b5fd80e389a69c8a580
parentf75c0a52d2a143e0917aea57bbd7bbd863b63301 (diff)
downloadaur-7f99b64d16ec545f23b25a0ac9e75bfbd67f7231.tar.gz
set version 0.3.0 and add patch to fix creating turn message
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--fix-creating-turn-message-by-using-correct-size.patch25
3 files changed, 41 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90049fd13472..b713d0057e0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = anki-drive-sdk-git
pkgdesc = C implementation of message protocols and data parsing to communicate with Anki Drive vehicles
- pkgver = 0.2.0.r23.20141113
- pkgrel = 2
+ pkgver = 0.3.0.r26.20160218
+ pkgrel = 1
url = https://github.com/anki/drive-sdk
arch = i686
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = anki-drive-sdk-git
depends = readline
optdepends = bluez-utils: for command line tool hciconfig
source = anki-drive-sdk-git::git+https://github.com/anki/drive-sdk.git
+ source = fix-creating-turn-message-by-using-correct-size.patch
md5sums = SKIP
+ md5sums = dc52ebb3421760cb5b72d116a624ce16
pkgname = anki-drive-sdk-git
diff --git a/PKGBUILD b/PKGBUILD
index cbea78cb1035..ff68b17a20e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Raimar Bühmann <raimar _at_ buehmann _dot_ de>
pkgname=anki-drive-sdk-git
-pkgver=0.2.0.r23.20141113
-pkgrel=2
+pkgver=0.3.0.r26.20160218
+pkgrel=1
pkgdesc="C implementation of message protocols and data parsing to communicate with Anki Drive vehicles"
arch=('i686' 'x86_64')
url="https://github.com/anki/drive-sdk"
@@ -10,8 +10,12 @@ license=('Apache')
depends=('glib2' 'readline')
optdepends=('bluez-utils: for command line tool hciconfig')
makedepends=('cmake' 'gcc')
-source=("$pkgname::git+https://github.com/anki/drive-sdk.git")
-md5sums=('SKIP')
+source=(
+ "$pkgname::git+https://github.com/anki/drive-sdk.git"
+ 'fix-creating-turn-message-by-using-correct-size.patch'
+)
+md5sums=('SKIP'
+ 'dc52ebb3421760cb5b72d116a624ce16')
pkgver() {
# remove ".r*.*" from package version
_pkgverTriple=$(echo $pkgver | sed "s/\.r.*//g")
@@ -23,6 +27,10 @@ pkgver() {
# add ".r*.*" from package version
echo "$_pkgverTriple.r$_commitCount.$_commitTime"
}
+prepare() {
+ cd $pkgname
+ patch -Np1 -i ../fix-creating-turn-message-by-using-correct-size.patch
+}
build() {
cd "$pkgname"
mkdir -p build
diff --git a/fix-creating-turn-message-by-using-correct-size.patch b/fix-creating-turn-message-by-using-correct-size.patch
new file mode 100644
index 000000000000..44fc4067f3e0
--- /dev/null
+++ b/fix-creating-turn-message-by-using-correct-size.patch
@@ -0,0 +1,25 @@
+From badbe55edfa5fe85333559961270ad7d29536ceb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Raimar=20B=C3=BChmann?= <raimar _at_ buehmann _dot de>
+Date: Thu, 18 Feb 2016 22:01:44 +0100
+Subject: [PATCH] fix creating turn message by using correct size
+
+---
+ src/protocol.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/protocol.c b/src/protocol.c
+index 0c5f3eb..0c00133 100644
+--- a/src/protocol.c
++++ b/src/protocol.c
+@@ -192,7 +192,7 @@ uint8_t anki_vehicle_msg_turn(anki_vehicle_msg_t *msg,
+
+ anki_vehicle_msg_turn_t *m = (anki_vehicle_msg_turn_t *)msg;
+ memset(m, 0, sizeof(anki_vehicle_msg_turn_t));
+- m->size = ANKI_VEHICLE_MSG_BASE_SIZE;
++ m->size = ANKI_VEHICLE_MSG_C2V_TURN_SIZE;
+ m->msg_id = ANKI_VEHICLE_MSG_C2V_TURN;
+ m->type = (uint8_t)type;
+ m->trigger = (uint8_t)trigger;
+--
+2.7.1
+