summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTNE2022-05-21 02:31:19 +0200
committerTNE2022-05-21 02:31:19 +0200
commit7fc14f5a533cb54cdf06018f9d613653c23162db (patch)
treebe41ddfd6269d994c644d699059038b9e7522e13
parentb5872ba557c17572a6d92b22c73018685742e59e (diff)
downloadaur-7fc14f5a533cb54cdf06018f9d613653c23162db.tar.gz
515.43.04
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rw-r--r--mhwd-nvidia15
3 files changed, 21 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f6a11fb62a9..e071da5e4b18 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = mhwd-nvidia
pkgdesc = mhwd-nvidia pci id
- pkgver = 510.54
+ pkgver = 515.43.04
pkgrel = 1
url = https://garudalinux.org/
arch = any
- license = GPL2
+ license = custom
makedepends = nvidia-dkms
makedepends = nvidia-utils
provides = mhwd-nvidia
diff --git a/PKGBUILD b/PKGBUILD
index 2a071a3046db..f3ea4dc17fee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Contributer : Guinux <nuxgui@gmail.com>
pkgname=mhwd-nvidia
-pkgver=510.54
+pkgver=515.43.04
pkgrel=1
pkgdesc="mhwd-nvidia pci id"
arch=("any")
url="https://garudalinux.org/"
-license=('GPL2')
+license=('custom')
source=('mhwd-nvidia')
makedepends=('nvidia-dkms' 'nvidia-utils')
sha256sums=('738749f5ada14afac3085d10fac351c55d423674228eea1dae8e41b935d1497c')
@@ -21,6 +21,6 @@ package() {
/usr/share/doc/nvidia/README \
/usr/src/nvidia-$pkgver/nvidia/nv-kernel.o_binary \
> $pkgdir/var/lib/mhwd/ids/pci/nvidia.ids
- # add PCIID: 1b82 Nvidia Gforce 1070 Ti
- sed -i 's/1b81 1b84/1b81 1b82 1b84/g' $pkgdir/var/lib/mhwd/ids/pci/nvidia.ids
+
+ install -Dm644 /usr/share/licenses/nvidia-dkms/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/mhwd-nvidia b/mhwd-nvidia
index 2fb12362210c..65c344386287 100644
--- a/mhwd-nvidia
+++ b/mhwd-nvidia
@@ -1,4 +1,19 @@
#!/bin/sh
+
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+
set -e
# This is a nasty kluge, but it seems to work. Better check the output when