summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick José Pereira2016-10-28 21:45:16 -0200
committerPatrick José Pereira2016-10-28 21:49:16 -0200
commit7fc1d878a37bd8fd8cbfeba03ed8dfe16a36d43c (patch)
treeb073f5044f6104a790780ff615a3755697494e54
downloadaur-7fc1d878a37bd8fd8cbfeba03ed8dfe16a36d43c.tar.gz
Add first commit of vrep package
Signed-off-by: Patrick José Pereira <patrickelectric@gmail.com>
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD52
-rw-r--r--vrep.sh3
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ecf3131409f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = vrep
+ pkgdesc = V-REP is the Swiss army knife among robot simulators. V-REP is used for fast algorithm development, factory automation simulations, fast prototyping and verification, robotics related education, remote monitoring, safety double-checking, etc.
+ pkgver = 3_3_2
+ pkgrel = 0.1
+ epoch = 1
+ url = http://www.coppeliarobotics.com/index.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = LGPL
+ options = !strip
+ source = http://coppeliarobotics.com/V-REP_PRO_EDU_V3_3_2_64_Linux.tar.gz
+ source = vrep.sh
+ md5sums = 48a3688f940e25f542fed01525023fb1
+ md5sums = a5f75fcd3c08b1a8c93f74997006e5d5
+ source_i686 = http://coppeliarobotics.com/V-REP_PRO_EDU_V3_3_2_Linux.tar.gz
+ source_i686 = vrep.sh
+ md5sums_i686 = aadd01183e4f5ac819aacd996d5e5d8d
+ md5sums_i686 = a5f75fcd3c08b1a8c93f74997006e5d5
+
+pkgname = vrep
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..320884e568f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: patrickelectric <patrickelectric {a.t} gmail {d.o.t} com>
+
+pkgname=vrep
+pkgver=3_3_2
+pkgrel=0.1
+epoch=1
+pkgdesc="V-REP is the Swiss army knife among robot simulators.
+
+V-REP is used for fast algorithm development, factory automation simulations,
+fast prototyping and verification, robotics related education, remote monitoring,
+safety double-checking, etc."
+arch=("i686" "x86_64")
+url="http://www.coppeliarobotics.com/index.html"
+license=("GPL" "LGPL")
+#depends=('')
+makedepends=('')
+#optdepends=('')
+options=(!strip)
+install=""
+source=("http://coppeliarobotics.com/V-REP_PRO_EDU_V${pkgver}_64_Linux.tar.gz"
+ "vrep.sh")
+source_i686=("http://coppeliarobotics.com/V-REP_PRO_EDU_V${pkgver}_Linux.tar.gz"
+ "vrep.sh")
+md5sums=('48a3688f940e25f542fed01525023fb1'
+ 'a5f75fcd3c08b1a8c93f74997006e5d5')
+md5sums_i686=('aadd01183e4f5ac819aacd996d5e5d8d'
+ 'a5f75fcd3c08b1a8c93f74997006e5d5')
+prepare()
+{
+ echo "nothing to prepare"
+}
+
+build() {
+ echo "nothing to build"
+}
+
+package() {
+ # Create wrapper for java8 + buider and documentation symlink
+ install -Dm755 "vrep.sh" "${pkgdir}/usr/bin/vrep"
+
+ if [ "$CARCH" = x86_64 ]
+ then
+ cd "${srcdir}/V-REP_PRO_EDU_V${pkgver}_64_Linux"
+ else
+ cd "${srcdir}/V-REP_PRO_EDU_V${pkgver}_Linux"
+ fi
+
+ # Copy the whole thing
+ install -dm766 "${pkgdir}/usr/share/vrep"
+ cp -pr . "${pkgdir}/usr/share/vrep"
+ chmod -R 777 "${pkgdir}/usr/share/vrep"
+}
diff --git a/vrep.sh b/vrep.sh
new file mode 100644
index 000000000000..21f051b45f4b
--- /dev/null
+++ b/vrep.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec /usr/share/vrep/vrep.sh "$@" \ No newline at end of file