summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2023-10-20 15:41:50 +0200
committerlarchunix2023-10-20 15:41:50 +0200
commit7fca5f05ed8b1ba97efd8cf1887241a869b44968 (patch)
tree6d409fd4ba1c54d58d3e4e7a89bd67d3a8fd2736
parent823da3695731ac6af4616b9a30c310b6a28a29d2 (diff)
downloadaur-7fca5f05ed8b1ba97efd8cf1887241a869b44968.tar.gz
Update to upstream release 4.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef93870b7187..c1155d67ae53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dnf-plugins-extras
pkgdesc = Extras DNF Plugins
- pkgver = 4.1.0
+ pkgver = 4.1.1
pkgrel = 1
url = https://github.com/rpm-software-management/dnf-plugins-extras
arch = any
@@ -18,7 +18,7 @@ pkgbase = dnf-plugins-extras
optdepends = tracer: for tracer plugin
backup = etc/dnf/plugins/rpmconf.conf
backup = etc/dnf/plugins/torproxy.conf
- source = https://github.com/rpm-software-management/dnf-plugins-extras/archive/4.1.0/dnf-plugins-extras-4.1.0.tar.gz
- sha256sums = f48b19694df17573e6743671d8dec4baa3a46822352370ed77af06d9af7b632c
+ source = https://github.com/rpm-software-management/dnf-plugins-extras/archive/4.1.1/dnf-plugins-extras-4.1.1.tar.gz
+ sha256sums = 092ba298d0c364670939a8680bdf365f344d6270b14cf38cd93a395fdf20ae71
pkgname = dnf-plugins-extras
diff --git a/PKGBUILD b/PKGBUILD
index b4ee8b4959d7..8f7d897b5fae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=dnf-plugins-extras
-pkgver=4.1.0
+pkgver=4.1.1
pkgrel=1
pkgdesc="Extras DNF Plugins"
arch=('any')
@@ -16,7 +16,7 @@ optdepends=('python-dbus: for snapper plugin'
backup=('etc/dnf/plugins/rpmconf.conf'
'etc/dnf/plugins/torproxy.conf')
source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-sha256sums=('f48b19694df17573e6743671d8dec4baa3a46822352370ed77af06d9af7b632c')
+sha256sums=('092ba298d0c364670939a8680bdf365f344d6270b14cf38cd93a395fdf20ae71')
prepare() {
cd "$pkgname-$pkgver"
@@ -33,8 +33,8 @@ build() {
cmake -B build \
-DCMAKE_INSTALL_PREFIX=/usr
- make -C build
- make -C build doc-man
+ cmake --build build
+ cmake --build build --target doc-man
}
# Tests seem to need a minimal RPM database on the system
@@ -47,7 +47,7 @@ build() {
package() {
cd "$pkgname-$pkgver"
- make -C build DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
install -Dp -m644 README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"
}