summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormorganamilo2021-06-18 12:55:13 +0100
committermorganamilo2021-06-18 12:55:55 +0100
commit7fd203df97e4e22b262165d88217084c63219457 (patch)
tree8488fe1392d6ac2b5044f8b960836f713d7dd90f
parentab29a2f9e51099c29ce1215313e14a0ab81b64fd (diff)
downloadaur-7fd203df97e4e22b262165d88217084c63219457.tar.gz
update pkgbuild
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7e1fe3d6c6b..871b1ceb9e98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = putils-git
pkgdesc = Utilities for working with pipes
- pkgver = r3.1e54e08
+ pkgver = r3.7f4ccee
pkgrel = 1
url = https://github.com/Morganamilo/putils
arch = x86_64
@@ -8,10 +8,10 @@ pkgbase = putils-git
makedepends = git
makedepends = go
makedepends = asciidoc
+ depends = glibc
provides = putils
conflicts = putils
source = git+https://github.com/Morganamilo/putils
md5sums = SKIP
pkgname = putils-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1217f723b464..00513b135a07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
-# Maintainer: Anna <morganamilo@gmail.com>
+# Maintainer: Morganamilo <morganamilo@gmail.com>
_pkgname=putils
pkgname=putils-git
-pkgver=r3.1e54e08
+pkgver=r3.7f4ccee
pkgrel=1
pkgdesc="Utilities for working with pipes"
arch=(x86_64)
url="https://github.com/Morganamilo/putils"
license=('GPL3')
+depends=(glibc)
makedepends=(git go asciidoc)
provides=(putils)
conflicts=(putils)
@@ -14,6 +15,12 @@ source=("git+https://github.com/Morganamilo/putils")
md5sums=('SKIP')
build() {
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+
cd "$_pkgname"
make PREFIX=/usr DESTDIR="$pkgdir" all
}