summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvitalyr2022-03-01 00:05:21 +0800
committervitalyr2022-03-01 00:05:21 +0800
commit7ff8c59ad28a37ea83e4f8f9573a8c578381b131 (patch)
treebe72f67eb6a1d12e3f6907d6f23eb9178a267989
parent481500b6fc8b74b7dc6d8f3158faf2d716970a5c (diff)
downloadaur-7ff8c59ad28a37ea83e4f8f9573a8c578381b131.tar.gz
Drop dependency `libgccjit` since it's included in `gcc` now
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD12
2 files changed, 3 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71d9f72107d7..e259bcc6da1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,7 +17,6 @@ pkgbase = emacs-native-comp-git-enhanced
depends = libxml2
depends = jansson
depends = harfbuzz
- depends = libgccjit
depends = gtk3
depends = libjpeg-turbo
depends = giflib
diff --git a/PKGBUILD b/PKGBUILD
index 7aaa18d7476c..c895690b4e07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,7 +48,9 @@ MOLD="YES" # Use the mold linker.
# This is the default linker.
# Notice that it will always be used.
-JIT="YES" # Enable native just-in-time compilation. libgccjit is in AUR.
+JIT="YES" # Enable native just-in-time compilation. Use libgccjit,
+ # which is already included in Arch's gcc package.
+ #
# This compiles only performance critical elisp files.
#
# To compile all elisp on demand, add
@@ -164,14 +166,6 @@ if [[ $CLANG == "YES" ]]; then
fi
fi
-if [[ $JIT == "YES" ]]; then
- if [[ $CLI == "YES" ]]; then
- depends_nox+=( 'libgccjit' );
- else
- depends+=( 'libgccjit' );
- fi
-fi
-
if [[ $CLI == "YES" ]]; then
depends=("${depends_nox[@]}");
elif [[ $NOTKIT == "YES" ]]; then