summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMubashshir2024-03-12 23:30:59 +0600
committerMubashshir2024-03-12 23:30:59 +0600
commit7ffed9182ebcc977c2fce3948df394b1518c3c71 (patch)
treeeaf81febe54b44affae0700b5705d767177619a0
parenta38ad48525da87550bdead396e99a6f6c1ef811f (diff)
downloadaur-7ffed9182ebcc977c2fce3948df394b1518c3c71.tar.gz
lib32-gst-bad-ugly: Fix gst-base disabling patch
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Allow-disabling-gstreamer.patch43
-rw-r--r--PKGBUILD4
3 files changed, 23 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9be8b2a93e3..e2abb3a4ece7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = lib32-gst-bad-ugly
pkgdesc = Multimedia graph framework (32-bit)
pkgver = 1.24.0
- pkgrel = 1
+ pkgrel = 2
url = https://gstreamer.freedesktop.org/
arch = x86_64
license = LGPL
@@ -85,7 +85,7 @@ pkgbase = lib32-gst-bad-ugly
source = 0002-HACK-meson-Disable-broken-tests.patch
validpgpkeys = D637032E45B8C6585B9456565D2EEE6F6F349D7C
sha256sums = SKIP
- sha256sums = 0cfce6cad2d9fc55fe36e4ca48ec8aa33106cc1f778ddf0ae47362d230e5539b
+ sha256sums = dd928acaa15670225059b36ca5a29d808feba3855700f9b36128a2e55a335a50
sha256sums = 951edc965cce062b3a08048297c9d66ff264eed5d8e884170706e4854c9f92df
pkgname = lib32-gst-plugins-ugly
diff --git a/0001-Allow-disabling-gstreamer.patch b/0001-Allow-disabling-gstreamer.patch
index 74248616c6dd..a3f7d1b9db67 100644
--- a/0001-Allow-disabling-gstreamer.patch
+++ b/0001-Allow-disabling-gstreamer.patch
@@ -1,38 +1,33 @@
diff --git a/meson.build b/meson.build
-index 1c33e18084..8612d88e04 100644
+index db32a57fba..67a208d517 100644
--- a/meson.build
+++ b/meson.build
-@@ -85,7 +85,7 @@ endif
+@@ -105,7 +105,7 @@ gst_python_option = get_option('python').disable_if(get_option('introspection').
# Ordered list of subprojects (dict has no ordering guarantees)
subprojects = [
-- ['gstreamer', {'build-hotdoc': true, 'subproject_options': tools_option}],
-+ ['gstreamer', {'option': get_option('gstreamer'), 'build-hotdoc': true, 'subproject_options': tools_option}],
+- ['gstreamer', {'build-hotdoc': true, 'subproject_options': building_full_options}],
++ ['gstreamer', {'option': get_option('gstreamer'), 'build-hotdoc': true, 'subproject_options': building_full_options}],
['gst-plugins-base', {'option': get_option('base'), 'build-hotdoc': true}],
['gst-plugins-good', {'option': get_option('good'), 'build-hotdoc': true}],
- ['libnice', { 'option': get_option('libnice'), 'match_gst_version': false}],
-diff --git a/meson_options.txt b/meson_options.txt
-index 49c20a0705..66ff309b1f 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -3,6 +3,7 @@ option('python', type : 'feature', value : 'auto')
- option('libav', type : 'feature', value : 'auto')
- option('libnice', type : 'feature', value : 'auto')
- option('base', type : 'feature', value : 'enabled')
-+option('gstreamer', type : 'feature', value : 'enabled')
- option('good', type : 'feature', value : 'enabled')
- option('ugly', type : 'feature', value : 'auto')
- option('bad', type : 'feature', value : 'auto')
-diff --git a/meson.build b/meson.build
-index 8612d88e04..7fa8b5724d 100644
---- a/meson.build
-+++ b/meson.build
-@@ -162,7 +162,7 @@ foreach sp : subprojects
+ ['libnice', { 'option': get_option('libnice'), 'match_gst_version': false, 'subproject_options': libnice_options}],
+@@ -192,7 +192,7 @@ foreach sp : subprojects
subproj = subproject(project_name, required: is_required, default_options: default_options)
endif
-- if project_name == 'gst-plugins-base'
-+ if project_name == 'gst-plugins-base' and not is_required.disabled()
+- if project_name == 'gst-plugins-base' and subproj.found()
++ if project_name == 'gst-plugins-base' and subproj.found() and not is_required.disabled()
gst_base_orc_req = subproj.get_variable('orc_req', '')
if gst_base_orc_req != orc_req
error('orc_req is "@0@" but it should be "@1@" from subprojects/gst-plugins-base/meson.build'
+diff --git a/meson_options.txt b/meson_options.txt
+index 91b1449f18..39152be149 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,5 +1,6 @@
+ # GStreamer subprojects
+ option('base', type : 'feature', value : 'enabled')
++option('gstreamer', type : 'feature', value : 'enabled')
+ option('good', type : 'feature', value : 'enabled')
+ option('ugly', type : 'feature', value : 'enabled')
+ option('bad', type : 'feature', value : 'enabled')
diff --git a/PKGBUILD b/PKGBUILD
index 12a693d15ac4..03fef8029216 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,7 +16,7 @@ pkgname=(lib32-gst-plugins-ugly)
readonly LIB32GST_DISABLE_{AV,BAD}
pkgver=1.24.0
-pkgrel=1
+pkgrel=2
pkgdesc="Multimedia graph framework (32-bit)"
url="https://gstreamer.freedesktop.org/"
arch=(x86_64)
@@ -97,7 +97,7 @@ source=(
0002-HACK-meson-Disable-broken-tests.patch
)
sha256sums=('SKIP'
- '0cfce6cad2d9fc55fe36e4ca48ec8aa33106cc1f778ddf0ae47362d230e5539b'
+ 'dd928acaa15670225059b36ca5a29d808feba3855700f9b36128a2e55a335a50'
'951edc965cce062b3a08048297c9d66ff264eed5d8e884170706e4854c9f92df')
validpgpkeys=(D637032E45B8C6585B9456565D2EEE6F6F349D7C) # Tim Müller <tim@gstreamer-foundation.org>