summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederic Bezies2018-11-28 08:44:31 +0100
committerFrederic Bezies2018-11-28 08:44:31 +0100
commit802fa24fb255cc672ecabd0c56381e444b68249c (patch)
treeddd8fc145f1d6b6600a034de4fb7265445a49271
parent5596dd8e04955647fe190b7b6fe200c31dbc8099 (diff)
downloadaur-802fa24fb255cc672ecabd0c56381e444b68249c.tar.gz
Fixing PKGBUILD
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD47
2 files changed, 2 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 548ec99c9c2e..4fe5c62996e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = watchman-git
pkgdesc = Watches files and records, or triggers actions, when they change.
pkgver = v4.9.0.r535.gc12ab4ca
- pkgrel = 1
+ pkgrel = 2
url = https://facebook.github.io/watchman/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3e1ae4048142..ae2da1312b4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=watchman-git
_gitname=watchman
pkgver=v4.9.0.r535.gc12ab4ca
-pkgrel=1
+pkgrel=2
pkgdesc='Watches files and records, or triggers actions, when they change.'
arch=('i686' 'x86_64')
url='https://facebook.github.io/watchman/'
@@ -47,48 +47,3 @@ package() {
# compile-command: "makepkg -sm && mksrcinfo"
# End:# Maintainer: Mario Rodas <marsam@users.noreply.github.com>
-pkgname=watchman-git
-_gitname=watchman
-pkgver=v4.9.0.r535.gc12ab4ca
-pkgrel=1
-pkgdesc='Watches files and records, or triggers actions, when they change.'
-arch=('i686' 'x86_64')
-url='https://facebook.github.io/watchman/'
-license=('Apache')
-depends=('pcre' 'openssl')
-makedepends=('git')
-conflicts=('watchman')
-options=('!libtool' 'staticlibs')
-provides=()
-source=("${_gitname}::git+https://github.com/facebook/watchman.git")
-sha256sums=('SKIP')
-
-pkgver() {
- cd "${srcdir}/${_gitname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-build() {
- cd "${srcdir}/${_gitname}"
- ./autogen.sh
- ./configure --prefix=/usr \
- --with-pcre \
- --without-python \
- --enable-statedir="/var/lib/${_gitname}"\
- --enable-lenient # to work around a gcc 8.x bug ; https://github.com/facebook/watchman/issues/638
- make
-}
-
-check() {
- cd "${srcdir}/${_gitname}"
- make check
-}
-
-package() {
- cd "${srcdir}/${_gitname}"
- make DESTDIR="${pkgdir}" install
-}
-
-# Local Variables:
-# compile-command: "makepkg -sm && mksrcinfo"
-# End: