summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStelios Tsampas2023-09-29 20:55:27 +0300
committerStelios Tsampas2023-09-29 20:55:27 +0300
commit807fe613b876b524507ffbe6d38cf544aeada41b (patch)
tree7e676a4a3456e8582eb6e23b0766ee7f574efd74
parent8caa37b4c31aac8a6f639b4b5e7a308e717f52b6 (diff)
downloadaur-807fe613b876b524507ffbe6d38cf544aeada41b.tar.gz
[ppsspp-git] Update submodules
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD57
-rw-r--r--PKGBUILD.testing54
3 files changed, 38 insertions, 97 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41e8c2a58490..b0e651a3fd6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ppsspp-git
pkgdesc = A PSP emulator written in C++
- pkgver = 1.15.4.r1211.308e983a99
+ pkgver = 1.16.5.r44.aa411c2f09
pkgrel = 1
url = https://www.ppsspp.org/
arch = x86_64
@@ -24,31 +24,9 @@ pkgbase = ppsspp-git
makedepends = zlib
options = !lto
source = git+https://github.com/hrydgard/ppsspp.git
- source = git+https://github.com/Kingcom/armips.git
- source = git+https://github.com/discordapp/discord-rpc.git
- source = git+https://github.com/hrydgard/ppsspp-ffmpeg.git
- source = armips-filesystem::git+https://github.com/Kingcom/filesystem.git
- source = git+https://github.com/google/cpu_features.git
- source = git+https://github.com/KhronosGroup/glslang.git
- source = git+https://github.com/hrydgard/ppsspp-lang.git
- source = ppsspp-miniupnp::git+https://github.com/hrydgard/miniupnp.git
- source = git+https://github.com/Tencent/rapidjson.git
- source = git+https://github.com/KhronosGroup/SPIRV-Cross.git
- source = git+https://github.com/RetroAchievements/rcheevos.git
source = ppsspp-sdl.desktop
source = ppsspp-qt.desktop
b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
- b2sums = SKIP
b2sums = c6bcdfedee866dfdcc82a8c333c31ff73ed0beec65b63acec8bc8186383c0bc9f0912f21bb9715b665e8dc1793b1a85599761f9037856fa54ad8aa3bfdbfd468
b2sums = 328e2ba47b78d242b0ec6ba6bfa039c77a36d1ef7246e5c2c2432d8e976e9360baf505eb05f48408ede1a30545cbbb7f875bf5ebd0252cef35523d449b8254a0
diff --git a/PKGBUILD b/PKGBUILD
index 306b88ecb65e..3e7291927e28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ pkgname=(
ppsspp-git
ppsspp-assets-git
)
-pkgver=1.15.4.r1211.308e983a99
+pkgver=1.16.5.r44.aa411c2f09
pkgrel=1
pkgdesc='A PSP emulator written in C++'
arch=(x86_64 aarch64)
@@ -38,32 +38,10 @@ makedepends=(
options=(!lto)
source=(
git+https://github.com/hrydgard/ppsspp.git
- git+https://github.com/Kingcom/armips.git
- git+https://github.com/discordapp/discord-rpc.git
- git+https://github.com/hrydgard/ppsspp-ffmpeg.git
- armips-filesystem::git+https://github.com/Kingcom/filesystem.git
- git+https://github.com/google/cpu_features.git
- git+https://github.com/KhronosGroup/glslang.git
- git+https://github.com/hrydgard/ppsspp-lang.git
- ppsspp-miniupnp::git+https://github.com/hrydgard/miniupnp.git
- git+https://github.com/Tencent/rapidjson.git
- git+https://github.com/KhronosGroup/SPIRV-Cross.git
- git+https://github.com/RetroAchievements/rcheevos.git
ppsspp-sdl.desktop
ppsspp-qt.desktop
)
b2sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'c6bcdfedee866dfdcc82a8c333c31ff73ed0beec65b63acec8bc8186383c0bc9f0912f21bb9715b665e8dc1793b1a85599761f9037856fa54ad8aa3bfdbfd468'
'328e2ba47b78d242b0ec6ba6bfa039c77a36d1ef7246e5c2c2432d8e976e9360baf505eb05f48408ede1a30545cbbb7f875bf5ebd0252cef35523d449b8254a0')
@@ -74,21 +52,24 @@ pkgver() {
prepare() {
cd ppsspp
- for submodule in assets/lang ext/miniupnp ffmpeg; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
- git -c protocol.file.allow=always submodule update ${submodule}
- done
- for submodule in ext/{armips,cpu_features,discord-rpc,glslang,rapidjson,SPIRV-Cross,rcheevos}; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url ../${submodule#*/}
- git -c protocol.file.allow=always submodule update ${submodule}
- done
- cd ext/armips
- for submodule in ext/filesystem; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url ../../../armips-${submodule#*/}
- git -c protocol.file.allow=always submodule update ${submodule}
+ _ppsspp_submodules=(
+ ffmpeg
+ assets/lang
+ ext/miniupnp
+ ext/armips
+ ext/cpu_features
+ ext/discord-rpc
+ ext/glslang
+ ext/rapidjson
+ ext/SPIRV-Cross
+ ext/rcheevos
+ ext/naett
+ ext/libchdr
+ )
+ # Explicitly set origin URL for submodules using relative paths
+ git remote set-url origin https://github.com/hrydgard/ppsspp.git
+ for path in ${_ppsspp_submodules[@]}; do
+ git submodule update --init --filter=tree:0 --recursive "$path"
done
}
diff --git a/PKGBUILD.testing b/PKGBUILD.testing
index 2319a3c49701..ad7959dd1565 100644
--- a/PKGBUILD.testing
+++ b/PKGBUILD.testing
@@ -11,7 +11,7 @@ pkgname=(
ppsspp-git
ppsspp-assets-git
)
-pkgver=1.15.4.r1211.308e983a99
+pkgver=1.16.5.r44.aa411c2f09
pkgrel=1
_ffver=3.0.12
pkgdesc='A PSP emulator written in C++'
@@ -39,17 +39,7 @@ makedepends=(
options=(!lto)
source=(
git+https://github.com/hrydgard/ppsspp.git
- git+https://github.com/Kingcom/armips.git
- git+https://github.com/discordapp/discord-rpc.git
https://ffmpeg.org/releases/ffmpeg-$_ffver.tar.xz
- armips-filesystem::git+https://github.com/Kingcom/filesystem.git
- git+https://github.com/google/cpu_features.git
- git+https://github.com/KhronosGroup/glslang.git
- git+https://github.com/hrydgard/ppsspp-lang.git
- ppsspp-miniupnp::git+https://github.com/hrydgard/miniupnp.git
- git+https://github.com/Tencent/rapidjson.git
- git+https://github.com/KhronosGroup/SPIRV-Cross.git
- git+https://github.com/RetroAchievements/rcheevos.git
ppsspp-sdl.desktop
ppsspp-qt.desktop
)
@@ -57,17 +47,7 @@ source_x86_64=(
ppsspp-ffmpeg_x86-64.sh::https://raw.githubusercontent.com/hrydgard/ppsspp-ffmpeg/master/linux_x86-64.sh
)
b2sums=('SKIP'
- 'SKIP'
- 'SKIP'
'e978c76cdab638d4bf2718e0ec58fb0d4c7c4017d3100de76460fc8b148cb899066dbe92680aad19f7bd60c7c8924d966fcee22a53133be695ac8352a6ed01cc'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'c6bcdfedee866dfdcc82a8c333c31ff73ed0beec65b63acec8bc8186383c0bc9f0912f21bb9715b665e8dc1793b1a85599761f9037856fa54ad8aa3bfdbfd468'
'328e2ba47b78d242b0ec6ba6bfa039c77a36d1ef7246e5c2c2432d8e976e9360baf505eb05f48408ede1a30545cbbb7f875bf5ebd0252cef35523d449b8254a0')
b2sums_x86_64=(
@@ -86,21 +66,23 @@ prepare() {
cp -r "$srcdir"/ffmpeg-$_ffver ffmpeg
cp "$srcdir"/ppsspp-ffmpeg_x86_64.sh ffmpeg/
chmod u+x ffmpeg/ppsspp-ffmpeg_x86_64.sh
- for submodule in assets/lang ext/miniupnp; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url ../ppsspp-${submodule#*/}
- git -c protocol.file.allow=always submodule update ${submodule}
- done
- for submodule in ext/{armips,cpu_features,discord-rpc,glslang,rapidjson,SPIRV-Cross,rcheevos}; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url ../${submodule#*/}
- git -c protocol.file.allow=always submodule update ${submodule}
- done
- cd ext/armips
- for submodule in ext/filesystem; do
- git submodule init ${submodule}
- git config submodule.${submodule}.url ../../../armips-${submodule#*/}
- git -c protocol.file.allow=always submodule update ${submodule}
+ _ppsspp_submodules=(
+ assets/lang
+ ext/miniupnp
+ ext/armips
+ ext/cpu_features
+ ext/discord-rpc
+ ext/glslang
+ ext/rapidjson
+ ext/SPIRV-Cross
+ ext/rcheevos
+ ext/naett
+ ext/libchdr
+ )
+ # Explicitly set origin URL for submodules using relative paths
+ git remote set-url origin https://github.com/hrydgard/ppsspp.git
+ for path in ${_ppsspp_submodules[@]}; do
+ git submodule update --init --filter=tree:0 --recursive "$path"
done
}