summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorf0x2020-04-12 20:05:33 +0200
committerf0x2020-04-12 20:05:33 +0200
commit8099b4e3b612102dbe0ac5b969219694bd1c2721 (patch)
tree8478a72842d650a793ab52e56c5c249f0a95299d
downloadaur-8099b4e3b612102dbe0ac5b969219694bd1c2721.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD46
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76ee5ff20a61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = hikari-darcs
+ pkgdesc = Stacking Wayland compositor with additional tiling capabilities, heavily inspired by the Calm Window manager (cwm)
+ pkgver = 1.0.2.20200412091748
+ pkgrel = 1
+ epoch = 1
+ url = https://hikari.acmelabs.space
+ arch = x86_64
+ license = BSD-2-Clause
+ makedepends = darcs
+ makedepends = bmake
+ makedepends = pandoc
+ depends = wlroots
+ depends = cairo
+ depends = pango
+ depends = xorg-server-xwayland
+ depends = libucl-git
+ provides = hikari
+ conflicts = hikari
+
+pkgname = hikari-darcs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..920e6e04764b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: f0x <aur at cthu dot lu>
+
+pkgname=hikari-darcs
+pkgver=1.0.2.20200412091748
+pkgrel=1
+epoch=1
+pkgdesc='Stacking Wayland compositor with additional tiling capabilities, heavily inspired by the Calm Window manager (cwm)'
+url='https://hikari.acmelabs.space'
+license=('BSD-2-Clause')
+arch=('x86_64')
+makedepends=('darcs' 'bmake' 'pandoc')
+depends=('wlroots' 'cairo' 'pango' 'xorg-server-xwayland' 'libucl-git')
+provides=('hikari')
+conflicts=('hikari')
+source=()
+
+_darcsmod="hikari"
+_darcstrunk="https://hub.darcs.net/raichoo"
+
+pkgver(){
+ cd ${srcdir}/$_darcsmod
+ lastver=$(darcs show tags | head -n1)
+ timestamp=$(darcs log -n 1 --xml-output | grep -oP "(?<=date=')\d+")
+ echo $lastver.$timestamp
+}
+
+build(){
+ cd ${srcdir}
+ if [[ -d ${srcdir}/$_darcsmod/_darcs ]]
+ then
+ msg "Retrieving missing patches"
+ cd $_darcsmod
+ darcs pull -a $_darcstrunk/$_darcsmod
+ else
+ msg "Retrieving complete sources"
+ darcs get --set-scripts-executable $_darcstrunk/$_darcsmod
+ cd $_darcsmod
+ fi
+ bmake WITH_POSIX_C_SOURCE=YES WITH_XWAYLAND=YES WITH_SCREENCOPY=YES WITH_GAMMACONTROL=YES WITH_LAYERSHELL=YES
+}
+
+package() {
+ cd "$srcdir/$_darcsmod"
+ bmake PREFIX="${pkgdir}"/usr ETC_PREFIX="${pkgdir}"/etc install
+}
+