summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2017-02-11 14:15:20 +0100
committerStefan Husmann2017-02-11 14:15:20 +0100
commit80a27dc4a9b5287e731d2ed596ffcee6299a4d7d (patch)
tree012dce8c2033e4a558f0d8a9216f762879c936ed
parenta82eee3fd64ec46436363daa814dfdc13ef27379 (diff)
downloadaur-80a27dc4a9b5287e731d2ed596ffcee6299a4d7d.tar.gz
adopted, cosmetic changes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD17
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 63d893105f63..8be20c636dbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = emacs-yaml-mode
pkgdesc = Emacs major mode for editing files in the YAML data serialization format
pkgver = 0.0.13
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/yoshiki/yaml-mode
install = emacs-yaml-mode.install
arch = any
license = GPL
depends = emacs
- source = https://github.com/yoshiki/yaml-mode/archive/v0.0.13.tar.gz
+ source = emacs-yaml-mode-0.0.13.taz.gz::https://github.com/yoshiki/yaml-mode/archive/v0.0.13.tar.gz
md5sums = 22a94319ba03a94578dfdfae11f8b5ae
pkgname = emacs-yaml-mode
diff --git a/PKGBUILD b/PKGBUILD
index 10bb4973c00b..96530f1a81fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,27 @@
# Maintainer: Olivier Galibert <galibert@pobox.com>
# Contributor: Philip Mueller <mail at philip.in-aachen dot net>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
pkgname=emacs-yaml-mode
pkgver=0.0.13
-pkgrel=1
+pkgrel=2
pkgdesc="Emacs major mode for editing files in the YAML data serialization format"
arch=('any')
url="https://github.com/yoshiki/yaml-mode"
license=('GPL')
-groups=()
depends=('emacs')
install=emacs-yaml-mode.install
-source=(https://github.com/yoshiki/yaml-mode/archive/v$pkgver.tar.gz)
+source=("$pkgname-$pkgver.taz.gz::https://github.com/yoshiki/${pkgname#emacs-}/archive/v$pkgver.tar.gz")
md5sums=('22a94319ba03a94578dfdfae11f8b5ae')
+build() {
+ cd ${pkgname#emacs-}-$pkgver
+ emacs -batch -q -f batch-byte-compile ${pkgname#emacs-}.el
+}
+
package() {
- cd $srcdir/yaml-mode-$pkgver
+ cd ${pkgname#emacs-}-$pkgver
# Install the mode for Emacs
- install -D -m644 yaml-mode.el $pkgdir/usr/share/emacs/site-lisp/yaml-mode.el
+ install -D -m644 ${pkgname#emacs-}.el $pkgdir/usr/share/emacs/site-lisp/${pkgname#emacs-}.el
+ install -D -m644 ${pkgname#emacs-}.elc $pkgdir/usr/share/emacs/site-lisp/${pkgname#emacs-}.elc
}