summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-08-01 15:59:18 -0400
committerJean Lucas2018-08-01 15:59:18 -0400
commit80d148e02f18f11cc9137532b23b49c770b8c7cf (patch)
tree643811a88fd1edcc2d426ab02603f0f5037cb569
downloadaur-80d148e02f18f11cc9137532b23b49c770b8c7cf.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e40c1d10be01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Wed Aug 1 19:59:05 UTC 2018
+pkgbase = taskbook
+ pkgdesc = Tasks, boards & notes for the command-line habitat
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/klauscfhq/taskbook
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ conflicts = taskbook-git
+ source = https://github.com/klauscfhq/taskbook/archive/v0.1.1.tar.gz
+ sha512sums = 5390f75890167ed18adcbab8af7763411ff7e66393b476928e24b0ae987dd2bde2e4ac68b69487b287d1f21abcc05fc22507156b91e4b03c2cbee0dbfbcadfb1
+
+pkgname = taskbook
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8c983f1c46ca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=taskbook
+pkgver=0.1.1
+pkgrel=1
+pkgdesc='Tasks, boards & notes for the command-line habitat'
+arch=(any)
+url=https://github.com/klauscfhq/taskbook
+license=(MIT)
+depends=(nodejs)
+makedepends=(npm)
+conflicts=(taskbook-git)
+source=($url/archive/v$pkgver.tar.gz)
+sha512sums=(5390f75890167ed18adcbab8af7763411ff7e66393b476928e24b0ae987dd2bde2e4ac68b69487b287d1f21abcc05fc22507156b91e4b03c2cbee0dbfbcadfb1)
+
+build() {
+ cd taskbook-$pkgver
+ npm install
+}
+
+package() {
+ install -d "$pkgdir"/usr/{lib/node_modules,bin}
+ cp -a taskbook-$pkgver "$pkgdir"/usr/lib/node_modules/taskbook
+ chmod +x "$pkgdir"/usr/lib/node_modules/taskbook/cli.js
+ ln -s /usr/lib/node_modules/taskbook/cli.js "$pkgdir"/usr/bin/taskbook
+ install -Dm 644 taskbook-$pkgver/license.md "$pkgdir"/usr/share/licenses/taskbook/LICENSE
+}