summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavier C. Llano2023-12-08 08:19:04 -0500
committerXavier C. Llano2023-12-08 08:19:04 -0500
commit80ded39dc07009fbe0ed7a1b8ce3c41a59fd8447 (patch)
treedfab37792051fc8295901f42a8cdf85e20796e4a
parent7e097f9c114d264515bad9f5ddee76538e0abdd3 (diff)
downloadaur-80ded39dc07009fbe0ed7a1b8ce3c41a59fd8447.tar.gz
Fix mozillavpn.install, and other minor fixes
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--mozillavpn.install10
3 files changed, 18 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94de57846162..f912af5710ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mozillavpn
pkgdesc = A fast, secure and easy to use VPN. Built by the makers of Firefox.
pkgver = 2.19.0
- pkgrel = 1
+ pkgrel = 2
url = https://mozilla.org/products/vpn
install = mozillavpn.install
arch = x86_64
@@ -36,6 +36,8 @@ pkgbase = mozillavpn
optdepends = qt6-wayland: for Wayland support
options = !lto
source = https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/2.19.0-mantic1/mozillavpn_2.19.0.orig.tar.gz
+ source = mozillavpn.install
sha256sums = 36754d1f0e2f3ff5b08cecf691b7e158981356dc53b55152d93925f1b4d87e03
+ sha256sums = bba558c169389be05ba37d0565ca94ad43b1fdb94e137327af0e0e5229e66227
pkgname = mozillavpn
diff --git a/PKGBUILD b/PKGBUILD
index 2f9596dfb8fc..bc25f5702f7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,14 @@
-# XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Maintainer XavierCLL <xavier.corredor.llano (a) gmail.com>
+# Contributor: Utsav <aur (a) utsav2 [.] dev>
+# Contributor: Tavian Barnes <tavianator@tavianator.com>
+# Contributor: jhorcl
+# Contributor: flbzh <frederic_lebouc (a) yahoo.fr>
+# Contributor: RafaƂ Wyszomirski <m6vuthzbw at mozmail dot com>
pkgname=mozillavpn
pkgver=2.19.0
_debian_series=mantic1
-pkgrel=1
+pkgrel=2
pkgdesc="A fast, secure and easy to use VPN. Built by the makers of Firefox."
arch=('x86_64')
url="https://mozilla.org/products/vpn"
@@ -45,8 +50,9 @@ makedepends=(
)
install=mozillavpn.install
# https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+packages
-source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz")
-sha256sums=('36754d1f0e2f3ff5b08cecf691b7e158981356dc53b55152d93925f1b4d87e03')
+source=("https://launchpad.net/~mozillacorp/+archive/ubuntu/mozillavpn/+sourcefiles/mozillavpn/${pkgver}-${_debian_series}/mozillavpn_${pkgver}.orig.tar.gz" "mozillavpn.install")
+sha256sums=('36754d1f0e2f3ff5b08cecf691b7e158981356dc53b55152d93925f1b4d87e03'
+ 'bba558c169389be05ba37d0565ca94ad43b1fdb94e137327af0e0e5229e66227')
build() {
cd "${pkgname}-${pkgver}"
diff --git a/mozillavpn.install b/mozillavpn.install
index 7cda67203e02..d256ea5063ea 100644
--- a/mozillavpn.install
+++ b/mozillavpn.install
@@ -1,10 +1,10 @@
post_install() {
- systemctl daemon-reload
- systemctl enable mozillavpn.service
- systemctl start mozillavpn.service
+ echo 'enable & start the Mozillavpn daemon with:'
+ echo 'systemctl enable mozillavpn.service'
+ echo 'systemctl start mozillavpn.service'
}
post_upgrade() {
- systemctl daemon-reload
- systemctl restart mozillavpn.service
+ echo 'Mozillavpn daemon must be restart after updating with:'
+ echo 'systemctl restart mozillavpn.service'
}