summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonidas P2022-08-07 23:00:30 +0300
committerLeonidas P2022-08-07 23:00:30 +0300
commit80dfcc8542965ab34425ab277c5dd8197325b787 (patch)
tree03869c2a0e35867d1fc19853ec22c6d627b19a68
parente307eae5243df81f332df573748b66bffc74a59c (diff)
downloadaur-80dfcc8542965ab34425ab277c5dd8197325b787.tar.gz
use _pkgname variable
-rw-r--r--PKGBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0b6ac8e2eec0..1f8d20064892 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Leonidas P. <jpegxguy at outlook dot com>
# Contributor: Vincent Bernardoff <vb AT luminar.eu.org>
-pkgname=mmc-utils-git
-pkgver=r88.a1b233c
+_pkgname=mmc-utils
+pkgname=${_pkgname}-git
+pkgver=r98.d7b343f
pkgrel=1
epoch=1
pkgdesc="Userspace tools for MMC/SD devices"
@@ -10,23 +11,22 @@ arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
url="https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git"
license=('GPL')
makedepends=('git')
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-source=('git://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=('git+https://git.kernel.org/pub/scm/utils/mmc/mmc-utils.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/${pkgname%-git}"
- make all
+ make -C "${_pkgname}"
}
package() {
- cd "$srcdir/${pkgname%-git}"
- make DESTDIR="$pkgdir/" prefix=/usr install
- install -D man/mmc.1 "$pkgdir/usr/share/man/man1/mmc.1"
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" prefix=/usr install
+ install -Dm644 man/mmc.1 "${pkgdir}/usr/share/man/man1/mmc.1"
}