summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2015-06-10 15:22:07 +0200
committerAlexander F Rødseth2015-06-10 15:22:07 +0200
commit80e632a87d9df675fe3c68b6cd8156df76ca2838 (patch)
treed63309ecc6277335180e3331bafe148c4ffa64df
downloadaur-80e632a87d9df675fe3c68b6cd8156df76ca2838.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
-rw-r--r--libgnomecups_0.2.3-ignore-ipp-not-found.patch11
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f49d74be047c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = libgnomecups
+ pkgdesc = GNOME CUPS library
+ pkgver = 0.2.3
+ pkgrel = 13
+ url = http://www.gnome.org/
+ arch = x86_64
+ arch = i686
+ license = LGPL
+ license = GPL
+ makedepends = perl-xml-parser
+ depends = libcups
+ options = !libtool
+ source = http://ftp.gnome.org/pub/GNOME/sources/libgnomecups/0.2/libgnomecups-0.2.3.tar.bz2
+ source = libgnomecups_0.2.3-ignore-ipp-not-found.patch
+ source = gentoo1.patch::http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-print/libgnomecups/files/libgnomecups-0.2.3-glib.h.patch?revision=1.1
+ source = gentoo2.patch::http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-print/libgnomecups/files/libgnomecups-0.2.3-cups-1.6.patch?revision=1.1
+ md5sums = dc4920c15c9f886f73ea74fbff0ae48b
+ md5sums = 973a1b9d93013ce431400a14b78f5d94
+ md5sums = de094a91df09f2136f13e5380b9bfa84
+ md5sums = b9e1d6a5eda9ecb98a1fcb6f8d0e9b4d
+
+pkgname = libgnomecups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa989e7efa51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Alexander Rødseth <rodseth@gmail.com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Paulius Palevicius <paulius@birzai.com>
+
+pkgname=libgnomecups
+pkgver=0.2.3
+pkgrel=13
+pkgdesc='GNOME CUPS library'
+arch=('x86_64' 'i686')
+license=('LGPL' 'GPL')
+url='http://www.gnome.org/'
+depends=('libcups')
+makedepends=('perl-xml-parser')
+options=('!libtool')
+source=("http://ftp.gnome.org/pub/GNOME/sources/$pkgname/0.2/$pkgname-$pkgver.tar.bz2"
+ 'libgnomecups_0.2.3-ignore-ipp-not-found.patch'
+ 'gentoo1.patch::http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-print/libgnomecups/files/libgnomecups-0.2.3-glib.h.patch?revision=1.1'
+ 'gentoo2.patch::http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/net-print/libgnomecups/files/libgnomecups-0.2.3-cups-1.6.patch?revision=1.1')
+md5sums=('dc4920c15c9f886f73ea74fbff0ae48b'
+ '973a1b9d93013ce431400a14b78f5d94'
+ 'de094a91df09f2136f13e5380b9bfa84'
+ 'b9e1d6a5eda9ecb98a1fcb6f8d0e9b4d')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ # This avoids generating huge 'IPP request failed with status 1030' lines
+ patch -Np1 -i "$srcdir/libgnomecups_0.2.3-ignore-ipp-not-found.patch"
+
+ # Gentoo seems to have taken over the development
+ patch -Np1 -i "$srcdir/gentoo1.patch"
+ patch -Np1 -i "$srcdir/gentoo2.patch"
+
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ make -C "$pkgname-$pkgver" DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/libgnomecups_0.2.3-ignore-ipp-not-found.patch b/libgnomecups_0.2.3-ignore-ipp-not-found.patch
new file mode 100644
index 000000000000..797367bf9f36
--- /dev/null
+++ b/libgnomecups_0.2.3-ignore-ipp-not-found.patch
@@ -0,0 +1,11 @@
+--- a/libgnomecups/gnome-cups-request.c 2007-01-31 10:49:17.000000000 -0800
++++ b/libgnomecups/gnome-cups-request.c 2009-11-24 12:49:30.000000000 -0800
+@@ -349,7 +349,7 @@
+ if (request->response == NULL)
+ status = IPP_INTERNAL_ERROR;
+
+- if (status > IPP_OK_CONFLICT) {
++ if (status > IPP_OK_CONFLICT && status != IPP_NOT_FOUND) {
+ g_warning ("IPP request failed with status %d", status);
+ if (request->error != NULL)
+ *(request->error) = g_error_new (GNOME_CUPS_ERROR,