summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrystaly2016-07-24 21:12:35 +0200
committercrystaly2016-07-24 21:14:04 +0200
commit80fc98e3fa6db7108c119745c448fb629ca61554 (patch)
tree5e6130bd2bd802d609eb3a0cacf54988fe991582
parentcc921c1d044fb594b1d088a84dd9f16fa2e928d9 (diff)
downloadaur-80fc98e3fa6db7108c119745c448fb629ca61554.tar.gz
Use original upstream as source.
Version tags are now available. Use new parameters for alsa controls.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--spotify-connect-web.install4
-rw-r--r--spotify-connect-web@.service2
4 files changed, 30 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6c099135307..2367460d1e5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
# Generated by mksrcinfo v8
-# Sun May 1 21:22:17 UTC 2016
+# Sun Jul 24 19:13:53 UTC 2016
pkgbase = spotify-connect-web
pkgdesc = Simple Web client for accessing Spotify connect api (Raspberry Pi 2)
- pkgver = r55.979f510
+ pkgver = 0.0.3.alpha.r6.g565767b
pkgrel = 1
- url = https://github.com/chukysoria/spotify-connect-web
+ url = https://github.com/Fornoth/spotify-connect-web
install = spotify-connect-web.install
- arch = any
- license = Apache
+ arch = armv7h
+ license = MIT
makedepends = git
depends = python2-flask
depends = python2-flask-bootstrap
@@ -19,12 +19,14 @@ pkgbase = spotify-connect-web
depends = python2
provides = spotify-connect-web
conflicts = spotify-connect-web
- source = git+https://github.com/chukysoria/spotify-connect-web#branch=master
+ source = git+https://github.com/Fornoth/spotify-connect-web#branch=master
+ source = https://github.com/sashahilton00/spotify-connect-resources/raw/master/armhf%20version/libspotify_embedded_shared.so
source = spotify-connect-web@.service
source = spotify-connect-web.install
sha256sums = SKIP
- sha256sums = 42a8a539419e6841cb3b00570ca998f884eae899b4275a072ce5e8c57bf23527
- sha256sums = b70e8014ef0bc217e8837d8979930d2f1d2ff3cfd18aff8e117f8e9736e9789e
+ sha256sums = 05a1d441fee75bae6d6b8c94538389e232bea79133cda673e780ca3b97e6a95d
+ sha256sums = 30b31e9688eb621ed3e6f42ce6689ee0ad079ce3aa7354d8d42830255685934a
+ sha256sums = 876ca4593670c1ca9b968e93413b90f51b4d10c325a7dbb313052037e6a9888c
pkgname = spotify-connect-web
diff --git a/PKGBUILD b/PKGBUILD
index 9b338561f73a..7e3b8313ac0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: crystaly <crystaly [ at ] posteo [ dot ] de>
pkgname=spotify-connect-web
-pkgver=r55.979f510
-pkgrel=2
+pkgver=0.0.3.alpha.r6.g565767b
+pkgrel=1
pkgdesc="Simple Web client for accessing Spotify connect api (Raspberry Pi 2)"
-arch=('any')
-url="https://github.com/chukysoria/spotify-connect-web"
-license=('Apache')
+arch=('armv7h')
+url="https://github.com/Fornoth/spotify-connect-web"
+license=('MIT')
groups=()
depends=('python2-flask' 'python2-flask-bootstrap' 'python2-flask-cors' 'python2-pyalsaaudio' 'python2-gevent' 'python2-cffi' 'python2-pycparser' 'python2')
makedepends=('git')
@@ -15,30 +15,24 @@ replaces=()
backup=()
options=()
install="${pkgname}.install"
-source=('git+https://github.com/chukysoria/spotify-connect-web#branch=master'
+source=('git+https://github.com/Fornoth/spotify-connect-web#branch=master'
+ 'https://github.com/sashahilton00/spotify-connect-resources/raw/master/armhf%20version/libspotify_embedded_shared.so'
'spotify-connect-web@.service'
'spotify-connect-web.install')
noextract=()
sha256sums=('SKIP'
- '42a8a539419e6841cb3b00570ca998f884eae899b4275a072ce5e8c57bf23527'
- 'b70e8014ef0bc217e8837d8979930d2f1d2ff3cfd18aff8e117f8e9736e9789e')
+ '05a1d441fee75bae6d6b8c94538389e232bea79133cda673e780ca3b97e6a95d'
+ '30b31e9688eb621ed3e6f42ce6689ee0ad079ce3aa7354d8d42830255685934a'
+ '876ca4593670c1ca9b968e93413b90f51b4d10c325a7dbb313052037e6a9888c')
pkgver() {
cd "$srcdir/${pkgname%-git}"
-
- # Git, no tags available
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$srcdir/${pkgname%-git}"
- # fix volmin/volmax parameters not being applied
- sed -i 's|.mixer_load()|.mixer_load(self.args.mixer, self.args.volmin, self.args.volmax)|g' connect_console.py
-
- # fix missing sleep import
- sed -i '/^from gevent/i from gevent import sleep' main.py
-
# replace python by python2
sed -i 's|^#!/usr/bin/env python$|#!/usr/bin/env python2|g' *.py
@@ -52,9 +46,12 @@ build() {
package() {
cd "$srcdir/${pkgname%-git}"
+ # copy libspotify.so to /usr/lib
+ install -D -m644 "$srcdir/libspotify_embedded_shared.so" "${pkgdir}/usr/lib/libspotify_embedded_shared.so"
+
# copy app files
install -d -m755 "${pkgdir}/usr/lib/${pkgname}"
- install -D -m 644 *.py *.pyc "${pkgdir}/usr/lib/${pkgname}"
+ install -D -m 644 *.py *.pyc *.h "${pkgdir}/usr/lib/${pkgname}"
install -D -m644 "$srcdir/spotify-connect-web@.service" "${pkgdir}/usr/lib/systemd/system/spotify-connect-web@.service"
diff --git a/spotify-connect-web.install b/spotify-connect-web.install
index 2ec1394e95dd..094d0b4a720c 100644
--- a/spotify-connect-web.install
+++ b/spotify-connect-web.install
@@ -1,5 +1,9 @@
post_upgrade() {
+ # compile cffi
+ cd /usr/lib/spotify-connect-web/
+ python2 -c "from connect_ffi import ffi, lib"
+
systemctl daemon-reload
}
diff --git a/spotify-connect-web@.service b/spotify-connect-web@.service
index 8ba75cbd3534..cb1a3ecf657b 100644
--- a/spotify-connect-web@.service
+++ b/spotify-connect-web@.service
@@ -5,7 +5,7 @@ After=network.target
[Service]
User=%i
-ExecStart=/usr/bin/python2 /usr/lib/spotify-connect-web/main.py --key ${HOME}/.config/spotify-connect-web/spotify_appkey.key --credentials ${HOME}/.config/spotify-connect-web/credentials.json --bitrate 320 --name "SpotifyConnectWeb" --volmin=50 --volmax=80 -d
+ExecStart=/usr/bin/python2 /usr/lib/spotify-connect-web/main.py --key ${HOME}/.config/spotify-connect-web/spotify_appkey.key --credentials ${HOME}/.config/spotify-connect-web/credentials.json --bitrate 320 --name "SpotifyConnectWeb" --dbrange 50 -o default:CARD=ALSA
#Restart=on-failure
[Install]