summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew O'Neill2021-08-18 17:16:29 -0400
committerAndrew O'Neill2021-08-18 17:16:29 -0400
commit81025144d2fa104a77692172a788115a2ac15c57 (patch)
treeeff963f8f2f1b16fb32dda30988d81d346503140
parent5c19f6406d81639a7bfb51e1bb45cd51808a067c (diff)
downloadaur-81025144d2fa104a77692172a788115a2ac15c57.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--oci-cli.patch48
3 files changed, 8 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e037eb7f27e..b5b8a19a4eaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = oci-cli
pkgdesc = Command line interface for Oracle Cloud Infrastructure
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 1
url = https://github.com/oracle/oci-cli
arch = x86_64
@@ -22,9 +22,7 @@ pkgbase = oci-cli
depends = python-retrying
depends = python-yaml
optdepends = python-cx_oracle-git: Used by the database service
- source = oci-cli-3.0.0.tar.gz::https://github.com/oracle/oci-cli/archive/v3.0.0.tar.gz
- source = oci-cli.patch
- sha256sums = 6d65f78cefa9f374696dd7ae8e77d6515e8c649cdf0e7bcf36a7ae5d7b603bbf
- sha256sums = 245f5877b41c848896994325ff2056fb040a2bbd86ba6a9877707603dd958fc4
+ source = oci-cli-3.0.1.tar.gz::https://github.com/oracle/oci-cli/archive/v3.0.1.tar.gz
+ sha256sums = f6187b065aaf765b772f8905f2483d5dcc36206bed6d3d68ebb908196679d59c
pkgname = oci-cli
diff --git a/PKGBUILD b/PKGBUILD
index 37ab18faeb4f..8d69dc9a84d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Andrew O'Neill <andrew at meanjollies dot com>
pkgname=oci-cli
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc='Command line interface for Oracle Cloud Infrastructure'
arch=('x86_64')
@@ -10,15 +10,14 @@ license=('Apache')
depends=('python' 'python-oci' 'python-arrow' 'python-certifi' 'python-click' 'python-dateutil' 'python-cryptography' 'python-pyopenssl' 'python-jmespath' 'python-terminaltables' 'python-idna' 'python-pytz' 'python-six' 'python-retrying' 'python-yaml')
makedepends=('python-setuptools')
optdepends=('python-cx_oracle-git: Used by the database service')
-source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz"
- "${pkgname}.patch")
-sha256sums=('6d65f78cefa9f374696dd7ae8e77d6515e8c649cdf0e7bcf36a7ae5d7b603bbf'
- '245f5877b41c848896994325ff2056fb040a2bbd86ba6a9877707603dd958fc4')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('f6187b065aaf765b772f8905f2483d5dcc36206bed6d3d68ebb908196679d59c')
prepare() {
cd "${pkgname}-${pkgver}"
- patch -p1 -i ../${pkgname}.patch
+ sed -i -r "s/(==|>|<).*'/'/g" setup.py
+ sed -i '/configparser/d' setup.py
}
build() {
diff --git a/oci-cli.patch b/oci-cli.patch
deleted file mode 100644
index 2a6b3c15ff29..000000000000
--- a/oci-cli.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -rupN oci-cli-3.0.0/setup.py oci-cli-3.0.0b/setup.py
---- oci-cli-3.0.0/setup.py 2021-08-03 15:20:34.000000000 -0400
-+++ oci-cli-3.0.0b/setup.py 2021-08-15 21:11:03.420019129 -0400
-@@ -29,23 +29,22 @@ with open_relative("README.rst") as f:
- readme = f.read()
-
- requires = [
-- 'oci==2.43.2',
-- 'arrow==0.17.0',
-+ 'oci',
-+ 'arrow',
- 'certifi',
-- 'click==7.0',
-- 'configparser==4.0.2',
-- 'cryptography>=3.2.1,<=3.4.7',
-- 'jmespath==0.10.0',
-- 'python-dateutil>=2.5.3,<3.0.0',
-- 'pytz>=2016.10',
-- 'six==1.14.0',
-- 'terminaltables==3.1.0',
-- 'pyOpenSSL==19.1.0',
-- 'PyYAML>=5.4,<6'
-+ 'click',
-+ 'cryptography',
-+ 'jmespath',
-+ 'python-dateutil',
-+ 'pytz',
-+ 'six',
-+ 'terminaltables',
-+ 'pyOpenSSL',
-+ 'PyYAML'
- ]
-
- extras = {
-- 'db': ['cx_Oracle==7.0']
-+ 'db': ['cx_Oracle']
- }
-
- fips_libcrypto_file = os.getenv("OCI_CLI_FIPS_LIBCRYPTO_FILE")
-@@ -90,7 +89,7 @@ setup(
- packages=all_packages,
- package_dir=package_dirs,
- include_package_data=True,
-- python_requires='>=3.6',
-+ python_requires='',
- license="Universal Permissive License 1.0 or Apache License 2.0",
- classifiers=[
- "Development Status :: 5 - Production/Stable",