summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Swanson2023-04-06 10:02:05 -0700
committerMike Swanson2023-04-06 10:02:05 -0700
commit811a0b543e161008bcef7caef065c3aaa54ce7ff (patch)
tree41c474add0ead826e5d97b31c673d4e623642e4d
parent30420c82b4b1ea1647beffdd986d480283fe665b (diff)
downloadaur-811a0b543e161008bcef7caef065c3aaa54ce7ff.tar.gz
Make the manual PDF buildable
-rw-r--r--.SRCINFO7
-rw-r--r--0001-manual-build-with-asciidoc.patch26
-rw-r--r--PKGBUILD20
3 files changed, 47 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc55f2cacbf3..008f510a349e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = freedoom
pkgdesc = Free game based on the Doom engine
pkgver = 0.12.1
- pkgrel = 2
+ pkgrel = 3
url = https://freedoom.github.io/
arch = any
license = BSD
@@ -10,7 +10,9 @@ pkgbase = freedoom
makedepends = python
makedepends = python-pillow
source = https://github.com/freedoom/freedoom/releases/download/v0.12.1/freedoom-0.12.1.tar.xz
- sha512sums = 08a8489e1bbd9418262bfefaa9afe67a281b6f3fd38f77ac822438da434229bb034077e53658c06fa93cbf3ba3c5c25dab5fe1844fe23043e310d21866e12810
+ source = 0001-manual-build-with-asciidoc.patch
+ b2sums = db783fd8a3467ab6ec628eb67b036ae069d01516b3f04860d4fda0692921f9a4aa65169ff8b79fa74e88bb496da3686dd7fbbf5e4bb1614ab331023a58c5204d
+ b2sums = 08f5fc17055e921a374aaf2cf092bdf1ff8b5a4069f9b9f5b12f0a119291d1f34d891a2b47e01d966340768c620f44f00848ef01b4675777df25f74a2f160645
pkgname = freedoom
provides = freedoom1
@@ -21,4 +23,3 @@ pkgname = freedoom
replaces = freedoom2
pkgname = freedm
-
diff --git a/0001-manual-build-with-asciidoc.patch b/0001-manual-build-with-asciidoc.patch
new file mode 100644
index 000000000000..31ce0870ddfd
--- /dev/null
+++ b/0001-manual-build-with-asciidoc.patch
@@ -0,0 +1,26 @@
+From b9f79a3af9b21e72eb0064119e5b63adbf6a6e74 Mon Sep 17 00:00:00 2001
+From: Mike Swanson <mikeonthecomputer@gmail.com>
+Date: Thu, 6 Apr 2023 09:58:03 -0700
+Subject: [PATCH] manual: build with asciidoc
+
+---
+ manual/Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/manual/Makefile b/manual/Makefile
+index 0b285d90..db67e568 100644
+--- a/manual/Makefile
++++ b/manual/Makefile
+@@ -1,7 +1,8 @@
+ all: freedoom-manual.pdf
+
+ freedoom-manual.pdf: manual.adoc
+- -asciidoctor-pdf -a toc manual.adoc -o $@
++ a2x -f pdf -a toc manual.adoc
++ mv manual.pdf freedoom-manual.pdf
+
+ clean:
+ $(RM) freedoom-manual.pdf
+--
+2.40.0
+
diff --git a/PKGBUILD b/PKGBUILD
index 075d83c7fe3f..e4c3961b5282 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,28 @@
pkgname=(freedoom freedm)
pkgbase=${pkgname[0]}
pkgver=0.12.1
-pkgrel=2
+pkgrel=3
pkgdesc="Free game based on the Doom engine"
arch=('any')
url="https://freedoom.github.io/"
license=('BSD')
makedepends=('asciidoc' 'deutex' 'python' 'python-pillow')
-source=(https://github.com/$pkgbase/$pkgbase/releases/download/v$pkgver/$pkgbase-$pkgver.tar.xz)
-sha512sums=('08a8489e1bbd9418262bfefaa9afe67a281b6f3fd38f77ac822438da434229bb034077e53658c06fa93cbf3ba3c5c25dab5fe1844fe23043e310d21866e12810')
+source=(https://github.com/$pkgbase/$pkgbase/releases/download/v$pkgver/$pkgbase-$pkgver.tar.xz
+ 0001-manual-build-with-asciidoc.patch)
+b2sums=('db783fd8a3467ab6ec628eb67b036ae069d01516b3f04860d4fda0692921f9a4aa65169ff8b79fa74e88bb496da3686dd7fbbf5e4bb1614ab331023a58c5204d'
+ '08f5fc17055e921a374aaf2cf092bdf1ff8b5a4069f9b9f5b12f0a119291d1f34d891a2b47e01d966340768c620f44f00848ef01b4675777df25f74a2f160645')
+
+prepare() {
+ cd "$pkgbase-$pkgver"
+
+ for patch in ../*.patch; do
+ if [ ! -f "$patch" ]; then
+ break;
+ else
+ patch -p1 -i "$patch"
+ fi
+ done
+}
build() {
cd "$pkgbase-$pkgver"