summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 11:02:20 +0800
committerSukanka2022-06-06 11:02:20 +0800
commit8137ddeec438d5b149dd7ae158e07ff3a8a0b097 (patch)
treed4c4cab0751f78b86b864a4d72be420fea92d8e4
downloadaur-8137ddeec438d5b149dd7ae158e07ff3a8a0b097.tar.gz
add r-ggfortify
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD66
2 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..21596c452d4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = r-ggfortify
+ pkgdesc = Data Visualization Tools for Statistical Analysis Results
+ pkgver = 0.4.14
+ pkgrel = 4
+ url = https://cran.r-project.org/package=ggfortify
+ arch = any
+ license = MIT
+ depends = r
+ depends = r-dplyr
+ depends = r-ggplot2
+ depends = r-gridextra
+ depends = r-scales
+ depends = r-stringr
+ depends = r-tibble
+ depends = r-tidyr
+ optdepends = r-changepoint
+ optdepends = r-cluster
+ optdepends = r-dlm
+ optdepends = r-fgarch
+ optdepends = r-forecast
+ optdepends = r-ggrepel
+ optdepends = r-glmnet
+ optdepends = r-grdevices
+ optdepends = r-kfas
+ optdepends = r-knitr
+ optdepends = r-lfda
+ optdepends = r-lintr
+ optdepends = r-mapdata
+ optdepends = r-markdown
+ optdepends = r-mass
+ optdepends = r-mswm
+ optdepends = r-nlme
+ optdepends = r-raster
+ optdepends = r-rocr
+ optdepends = r-sp
+ optdepends = r-stats
+ optdepends = r-strucchange
+ optdepends = r-survival
+ optdepends = r-testthat
+ optdepends = r-timeseries
+ optdepends = r-tseries
+ optdepends = r-utils
+ optdepends = r-vars
+ optdepends = r-xts
+ optdepends = r-zoo
+ source = https://cran.r-project.org/src/contrib/ggfortify_0.4.14.tar.gz
+ sha256sums = 5c5ad3d94ee43c39635419d1ae622a7906ba3a37d187ae924183f8fb1539150d
+
+pkgname = r-ggfortify
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc54ca41b753
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ggfortify
+_pkgver=0.4.14
+pkgname=r-${_pkgname,,}
+pkgver=0.4.14
+pkgrel=4
+pkgdesc='Data Visualization Tools for Statistical Analysis Results'
+arch=('any')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('MIT')
+depends=(
+ r
+ r-dplyr
+ r-ggplot2
+ r-gridextra
+ r-scales
+ r-stringr
+ r-tibble
+ r-tidyr
+)
+optdepends=(
+ r-changepoint
+ r-cluster
+ r-dlm
+ r-fgarch
+ r-forecast
+ r-ggrepel
+ r-glmnet
+ r-grdevices
+ r-kfas
+ r-knitr
+ r-lfda
+ r-lintr
+ r-mapdata
+ r-markdown
+ r-mass
+ r-mswm
+ r-nlme
+ r-raster
+ r-rocr
+ r-sp
+ r-stats
+ r-strucchange
+ r-survival
+ r-testthat
+ r-timeseries
+ r-tseries
+ r-utils
+ r-vars
+ r-xts
+ r-zoo
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('5c5ad3d94ee43c39635419d1ae622a7906ba3a37d187ae924183f8fb1539150d')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+ install -Dm644 "${_pkgname}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+# vim:set ts=2 sw=2 et: