summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2017-01-07 12:35:55 +1100
committerMatthew Gamble2017-01-07 12:35:55 +1100
commit8139ab10a97bacf23c01d56a3f14793bf0d39746 (patch)
treef4e6cdb9034f3e4c3665046c4244e13f87be1dce
parent9a096253a58e6636e11eef69d5858f03c94efb70 (diff)
downloadaur-8139ab10a97bacf23c01d56a3f14793bf0d39746.tar.gz
Python 3.6 updates
- Update code style - Bump pkgrel - Update download URL
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88f7330d88fd..b0ed07f593db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
+# Generated by mksrcinfo v8
+# Sat Jan 7 01:35:52 UTC 2017
pkgbase = python-unstdlib
pkgdesc = Unstandard Python library of useful and highly-reusable functions.
pkgver = 1.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/shazow/unstdlib.py
arch = any
license = MIT
makedepends = python-setuptools
depends = python
- source = https://pypi.python.org/packages/source/u/unstdlib/unstdlib-1.7.tar.gz
+ source = https://pypi.python.org/packages/4c/d6/5aa62dd4cff8d452e69b6a7c506cb288d8ae2c99ac3d8354004b887b047b/unstdlib-1.7.tar.gz
sha256sums = 9348ff23b8f3a235db55b11e397d55352b2029e4fb0979558fee2d1ea8667280
pkgname = python-unstdlib
diff --git a/PKGBUILD b/PKGBUILD
index 5101e85a5dfd..43833fa465bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: Matthew Gamble
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
pkgname=python-unstdlib
pkgver=1.7
-pkgrel=1
+pkgrel=2
pkgdesc="Unstandard Python library of useful and highly-reusable functions."
-arch=('any')
-url='https://github.com/shazow/unstdlib.py'
-license=('MIT')
-depends=('python')
-makedepends=('python-setuptools')
-source=("https://pypi.python.org/packages/source/u/unstdlib/unstdlib-$pkgver.tar.gz")
+arch=("any")
+url="https://github.com/shazow/unstdlib.py"
+license=("MIT")
+depends=("python")
+makedepends=("python-setuptools")
+source=("https://pypi.python.org/packages/4c/d6/5aa62dd4cff8d452e69b6a7c506cb288d8ae2c99ac3d8354004b887b047b/unstdlib-${pkgver}.tar.gz")
sha256sums=('9348ff23b8f3a235db55b11e397d55352b2029e4fb0979558fee2d1ea8667280')
build() {
- cd "unstdlib-$pkgver"
+ cd "unstdlib-${pkgver}"
tail -n 21 README > LICENSE
}
package() {
- cd "unstdlib-$pkgver"
- python setup.py install --root="$pkgdir"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "unstdlib-${pkgver}"
+ python setup.py install --root="${pkgdir}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-unstdlib/LICENSE"
}