summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-11-27 08:12:01 +1300
committercaltlgin2020-11-27 08:12:01 +1300
commit81a1767305b5b1e7c7867a22b490d2a3bf563f38 (patch)
tree03b732802c77d58668cb5aae60534fa9d313ba3b
downloadaur-81a1767305b5b1e7c7867a22b490d2a3bf563f38.tar.gz
Add to AUR
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD32
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..715cfe9e9922
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = floatybox
+ pkgdesc = Float your way through perilous terrain in this endless side-scoller game
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://octobanana.com/software/floatybox
+ arch = x86_64
+ license = MIT
+ makedepends = boost
+ makedepends = cmake
+ depends = boost-libs
+ source = floatybox-0.1.0.tar.gz::https://github.com/octobanana/floatybox/archive/0.1.0.tar.gz
+ sha256sums = 1949018c82ab3a5ee66c474c850614133f52c134ed04aa133d4841d46ccc4718
+
+pkgname = floatybox
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..623d0e70ff3e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0408b9538a63
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+
+pkgname='floatybox'
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='Float your way through perilous terrain in this endless side-scoller game'
+arch=('x86_64')
+url='https://octobanana.com/software/floatybox'
+_url_source='https://github.com/octobanana/floatybox'
+license=('MIT')
+depends=('boost-libs')
+makedepends=('boost' 'cmake')
+source=("${pkgname}-${pkgver}.tar.gz::${_url_source}/archive/${pkgver}.tar.gz")
+sha256sums=('1949018c82ab3a5ee66c474c850614133f52c134ed04aa133d4841d46ccc4718')
+
+build() {
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B 'build' -S "${pkgname}-${pkgver}" \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -Wno-dev
+ make -C 'build'
+}
+
+package() {
+ install -Dvm755 "build/${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dvm644 "${pkgname}-${pkgver}/"{'README.md','doc/help.txt'} -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dvm644 "${pkgname}-${pkgver}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
+# vim: ts=2 sw=2 et: