summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlobodan Terzić2020-05-03 19:29:48 +0200
committerSlobodan Terzić2020-05-03 19:29:48 +0200
commit81ae56b184f62bcfab5da7921becf01230b7d1b8 (patch)
tree78cbeae3f233a71a31b7fd75bf8289655f0cb9dd
parent12a5f4248a945f5fbd5b26dfcaa40312ba57f2d6 (diff)
downloadaur-81ae56b184f62bcfab5da7921becf01230b7d1b8.tar.gz
Use less zealous versioning. Use system qtkeychain.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 547289e24476..e232682aad53 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mudlet-git
pkgdesc = A modern MUD client with a graphical user inteface and built in Lua scripting (git development branch
- pkgver = 4137_Mudlet.4.6.1.77.g819757d4a_2020.03.25
+ pkgver = Mudlet.4.6.1.r218.g102491a74
pkgrel = 1
url = http://www.mudlet.org
arch = i686
@@ -22,6 +22,7 @@ pkgbase = mudlet-git
depends = ttf-font
depends = pugixml
depends = lua-yajl
+ depends = qtkeychain
optdepends = discord-rpc-api: discord integration
optdepends = ttf-bitstream-vera: default font
optdepends = ttf-ubuntu-font-family: default font
diff --git a/PKGBUILD b/PKGBUILD
index 171def9bb407..a9514849c660 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Contributor: Xabre <xabre @archlinux.info>
pkgname=mudlet-git
_gitname=Mudlet
-pkgver=4137_Mudlet.4.6.1.77.g819757d4a_2020.03.25
+pkgver=Mudlet.4.6.1.r218.g102491a74
pkgrel=1
pkgdesc="A modern MUD client with a graphical user inteface and built in Lua scripting (git development branch"
arch=('i686' 'x86_64')
url="http://www.mudlet.org"
license=('GPL')
depends=('qt5-multimedia' 'hunspell' 'libzip' 'glu' 'lua51-filesystem' 'luazip5.1' 'lua51-sql-sqlite' \
- 'lrexlib-pcre5.1' 'qt5-gamepad' 'lua51-utf8' 'ttf-font' 'pugixml' 'lua-yajl')
+ 'lrexlib-pcre5.1' 'qt5-gamepad' 'lua51-utf8' 'ttf-font' 'pugixml' 'lua-yajl' 'qtkeychain')
makedepends=('git' 'boost' 'qt5-tools')
optdepends=('discord-rpc-api: discord integration'
'ttf-bitstream-vera: default font'
@@ -21,17 +21,16 @@ sha256sums=('SKIP')
pkgver() {
cd ${_gitname}
- _tag=$(git describe --tags | sed 's:^v::') # tag is mobile, and switches between numbers and letters, can't use it for versioning
- _commits=$(git rev-list --count HEAD) # total commits is the most sane way of getting incremental pkgver
- _date=$(git log -1 --date=short --pretty=format:%cd)
- printf "%s_%s_%s\n" "${_commits}" "${_tag}" "${_date}" | sed 's/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "$srcdir/${_gitname}/src"
export XDG_DATA_DIRS=/usr/share
export WITH_FONTS=NO
- export WITH_UPDATER=NO
+ export WITH_UPDATER=NO
+ export WITH_OWN_QTKEYCHAIN=NO
+
qmake-qt5 PREFIX=/usr
make
}