summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVadim Tsesko2021-03-23 14:19:05 +0300
committerVadim Tsesko2021-03-23 14:19:05 +0300
commit81b5943f0a9731791e0ede737226ea63249a9423 (patch)
treefd2deb3f3300fde7f879fcb9448b93eee59e3632
parent7290074d76f6afdfd378196fd43c0899a1c5fdf4 (diff)
downloadaur-81b5943f0a9731791e0ede737226ea63249a9423.tar.gz
Added converter.jar. Fixed jars permission mode.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c190e5d27c75..a2576d832a1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = async-profiler
pkgdesc = Sampling CPU and HEAP profiler for Java featuring AsyncGetCallTrace + perf_events
pkgver = 2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jvm-profiling-tools/async-profiler
install = async-profiler.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 9611d84b0d87..27b5e3760ac2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=async-profiler
pkgver=2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Sampling CPU and HEAP profiler for Java featuring AsyncGetCallTrace + perf_events'
arch=('x86_64')
url='https://github.com/jvm-profiling-tools/async-profiler'
@@ -22,6 +22,7 @@ build() {
package() {
cd "$pkgname-$pkgver"
install -d "$pkgdir/opt/async-profiler/build"
- install build/libasyncProfiler.so build/jattach build/async-profiler.jar "$pkgdir/opt/async-profiler/build"
+ install -m 644 build/async-profiler.jar build/converter.jar "$pkgdir/opt/async-profiler/build"
+ install build/libasyncProfiler.so build/jattach "$pkgdir/opt/async-profiler/build"
install profiler.sh "$pkgdir/opt/async-profiler/profiler.sh"
}