summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSolomon Choina2020-12-14 15:44:43 -0500
committerSolomon Choina2020-12-14 15:44:43 -0500
commit81b7cb7bacbb08e7ccad76af2d918c30dc381fd2 (patch)
tree03a9941b56a4d90482d2497adb891c03e3a28021
parentd35e98eb113b62fd73dff3af17b8accd66988cb7 (diff)
downloadaur-81b7cb7bacbb08e7ccad76af2d918c30dc381fd2.tar.gz
update pkgver and stack updates
-rw-r--r--PKGBUILD6
-rw-r--r--stack.yaml52
2 files changed, 40 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa776f327336..e034bf1751dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Solomon Choina <shlomochoina@gmail.com
# Maintainer: Leif Warner <abimelech@gmail.com>
pkgname=taffybar
-pkgver=3.2.2
+pkgver=3.2.3
pkgrel=1
license=('BSD3')
pkgdesc="A desktop bar similar to xmobar, but with more GUI"
@@ -17,10 +17,10 @@ source=("https://github.com/taffybar/taffybar/archive/v${pkgver}.tar.gz"
"https://raw.githubusercontent.com/taffybar/taffybar/13b32fc2bc62129093494e939339a979d641691c/xmonad.hs.example"
)
-sha256sums=('6e703c50535ad6ab80a60c4dcfcecb95b85670676bd5f6457643e5fb03d5eed6'
+sha256sums=('74333f8177677d4acb509d09ca3727b726b70d1b6cfc1a5439d236eabc6556b3'
'554340a052abecb78fbb959d1a05b8f4f4db947fc151e7f0f8c49f2300f1ab6d'
'f4a08e887ba527a24f4cecc22393023bf7230172cc76f840ddfc5cfc54182a7e'
- '557fa41b3e005451c7334ebb14ce476d4f7d0fcbdfad25c984db9a49b18da529'
+ '0bd90a3b0859ccb7a5319ce7906a7c4611153035cb75ee5a1127d34325cc03d4'
'1a8ca4f177891941960585e228d5386ea9f120a1bb12ac0a956200de839032cb')
# PKGBUILD functions
diff --git a/stack.yaml b/stack.yaml
index fa5dcbb99e07..28558e8d41e1 100644
--- a/stack.yaml
+++ b/stack.yaml
@@ -3,26 +3,48 @@ packages:
extra-deps:
- ConfigFile-1.1.4
-- broadcast-chan-0.2.1
+- broadcast-chan-0.2.1.1
- dbus-hslogger-0.1.0.1
-- gio-0.13.4.1
+# gtk-sni-tray for a clean tray
- gtk-sni-tray-0.1.6.0
+# GTK3 for my-taffybar
+- gtk3-0.15.5
+# For gtk3
+- cairo-0.13.8.1
+- gio-0.13.8.1
+- glib-0.13.8.1
+- gtk2hs-buildtools-0.13.8.0
+- pango-0.13.8.1
+
+# From base taffybar
+- gi-glib-2.0.24
+- haskell-gi-0.24.5
+- haskell-gi-base-0.24.4
+# From manual "finding out the package and finding the most recent version"
+- gi-cairo-connector-0.1.0
+- gi-cairo-render-0.1.0
+- gi-pango-1.0.23
+- gi-gtk-hs-0.3.9
+# Seeing that theoretically the `g_spec_param_uref` linking issue has been fixed,
+# gi-gobject is fixed to the most recent version
+# Source : https://github.com/haskell-gi/haskell-gi/issues/298 and
+# https://github.com/haskell-gi/haskell-gi/issues/301
+- gi-gobject-2.0.24
+# From gi-pango
+- gi-harfbuzz-0.0.3
+- gi-dbusmenu-0.4.6
+- gi-dbusmenugtk3-0.4.7
+- gi-gdkx11-3.0.8
+- gi-xlib-2.0.7
- gtk-strut-0.1.3.0
-- libxml-sax-0.7.5
- rate-limit-1.4.1
-- spool-0.1
- status-notifier-item-0.3.0.5
- time-units-1.0.0
- xml-helpers-1.0.0
-- gi-cairo-connector-0.0.1
-- gi-cairo-render-0.0.1
-- gi-dbusmenu-0.4.4
-- gi-dbusmenugtk3-0.4.5
-- gi-gdkx11-3.0.5
-- gi-xlib-2.0.5
-- MissingH-1.4.3.0
-- xdg-desktop-entry-0.1.1.1
-
-resolver: lts-15.10
+- safe-0.3.19
-ghc-options: {"$locals": -ddump-to-file -ddump-hi}
+resolver: lts-16.26
+allow-newer: true
+ghc-options:
+ $everything: -split-sections -haddock
+ $locals: -fwrite-ide-info -hiedir=.hie -fmax-relevant-binds=0