summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorruniq2017-01-29 11:41:50 +0100
committerruniq2017-01-29 11:41:50 +0100
commit81bc14f41a82cc5c7ba1f5f746b8220f46a8b176 (patch)
tree826dc1b903674440b769252632e1945c6569b736
parent05118ef1801b2739e6883b06468ae63c7d5b6e09 (diff)
downloadaur-81bc14f41a82cc5c7ba1f5f746b8220f46a8b176.tar.gz
Update version, use system versions of libs
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
-rw-r--r--gog-baldurs-gate-2-enhanced-edition2
-rw-r--r--gog-baldurs-gate-2-enhanced-edition.desktop6
4 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 357e36a25b9c..62ac07fe2adf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,26 @@
pkgbase = gog-baldurs-gate-2-enhanced-edition
pkgdesc = Your story begins anew in the exotic southern kingdom of Amn, amidst the opulence of the sinister capital city of Athkatla. GOG Version. Linux native.
- pkgver = 2.0.0.2
+ pkgver = 2.6.0.10
pkgrel = 1
url = http://www.gog.com/game/baldurs_gate_2_enhanced_edition
arch = i686
arch = x86_64
license = custom
- source = gog://gog_baldur_s_gate_2_enhanced_edition_2.0.0.2.sh
+ depends = lib32-glibc
+ depends = lib32-alsa-lib
+ depends = lib32-libgl
+ depends = lib32-libxcb
+ optdepends = lib32-libpulse: pulseaudio support
+ source = gog://gog_baldur_s_gate_2_enhanced_edition_2.6.0.10.sh
source = gog-baldurs-gate-2-enhanced-edition
source = gog-baldurs-gate-2-enhanced-edition.desktop
- sha256sums = bd797cbdd93cd45d77065e90c06ae98d5cd4275962e34ca42a3b37f1b01090f8
+ sha256sums = f123b2482c169c81d52c93513c4659db3ed376c2781401d24b65ce08d49747e9
sha256sums = 55e56f5c3e4b03a3dfa70ad66e85b5cdac229baa7fc72775fd77a6962ea68ca7
sha256sums = 082330f67a7a6aa4ecc4d2f71765f12224f03260edff82e42d7622fd5084c14d
depends_i686 = glibc
depends_i686 = alsa-lib
depends_i686 = libgl
optdepends_i686 = libpulse: pulseaudio support
- depends_x86_64 = lib32-glibc
- depends_x86_64 = lib32-alsa-lib
- depends_x86_64 = lib32-libgl
- optdepends_x86_64 = lib32-libpulse: pulseaudio support
pkgname = gog-baldurs-gate-2-enhanced-edition
diff --git a/PKGBUILD b/PKGBUILD
index 218dac835b4e..eafa49f8ffd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,32 @@
pkgname=gog-baldurs-gate-2-enhanced-edition
_pkgname=baldurs-gate-2-enhanced-edition
_original="Baldurs Gate 2 Enhanced Edition"
-pkgver=2.0.0.2
+pkgver=2.6.0.10
pkgrel=1
pkgdesc="Your story begins anew in the exotic southern kingdom of Amn, amidst the opulence of the sinister capital city of Athkatla. GOG Version. Linux native."
arch=('i686' 'x86_64')
url="http://www.gog.com/game/baldurs_gate_2_enhanced_edition"
license=('custom')
-depends_i686=('glibc' 'alsa-lib' 'libgl')
-depends_x86_64=('lib32-glibc' 'lib32-alsa-lib' 'lib32-libgl')
+depends_i686=('glibc' 'alsa-lib' 'libgl' 'libxcb')
+depends_x86_64=('lib32-glibc' 'lib32-alsa-lib' 'lib32-libgl' 'lib32-libxcb')
optdepends_i686=('libpulse: pulseaudio support')
optdepends_x86_64=('lib32-libpulse: pulseaudio support')
DLAGENTS+=("gog::/usr/bin/echo Could not find %u. Manually download it to \"$(pwd)\", or set up a gog:// DLAGENT in /etc/makepkg.conf.")
source=("gog://gog_baldur_s_gate_2_enhanced_edition_$pkgver.sh"
"$pkgname"
"$pkgname.desktop")
-sha256sums=('bd797cbdd93cd45d77065e90c06ae98d5cd4275962e34ca42a3b37f1b01090f8'
+sha256sums=('f123b2482c169c81d52c93513c4659db3ed376c2781401d24b65ce08d49747e9'
'55e56f5c3e4b03a3dfa70ad66e85b5cdac229baa7fc72775fd77a6962ea68ca7'
'082330f67a7a6aa4ecc4d2f71765f12224f03260edff82e42d7622fd5084c14d')
+PKGEXT=".pkg.tar"
package() {
- _pkgdir="$pkgdir/opt/gog/$_pkgname"
- mkdir -p "$pkgdir"/opt/gog/$_pkgname
- cp -r data/noarch/* "$_pkgdir"
+ mkdir -p "$pkgdir/opt/$pkgname"
+ cp -r data/noarch/* "$pkgdir/opt/$pkgname"
+ # Remove packaged libraries that result in the game not starting
+ rm "$pkgdir/opt/$pkgname/lib/libstdc++.so.6"
+ rm "$pkgdir/opt/$pkgname/lib/libxcb.so.1"
install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
install -Dm644 data/noarch/support/icon.png "$pkgdir/usr/share/pixmaps/hicolor/256x256/$pkgname.png"
diff --git a/gog-baldurs-gate-2-enhanced-edition b/gog-baldurs-gate-2-enhanced-edition
index bb0ae56d1aa3..b787f4273d3d 100644
--- a/gog-baldurs-gate-2-enhanced-edition
+++ b/gog-baldurs-gate-2-enhanced-edition
@@ -1,4 +1,4 @@
#!/bin/sh
-gogdir="/opt/gog/baldurs-gate-2-enhanced-edition"
+gogdir="/opt/gog-baldurs-gate-2-enhanced-edition"
"${gogdir}/start.sh"
diff --git a/gog-baldurs-gate-2-enhanced-edition.desktop b/gog-baldurs-gate-2-enhanced-edition.desktop
index 82d2e93f4220..f1a81dbae2ea 100644
--- a/gog-baldurs-gate-2-enhanced-edition.desktop
+++ b/gog-baldurs-gate-2-enhanced-edition.desktop
@@ -5,8 +5,8 @@ Type=Application
Name=Baldur's Gate 2 Enhanced Edition
GenericName=Baldur's Gate 2 Enhanced Edition
Comment=Baldur's Gate 2 Enhanced Edition
-Icon=/opt/gog/baldurs-gate-2-enhanced-edition/support/icon.png
-Exec="/opt/gog/baldurs-gate-2-enhanced-edition/start.sh" ""
+Icon=/opt/gog=baldurs-gate-2-enhanced-edition/support/icon.png
+Exec=/opt/gog-baldurs-gate-2-enhanced-edition/start.sh
Categories=Game;
-Path="/opt/gog/baldurs-gate-2-enhanced-edition"
+Path="/opt/gog-baldurs-gate-2-enhanced-edition"