summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-05-20 13:45:35 +0200
committerFabioLolix2023-05-20 13:45:35 +0200
commit81f06b2ac8d63d76c936d3804827011eba614d73 (patch)
tree87a0e80e4c93198268b88299b433869b601960cc
parent0479882e49e3287ff053c8cb4879375fb762f299 (diff)
downloadaur-81f06b2ac8d63d76c936d3804827011eba614d73.tar.gz
revision
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD65
-rw-r--r--README.md1
-rw-r--r--UNLICENSE24
-rw-r--r--glib-2.68.patch26
-rw-r--r--icu68.patch170
6 files changed, 256 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30b5a9fffb66..bbcb9d9c7d85 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,30 +1,40 @@
pkgbase = qt5-webkit-git
pkgdesc = Classes for a WebKit2 based implementation and a new QML API
- pkgver = v5.212.0.alpha2.r16.gbeaeeb998
+ pkgver = 5.212.0.alpha4.r13.gac8ebc6c3
pkgrel = 1
- url = https://code.qt.io/cgit/qt/qtwebkit.git
- arch = i686
+ url = https://github.com/qtwebkit/qtwebkit
arch = x86_64
license = GPL3
- license = LGPL
+ license = LGPL3
license = FDL
+ license = custom
makedepends = git
- makedepends = python2
+ makedepends = cmake
+ makedepends = ruby
makedepends = gperf
- makedepends = libwebp
- makedepends = pkgconf
- depends = qt5-sensors-git
- depends = qt5-location-git
- depends = qt5-webchannel-git
- depends = gst-plugins-base
+ makedepends = python
+ makedepends = qt5-doc
+ makedepends = qt5-tools
+ depends = qt5-location
+ depends = qt5-sensors
+ depends = qt5-webchannel
+ depends = libwebp
depends = libxslt
depends = libxcomposite
+ depends = gst-plugins-base
+ depends = hyphen
+ depends = woff2
optdepends = gst-plugins-good: Webm codec support
- optdepends = libwebp: WebP codec support
provides = qt5-webkit
conflicts = qt5-webkit
- source = qt5-webkit::git+https://code.qt.io/qt/qtwebkit.git#branch=dev
+ options = !lto
+ source = qt5-webkit::git+https://code.qt.io/qt/qtwebkit.git#branch=5.212
+ source = https://src.fedoraproject.org/rpms/qt5-qtwebkit/raw/rawhide/f/qtwebkit-cstdint.patch
+ source = icu68.patch
+ source = glib-2.68.patch
sha256sums = SKIP
+ sha256sums = 4c71c958eae45cae65c9f002024eb1369d06029b668e595158138ff7971e64f1
+ sha256sums = 0b40ed924f03ff6081af610bb0ee01560b7bd1fb68f8af02053304a01d4ccdf0
+ sha256sums = 4969dd03e482155e2490b50307dada81dda7bbc9e5398e3a53c20bc474f7c04e
pkgname = qt5-webkit-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 083b7a9c733f..e736c250cf2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,52 @@
-# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org>
+# Contributor: Dāvis Mosāns <davispuh at gmail dot com>
-_pkgname=qt5-webkit
-pkgname=$_pkgname-git
-pkgver=v5.212.0.alpha2.r16.gbeaeeb998
+pkgname=qt5-webkit-git
+pkgver=5.212.0.alpha4.r13.gac8ebc6c3
pkgrel=1
+arch=(x86_64)
+url='https://github.com/qtwebkit/qtwebkit'
+license=(GPL3 LGPL3 FDL custom)
pkgdesc='Classes for a WebKit2 based implementation and a new QML API'
-arch=('i686' 'x86_64')
-url='https://code.qt.io/cgit/qt/qtwebkit.git'
-license=('GPL3' 'LGPL' 'FDL')
-depends=('qt5-sensors-git' 'qt5-location-git' 'qt5-webchannel-git' 'gst-plugins-base' 'libxslt' 'libxcomposite')
-optdepends=('gst-plugins-good: Webm codec support' 'libwebp: WebP codec support')
-makedepends=('git' 'python2' 'gperf' 'libwebp' 'pkgconf')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
-source=("$_pkgname::git+https://code.qt.io/qt/qtwebkit.git#branch=dev")
-sha256sums=('SKIP')
+source=("qt5-webkit::git+https://code.qt.io/qt/qtwebkit.git#branch=5.212"
+ "https://src.fedoraproject.org/rpms/qt5-qtwebkit/raw/rawhide/f/qtwebkit-cstdint.patch"
+ icu68.patch
+ glib-2.68.patch)
+depends=(qt5-location qt5-sensors qt5-webchannel libwebp libxslt libxcomposite gst-plugins-base hyphen woff2)
+makedepends=(git cmake ruby gperf python qt5-doc qt5-tools)
+optdepends=('gst-plugins-good: Webm codec support')
+provides=(qt5-webkit)
+conflicts=(qt5-webkit)
+options=(!lto)
+sha256sums=('SKIP'
+ '4c71c958eae45cae65c9f002024eb1369d06029b668e595158138ff7971e64f1'
+ '0b40ed924f03ff6081af610bb0ee01560b7bd1fb68f8af02053304a01d4ccdf0'
+ '4969dd03e482155e2490b50307dada81dda7bbc9e5398e3a53c20bc474f7c04e')
pkgver() {
- cd "$srcdir/$_pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$srcdir/qt5-webkit"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$srcdir"
- mkdir -p build
-
- # Use python2 for Python 2.x
- find "./$_pkgname" -name '*.py' -exec sed -i \
- 's|#![ ]*/usr/bin/python$|&2|;s|#![ ]*/usr/bin/env python$|&2|;1 s|#[ ].*$|#!/usr/bin/python2|' {} +
- find "./$_pkgname" -type f \( -name "*.pr?" -o -name "*.make" \) -exec sed -i -e "s|python |python2 |" {} +
+ cd "$srcdir/qt5-webkit"
+ patch -p0 -i ../icu68.patch # Fix build with ICU 68.x
+ patch -p1 -i ../glib-2.68.patch # https://github.com/qtwebkit/qtwebkit/issues/1057
+ patch -p1 -i ../qtwebkit-cstdint.patch # gcc 11.1
}
build() {
- cd "$srcdir/build"
-
- qmake "$srcdir/$_pkgname"
- make
+ cmake -B build -S qt5-webkit \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS} -DNDEBUG" \
+ -DPORT=Qt \
+ -DENABLE_TOOLS=OFF
+ cmake --build build
}
package() {
- cd "$srcdir/build"
+ DESTDIR="$pkgdir" cmake --install build
- make INSTALL_ROOT="$pkgdir" install
+ install -d "$pkgdir"/usr/share/licenses
+ ln -s /usr/share/licenses/qt5-base "$pkgdir"/usr/share/licenses/${pkgname}
}
diff --git a/README.md b/README.md
deleted file mode 100644
index 56ad3c4cb331..000000000000
--- a/README.md
+++ /dev/null
@@ -1 +0,0 @@
-# qt5-webkit-git
diff --git a/UNLICENSE b/UNLICENSE
deleted file mode 100644
index 68a49daad8ff..000000000000
--- a/UNLICENSE
+++ /dev/null
@@ -1,24 +0,0 @@
-This is free and unencumbered software released into the public domain.
-
-Anyone is free to copy, modify, publish, use, compile, sell, or
-distribute this software, either in source code form or as a compiled
-binary, for any purpose, commercial or non-commercial, and by any
-means.
-
-In jurisdictions that recognize copyright laws, the author or authors
-of this software dedicate any and all copyright interest in the
-software to the public domain. We make this dedication for the benefit
-of the public at large and to the detriment of our heirs and
-successors. We intend this dedication to be an overt act of
-relinquishment in perpetuity of all present and future rights to this
-software under copyright law.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
-EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
-OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-OTHER DEALINGS IN THE SOFTWARE.
-
-For more information, please refer to <http://unlicense.org/>
diff --git a/glib-2.68.patch b/glib-2.68.patch
new file mode 100644
index 000000000000..3df60789638c
--- /dev/null
+++ b/glib-2.68.patch
@@ -0,0 +1,26 @@
+From 5b698ba3faffd4e198a45be9fe74f53307395e4b Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fvogt@suse.de>
+Date: Wed, 7 Apr 2021 13:38:09 +0200
+Subject: [PATCH] Remove invalid g_object declarations to fix build with glib
+ >= 2.68
+
+g_object_ref_sink is defined as a macro meanwhile and so the build fails.
+Just remove the declarations, glib.h is included anyway.
+---
+ Source/WTF/wtf/glib/GRefPtr.h | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/Source/WTF/wtf/glib/GRefPtr.h b/Source/WTF/wtf/glib/GRefPtr.h
+index 06133d82cb35..d9a1d2f145f5 100644
+--- a/Source/WTF/wtf/glib/GRefPtr.h
++++ b/Source/WTF/wtf/glib/GRefPtr.h
+@@ -29,9 +29,6 @@
+ #include <algorithm>
+ #include <glib.h>
+
+-extern "C" void g_object_unref(gpointer);
+-extern "C" gpointer g_object_ref_sink(gpointer);
+-
+ namespace WTF {
+
+ enum GRefPtrAdoptType { GRefPtrAdopt };
diff --git a/icu68.patch b/icu68.patch
new file mode 100644
index 000000000000..25f094d7f35f
--- /dev/null
+++ b/icu68.patch
@@ -0,0 +1,170 @@
+Regressed by https://github.com/unicode-org/icu/commit/c3fe7e09d844
+
+In file included from Source/WebCore/platform/text/TextAllInOne.cpp:31:
+Source/WebCore/platform/text/TextCodecICU.cpp:311:42: error: use of undeclared identifier 'TRUE'
+ ucnv_setFallback(m_converterICU, TRUE);
+ ^
+In file included from Source/WebCore/platform/text/TextAllInOne.cpp:40:
+In file included from Source/WebCore/platform/text/icu/UTextProvider.cpp:27:
+Source/WebCore/platform/text/icu/UTextProvider.h:83:28: error: use of undeclared identifier 'TRUE'
+ isAccessible = TRUE;
+ ^
+Source/WebCore/platform/text/icu/UTextProvider.h:88:28: error: use of undeclared identifier 'FALSE'
+ isAccessible = FALSE;
+ ^
+Source/WebCore/platform/text/icu/UTextProvider.h:97:28: error: use of undeclared identifier 'TRUE'
+ isAccessible = TRUE;
+ ^
+Source/WebCore/platform/text/icu/UTextProvider.h:102:28: error: use of undeclared identifier 'FALSE'
+ isAccessible = FALSE;
+ ^
+In file included from Source/WebCore/platform/text/TextAllInOne.cpp:41:
+Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:103:20: error: use of undeclared identifier 'TRUE'
+ return TRUE;
+ ^
+Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:108:20: error: use of undeclared identifier 'FALSE'
+ return FALSE;
+ ^
+Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:114:20: error: use of undeclared identifier 'TRUE'
+ return TRUE;
+ ^
+Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:119:20: error: use of undeclared identifier 'FALSE'
+ return FALSE;
+ ^
+Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:147:12: error: use of undeclared identifier 'TRUE'
+ return TRUE;
+ ^
+Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:339:16: error: use of undeclared identifier 'FALSE'
+ return FALSE;
+ ^
+Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp:359:12: error: use of undeclared identifier 'TRUE'
+ return TRUE;
+ ^
+In file included from Source/WebCore/platform/text/TextAllInOne.cpp:42:
+Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp:128:16: error: use of undeclared identifier 'FALSE'
+ return FALSE;
+ ^
+Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp:148:12: error: use of undeclared identifier 'TRUE'
+ return TRUE;
+ ^
+
+--- Source/WebCore/platform/text/TextCodecICU.cpp.orig 2020-03-04 17:16:37 UTC
++++ Source/WebCore/platform/text/TextCodecICU.cpp
+@@ -308,7 +308,7 @@ void TextCodecICU::createICUConverter() const
+ m_converterICU = ucnv_open(m_canonicalConverterName, &err);
+ ASSERT(U_SUCCESS(err));
+ if (m_converterICU)
+- ucnv_setFallback(m_converterICU, TRUE);
++ ucnv_setFallback(m_converterICU, true);
+ }
+
+ int TextCodecICU::decodeToBuffer(UChar* target, UChar* targetLimit, const char*& source, const char* sourceLimit, int32_t* offsets, bool flush, UErrorCode& err)
+--- Source/WebCore/platform/text/icu/UTextProvider.h.orig 2020-03-04 17:16:37 UTC
++++ Source/WebCore/platform/text/icu/UTextProvider.h
+@@ -80,12 +80,12 @@ inline bool uTextAccessInChunkOrOutOfRange(UText* text
+ // Ensure chunk offset is well formed if computed offset exceeds int32_t range.
+ ASSERT(offset < std::numeric_limits<int32_t>::max());
+ text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
+- isAccessible = TRUE;
++ isAccessible = true;
+ return true;
+ }
+ if (nativeIndex >= nativeLength && text->chunkNativeLimit == nativeLength) {
+ text->chunkOffset = text->chunkLength;
+- isAccessible = FALSE;
++ isAccessible = false;
+ return true;
+ }
+ } else {
+@@ -94,12 +94,12 @@ inline bool uTextAccessInChunkOrOutOfRange(UText* text
+ // Ensure chunk offset is well formed if computed offset exceeds int32_t range.
+ ASSERT(offset < std::numeric_limits<int32_t>::max());
+ text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
+- isAccessible = TRUE;
++ isAccessible = true;
+ return true;
+ }
+ if (nativeIndex <= 0 && !text->chunkNativeStart) {
+ text->chunkOffset = 0;
+- isAccessible = FALSE;
++ isAccessible = false;
+ return true;
+ }
+ }
+--- Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp.orig 2020-03-04 17:16:37 UTC
++++ Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
+@@ -100,23 +100,23 @@ static UBool uTextLatin1Access(UText* uText, int64_t i
+ if (index < uText->chunkNativeLimit && index >= uText->chunkNativeStart) {
+ // Already inside the buffer. Set the new offset.
+ uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
+- return TRUE;
++ return true;
+ }
+ if (index >= length && uText->chunkNativeLimit == length) {
+ // Off the end of the buffer, but we can't get it.
+ uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
+- return FALSE;
++ return false;
+ }
+ } else {
+ if (index <= uText->chunkNativeLimit && index > uText->chunkNativeStart) {
+ // Already inside the buffer. Set the new offset.
+ uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
+- return TRUE;
++ return true;
+ }
+ if (!index && !uText->chunkNativeStart) {
+ // Already at the beginning; can't go any farther.
+ uText->chunkOffset = 0;
+- return FALSE;
++ return false;
+ }
+ }
+
+@@ -144,7 +144,7 @@ static UBool uTextLatin1Access(UText* uText, int64_t i
+
+ uText->nativeIndexingLimit = uText->chunkLength;
+
+- return TRUE;
++ return true;
+ }
+
+ static int32_t uTextLatin1Extract(UText* uText, int64_t start, int64_t limit, UChar* dest, int32_t destCapacity, UErrorCode* status)
+@@ -336,7 +336,7 @@ static int64_t uTextLatin1ContextAwareNativeLength(UTe
+ static UBool uTextLatin1ContextAwareAccess(UText* text, int64_t nativeIndex, UBool forward)
+ {
+ if (!text->context)
+- return FALSE;
++ return false;
+ int64_t nativeLength = uTextLatin1ContextAwareNativeLength(text);
+ UBool isAccessible;
+ if (uTextAccessInChunkOrOutOfRange(text, nativeIndex, nativeLength, forward, isAccessible))
+@@ -356,7 +356,7 @@ static UBool uTextLatin1ContextAwareAccess(UText* text
+ ASSERT(newContext == UTextProviderContext::PriorContext);
+ textLatin1ContextAwareSwitchToPriorContext(text, nativeIndex, nativeLength, forward);
+ }
+- return TRUE;
++ return true;
+ }
+
+ static int32_t uTextLatin1ContextAwareExtract(UText*, int64_t, int64_t, UChar*, int32_t, UErrorCode* errorCode)
+--- Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp.orig 2020-03-04 17:16:37 UTC
++++ Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
+@@ -125,7 +125,7 @@ static inline int64_t uTextUTF16ContextAwareNativeLeng
+ static UBool uTextUTF16ContextAwareAccess(UText* text, int64_t nativeIndex, UBool forward)
+ {
+ if (!text->context)
+- return FALSE;
++ return false;
+ int64_t nativeLength = uTextUTF16ContextAwareNativeLength(text);
+ UBool isAccessible;
+ if (uTextAccessInChunkOrOutOfRange(text, nativeIndex, nativeLength, forward, isAccessible))
+@@ -145,7 +145,7 @@ static UBool uTextUTF16ContextAwareAccess(UText* text,
+ ASSERT(newContext == UTextProviderContext::PriorContext);
+ textUTF16ContextAwareSwitchToPriorContext(text, nativeIndex, nativeLength, forward);
+ }
+- return TRUE;
++ return true;
+ }
+
+ static int32_t uTextUTF16ContextAwareExtract(UText*, int64_t, int64_t, UChar*, int32_t, UErrorCode* errorCode)