summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksandar Trifunovic2018-08-22 14:34:25 +0200
committerAleksandar Trifunovic2018-08-22 14:34:25 +0200
commit81fcaed998f4ae15118d534ad09d6f8aa089bce1 (patch)
tree182edfbea8d94adb71a311389a4a137cb3d8518c
parent6a9a1c70d8f49e4e506c89eff4d6c2c8e06fff9d (diff)
downloadaur-81fcaed998f4ae15118d534ad09d6f8aa089bce1.tar.gz
v2.6.3; point to same commits for third party modules
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 393c3cc09b89..906b45ed83fd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = valhalla
pkgdesc = Routing engine for OpenStreetMap.
- pkgver = 2.6.2
+ pkgver = 2.6.3
pkgrel = 1
url = https://github.com/valhalla/valhalla
arch = x86_64
@@ -17,8 +17,8 @@ pkgbase = valhalla
depends = python
depends = lua
depends = libspatialite
- source = https://github.com/valhalla/valhalla/archive/2.6.2.tar.gz
- sha256sums = d6efbda5d66ea20dddf070dc70e9b4891270df2d3fa06d801f0f800aab011126
+ source = https://github.com/valhalla/valhalla/archive/2.6.3.tar.gz
+ sha256sums = 42db5bc48409983b4ccfd0a152347016e0a6dd6aa1313b9ba6896d2346df9d0b
pkgname = valhalla
diff --git a/PKGBUILD b/PKGBUILD
index 8767fb89c272..a6b4cc0c06f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aleksandar Trifunović <akstrfn@gmail.com>
pkgname=valhalla
-pkgver=2.6.2
+pkgver=2.6.3
pkgrel=1
pkgdesc="Routing engine for OpenStreetMap."
arch=('x86_64')
@@ -10,12 +10,17 @@ license=('custom:MIT')
depends=('prime_server' 'boost-libs' 'protobuf' 'python' 'lua' 'libspatialite')
makedepends=('cmake' 'git' 'vim' 'jq' 'boost' 'rapidjson')
source=("${url}/archive/$pkgver.tar.gz")
-sha256sums=('d6efbda5d66ea20dddf070dc70e9b4891270df2d3fa06d801f0f800aab011126')
+sha256sums=('42db5bc48409983b4ccfd0a152347016e0a6dd6aa1313b9ba6896d2346df9d0b')
prepare() {
cd "$pkgname-$pkgver"
- git clone --depth=1 https://github.com/scrosby/OSM-binary third_party/OSM-binary
- git clone --depth=1 https://github.com/valhalla/osmlr-tile-spec third_party/OSMLR
+ git clone https://github.com/scrosby/OSM-binary third_party/OSM-binary
+ git clone https://github.com/valhalla/osmlr-tile-spec third_party/OSMLR
+
+ cd "$srcdir/$pkgname-$pkgver"/third_party/OSM-binary && git checkout 4e32fa2
+ cd "$srcdir/$pkgname-$pkgver"/third_party/OSMLR && git checkout ae07abe
+
+ cd "$srcdir/$pkgname-$pkgver"
# TODO this seems fixed but tests are failing upstream anyway
# There is probably a better way to solve this. Sources: