summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadek Podgorny2022-05-09 18:52:29 +0200
committerRadek Podgorny2022-05-09 18:52:29 +0200
commit8219cc971a6d786326ada139460e0095d9415f64 (patch)
treed5f63a7d49c8db6685062861e3fa442a3d2214a9
parent3a08df5473016f06363ae570b81ab7e60a0f8512 (diff)
downloadaur-8219cc971a6d786326ada139460e0095d9415f64.tar.gz
version bump to 0.21.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--deque.patch11
-rw-r--r--qpainterpath.patch20
-rw-r--r--upnp-1.9.patch19
5 files changed, 6 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 00d3c49413e1..16f3eacf7451 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = litecoin-qt
pkgdesc = Peer-to-peer network based digital currency (QT)
- pkgver = 0.18.1
+ pkgver = 0.21.2
pkgrel = 4
url = http://www.litecoin.org/
install = litecoin-qt.install
@@ -16,15 +16,11 @@ pkgbase = litecoin-qt
depends = protobuf
depends = libevent
conflicts = litecoin
- source = https://download.litecoin.org/litecoin-0.18.1/src/litecoin-0.18.1.tar.gz
- source = deque.patch
- source = qpainterpath.patch
+ source = https://download.litecoin.org/litecoin-0.21.2/src/litecoin-0.21.2.tar.gz
source = boost1770.patch
source = litecoin-qt.desktop
source = litecoin128.png
- sha256sums = 6dfa71ccf059463f0a304f85ff1ca8b88039d63e93269d6f056ab24915be936d
- sha256sums = 595b465639a0ac22c262da404b942d682b8bda5f010db9b13d07b671b3877af1
- sha256sums = d7716150afe7cd49b708699c27f5e39835b6849c4839c005ff36b4e06ccd9593
+ sha256sums = 255263d27e409628ddaf7165f8d8363cefbd683bde613c3e7623a27f9733ada2
sha256sums = 3ccbff49fef5a7e820168f4c4b75ae9a1e74e81dc08587145aa85599254b85e5
sha256sums = cfc53dc9028745358235698ddd562d3e6b4a3ea9f896f5efc1aa8cd81f595559
sha256sums = 79fb205581c1e6df9758b56e2b527350f23124677036bc68176d088c4a28af8d
diff --git a/PKGBUILD b/PKGBUILD
index caa0fb44f017..4f76a06717cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Nicolas Doualot <packages at slubman.info>
pkgname=litecoin-qt
-pkgver=0.18.1
-pkgrel=4
+pkgver=0.21.2
+pkgrel=1
arch=('i686' 'x86_64')
url="http://www.litecoin.org/"
license=('MIT')
@@ -14,22 +14,16 @@ makedepends=(boost qt5-tools)
conflicts=(litecoin)
install=litecoin-qt.install
source=("https://download.litecoin.org/litecoin-${pkgver}/src/litecoin-${pkgver}.tar.gz"
- "deque.patch"
- "qpainterpath.patch"
"boost1770.patch"
"$pkgname.desktop"
"litecoin128.png")
-sha256sums=('6dfa71ccf059463f0a304f85ff1ca8b88039d63e93269d6f056ab24915be936d'
- '595b465639a0ac22c262da404b942d682b8bda5f010db9b13d07b671b3877af1'
- 'd7716150afe7cd49b708699c27f5e39835b6849c4839c005ff36b4e06ccd9593'
+sha256sums=('255263d27e409628ddaf7165f8d8363cefbd683bde613c3e7623a27f9733ada2'
'3ccbff49fef5a7e820168f4c4b75ae9a1e74e81dc08587145aa85599254b85e5'
'cfc53dc9028745358235698ddd562d3e6b4a3ea9f896f5efc1aa8cd81f595559'
'79fb205581c1e6df9758b56e2b527350f23124677036bc68176d088c4a28af8d')
build() {
cd "$srcdir/litecoin-$pkgver"
- patch -p2 <$srcdir/deque.patch
- patch -p1 <$srcdir/qpainterpath.patch
patch -p1 <$srcdir/boost1770.patch
./autogen.sh
./configure --with-incompatible-bdb --with-gui=qt5
diff --git a/deque.patch b/deque.patch
deleted file mode 100644
index 8d823fc7a747..000000000000
--- a/deque.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ur src2/litecoin-0.17.1/src/httpserver.cpp src/litecoin-0.17.1/src/httpserver.cpp
---- src2/litecoin-0.17.1/src/httpserver.cpp 2019-04-08 14:28:20.000000000 +0700
-+++ src/litecoin-0.17.1/src/httpserver.cpp 2020-02-03 18:31:55.196768990 +0700
-@@ -30,6 +30,7 @@
- #include <event2/keyvalq_struct.h>
-
- #include <support/events.h>
-+#include <deque>
-
- #ifdef EVENT__HAVE_NETINET_IN_H
- #include <netinet/in.h>
diff --git a/qpainterpath.patch b/qpainterpath.patch
deleted file mode 100644
index a20e50ac4c20..000000000000
--- a/qpainterpath.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-commit 990d5e8fa20b7d6b4b8c629d143e180437ecdffc
-Author: Andrew Chow <achow101-github@achow101.com>
-Date: Thu May 28 14:56:47 2020 -0400
-
- Add missing QPainterPath include
-
- This is needed to compile with Qt 5.15.
-
-diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
-index 1588be8da..b0091ada3 100644
---- a/src/qt/trafficgraphwidget.cpp
-+++ b/src/qt/trafficgraphwidget.cpp
-@@ -7,6 +7,7 @@
- #include <qt/clientmodel.h>
-
- #include <QPainter>
-+#include <QPainterPath>
- #include <QColor>
- #include <QTimer>
-
diff --git a/upnp-1.9.patch b/upnp-1.9.patch
deleted file mode 100644
index 42e6cf18e8d0..000000000000
--- a/upnp-1.9.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naur a/src/net.cpp b/src/net.cpp
---- a/src/net.cpp 2015-06-15 10:51:30.000000000 +0200
-+++ b/src/net.cpp 2015-10-03 16:15:10.441886309 +0200
-@@ -1020,10 +1020,14 @@
- #ifndef UPNPDISCOVER_SUCCESS
- /* miniupnpc 1.5 */
- devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0);
--#else
-+#elif MINIUPNPC_API_VERSION < 14
- /* miniupnpc 1.6 */
- int error = 0;
- devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, &error);
-+#else
-+ /* miniupnpc 1.9.20150730 */
-+ int error = 0;
-+ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, 2, &error);
- #endif
-
- struct UPNPUrls urls;