summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleksandr Natalenko2022-07-16 19:03:10 +0200
committerOleksandr Natalenko2022-07-16 19:03:10 +0200
commit82298aba9794b2d10b6452999818047ec6d31c06 (patch)
treeb60f37f5e71cd8e1eb61f2205b1a454878b6fecc
parentbb8c4b0c9a921a6d077f614b35a0b7fb65591032 (diff)
downloadaur-82298aba9794b2d10b6452999818047ec6d31c06.tar.gz
update to v22.01
Signed-off-by: Oleksandr Natalenko <oleksandr@natalenko.name>
-rw-r--r--.SRCINFO12
-rw-r--r--01-gcc-12.patch17
-rw-r--r--PKGBUILD16
-rw-r--r--meson.build2
4 files changed, 11 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf4b18bbe84e..8afeb2ca3750 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = 7-zip
pkgdesc = File archiver with a high compression ratio
- pkgver = 22.00
- pkgrel = 2
+ pkgver = 22.01
+ pkgrel = 1
url = https://www.7-zip.org
arch = x86_64
license = LGPL
@@ -9,11 +9,9 @@ pkgbase = 7-zip
license = custom:unRAR
makedepends = uasm
makedepends = meson
- source = https://7-zip.org/a/7z2200-src.tar.xz
- source = 01-gcc-12.patch
+ source = https://7-zip.org/a/7z2201-src.tar.xz
source = meson.build
- sha256sums = 40969f601e86aff49aaa0ba0df5ce6fd397cf7e2683a84b591b0081e461ef675
- sha256sums = e4d34366e091b8404dd04f02bcad46518d2930ec0b4a420e1316db020234b085
- sha256sums = d1171dd766792cb9d927aed289a7c5bddbd328bf1bcbbf3ed74311abf1e24be5
+ sha256sums = 393098730c70042392af808917e765945dc2437dee7aae3cfcc4966eb920fbc5
+ sha256sums = 9ed64c321a4425a8874c56aa0c64132829001be5ad8fdda28426254b723829a1
pkgname = 7-zip
diff --git a/01-gcc-12.patch b/01-gcc-12.patch
deleted file mode 100644
index 18f76e4a689d..000000000000
--- a/01-gcc-12.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- a/C/LzmaEnc.c 2021-11-18 19:00:00.000000000 +0100
-+++ b/C/LzmaEnc.c 2022-05-12 20:59:51.038852048 +0200
-@@ -2993,12 +2993,13 @@
-
- nowPos64 = p->nowPos64;
- RangeEnc_Init(&p->rc);
-- p->rc.outStream = &outStream.vt;
-
- if (desiredPackSize == 0)
- return SZ_ERROR_OUTPUT_EOF;
-
-+ p->rc.outStream = &outStream.vt;
- res = LzmaEnc_CodeOneBlock(p, desiredPackSize, *unpackSize);
-+ p->rc.outStream = NULL;
-
- *unpackSize = (UInt32)(p->nowPos64 - nowPos64);
- *destLen -= outStream.rem;
diff --git a/PKGBUILD b/PKGBUILD
index 932aa5a2e349..10bb7694968e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,17 @@
# Maintainer: Oleksandr Natalenko <oleksandr@natalenko.name>
pkgname=7-zip
-pkgver=22.00
-pkgrel=2
+pkgver=22.01
+pkgrel=1
pkgdesc="File archiver with a high compression ratio"
url="https://www.7-zip.org"
license=('LGPL' 'BSD' 'custom:unRAR')
arch=(x86_64)
makedepends=(uasm meson)
-source=(https://7-zip.org/a/7z2200-src.tar.xz
- 01-gcc-12.patch
+source=(https://7-zip.org/a/7z2201-src.tar.xz
meson.build)
-sha256sums=('40969f601e86aff49aaa0ba0df5ce6fd397cf7e2683a84b591b0081e461ef675'
- 'e4d34366e091b8404dd04f02bcad46518d2930ec0b4a420e1316db020234b085'
- 'd1171dd766792cb9d927aed289a7c5bddbd328bf1bcbbf3ed74311abf1e24be5')
-
-prepare() {
- patch -Np1 -i 01-gcc-12.patch
-}
+sha256sums=('393098730c70042392af808917e765945dc2437dee7aae3cfcc4966eb920fbc5'
+ '9ed64c321a4425a8874c56aa0c64132829001be5ad8fdda28426254b723829a1')
build() {
arch-meson . build
diff --git a/meson.build b/meson.build
index da4ae7d120c6..9f48e66ccbd1 100644
--- a/meson.build
+++ b/meson.build
@@ -4,7 +4,7 @@ project(
'c',
'cpp',
],
- version: '22.00',
+ version: '22.01',
default_options: [
'warning_level=2',
'werror=true',