summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-11-08 08:04:23 +0330
committerMohammadreza Abdollahzadeh2022-11-08 08:04:23 +0330
commit8252c415c8450be2afb296e407e719199f0177da (patch)
treea664b8cf7eb434065a774e3e3e27b59f42bcc0e7
parent0946a9807637ed08587628e140641b618bf0a8e5 (diff)
downloadaur-8252c415c8450be2afb296e407e719199f0177da.tar.gz
upgpkg: python-obspy-docs 1.3.1-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37514d96dd45..191bcc2df007 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,12 @@
pkgbase = python-obspy-docs
pkgdesc = Set of HTML documentation for Obspy seismological framework.
- pkgver = 1.3.0
+ pkgver = 1.3.1
pkgrel = 1
url = http://docs.obspy.org
arch = any
license = LGPL
- makedepends = python-cartopy
- makedepends = python-obspy
- makedepends = python-m2r2
- makedepends = python-matplotlib
- makedepends = python-sphinx
- makedepends = python-sphinx_rtd_theme
options = docs
- source = python-obspy-1.3.0.tar.gz::https://github.com/obspy/obspy/archive/1.3.0.tar.gz
- sha256sums = 12a5ba9cae3445c9f31bd0e0561e791bc755cc627d4412f851f6286fef82be34
+ source = https://github.com/obspy/obspy/releases/download/1.3.1/obspy-1.3.1-documentation.tgz
+ sha256sums = bf9674ade7f351c59c0ef016c9714212d1c99ef0bcd2c9743644aa878a2a8d14
pkgname = python-obspy-docs
diff --git a/PKGBUILD b/PKGBUILD
index edb4ef2ef680..78d3d6c16d49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,19 @@
# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
pkgname=python-obspy-docs
-pkgver=1.3.0
+pkgver=1.3.1
pkgrel=1
pkgdesc='Set of HTML documentation for Obspy seismological framework.'
arch=('any')
url='http://docs.obspy.org'
license=('LGPL')
options=('docs')
-makedepends=('python-cartopy' 'python-obspy' 'python-m2r2' 'python-matplotlib' 'python-sphinx' 'python-sphinx_rtd_theme')
-source=("${pkgname%-docs}-${pkgver}.tar.gz::https://github.com/obspy/obspy/archive/${pkgver}.tar.gz")
-sha256sums=('12a5ba9cae3445c9f31bd0e0561e791bc755cc627d4412f851f6286fef82be34')
-
-build() {
- cd "obspy-${pkgver}/misc/docs"
- mkdir _build
- sphinx-build -a -E -j auto -b html source _build
-}
+source=("https://github.com/obspy/obspy/releases/download/${pkgver}/obspy-${pkgver}-documentation.tgz")
+sha256sums=('bf9674ade7f351c59c0ef016c9714212d1c99ef0bcd2c9743644aa878a2a8d14')
package() {
- cd "obspy-${pkgver}/misc/docs"
install -d ${pkgdir}/usr/share/doc/python-obspy
- cp -a _build ${pkgdir}/usr/share/doc/python-obspy/html
+ cp -r obspy-documentation-${pkgver} ${pkgdir}/usr/share/doc/python-obspy/html
+ chmod -R a=rX,u=rwX ${pkgdir}/usr/share/doc/python-obspy/html
}
# vim:set ts=4 sw=4 et: