summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-02-23 17:46:57 +0100
committerhaawda2019-02-23 17:46:57 +0100
commit825f31ac831281a08b465abcd001922ae33b2280 (patch)
treef4c1792503974bade2a1ee08e53c936c021b1882
downloadaur-825f31ac831281a08b465abcd001922ae33b2280.tar.gz
initial upload
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD36
-rw-r--r--emacs-cider.install24
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4be5f0461325
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = emacs-cider-git
+ pkgdesc = The Clojure Interactive Development Environment that Rocks for Emacs
+ pkgver = 0.21.0r11.g62134b4f
+ pkgrel = 1
+ url = https://github.com/clojure-emacs/cider
+ install = emacs-cider.install
+ arch = any
+ license = GPL3
+ depends = emacs
+ depends = emacs-clojure-mode
+ depends = emacs-pkg-info
+ depends = emacs-queue
+ depends = emacs-spinner
+ depends = emacs-sesman
+ depends = emacs-seq
+ provides = emacs-cider
+ conflicts = emacs-cider
+ source = git+https://github.com/clojure-emacs/cider.git
+ sha256sums = SKIP
+
+pkgname = emacs-cider-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec7f135e3a86
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Alex Whitt <alex.joseph.whitt@gmail.com>
+# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+
+_pkgsrcname=cider
+_pkgmaintainer=clojure-emacs
+_pkgdestdirname=cider
+_versionprefix=v
+pkgver=0.21.0r11.g62134b4f
+pkgrel=1
+pkgdesc="The Clojure Interactive Development Environment that Rocks for Emacs"
+pkgname=emacs-${_pkgdestdirname}-git
+arch=('any')
+url="https://github.com/${_pkgmaintainer}/${_pkgsrcname}"
+license=('GPL3')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+depends=('emacs' 'emacs-clojure-mode' 'emacs-pkg-info' 'emacs-queue' 'emacs-spinner' 'emacs-sesman' 'emacs-seq')
+source=("git+$url.git")
+sha256sums=('SKIP')
+install=${pkgname%-git}.install
+
+pkgver() {
+ cd ${_pkgsrcname}
+ git describe --tags|sed 's+-+r+'|tr - .|cut -c2-
+}
+
+build() {
+ cd ${_pkgsrcname}
+ emacs -q --no-splash -batch -L . -f batch-byte-compile *.el
+}
+
+package() {
+ cd ${_pkgsrcname}
+ install -d "$pkgdir"/usr/share/emacs/site-lisp/
+ install -m644 *.el{c,} "$pkgdir"/usr/share/emacs/site-lisp
+}
diff --git a/emacs-cider.install b/emacs-cider.install
new file mode 100644
index 000000000000..3855d6497b51
--- /dev/null
+++ b/emacs-cider.install
@@ -0,0 +1,24 @@
+post_install () {
+
+cat << EOF
+
+==> Add this code to your .emacs file to use the mode:
+
+(require 'cider)
+
+==> Or, with use-package:
+
+(use-package cider)
+
+==> From the README:
+
+Simply open in Emacs a file belonging to your lein or boot project (like foo.clj) and type M-x cider-jack-in. This will start an nREPL server with all the project dependencies loaded in and CIDER will automatically connect to it.
+
+Alternatively you can use C-u M-x cider-jack-in to specify the name of a lein or boot project, without having to visit any file in it.
+
+EOF
+}
+
+post_upgrade () {
+ post_install $1
+}