summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteven Honeyman2015-06-09 19:08:16 +0100
committerSteven Honeyman2015-06-09 19:08:16 +0100
commit82734e3b66d627b06b45fd20719e87d4a50a1081 (patch)
treef718fa1e70cec1394a388ee0f4635c064cd2187d
downloadaur-82734e3b66d627b06b45fd20719e87d4a50a1081.tar.gz
Initial import
-rw-r--r--.AURINFO32
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD55
-rw-r--r--gimp-2.8.10-device_info.patch33
-rw-r--r--gimp-2.8.10-freetype.patch22
-rw-r--r--sessionrc74
6 files changed, 252 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..9985a31524a3
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,32 @@
+pkgbase = gimp-light
+ pkgdesc = A trimmed down install of the GNU Image Manipulation Program
+ pkgver = 2.8.10
+ pkgrel = 4
+ url = http://www.gimp.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = intltool
+ depends = gtk2
+ depends = babl
+ depends = gegl
+ depends = libexif
+ depends = libxpm
+ depends = libjpeg
+ depends = libpng
+ provides = gimp
+ conflicts = gimp-devel
+ conflicts = gimp
+ source = http://download.gimp.org/pub/gimp/v2.8/gimp-2.8.10.tar.bz2
+ source = gimp-2.8.10-freetype.patch
+ source = gimp-2.8.10-device_info.patch
+ source = sessionrc
+ options = strip
+ options = !docs
+ options = !libtool
+ options = !staticlibs
+ options = emptydirs
+
+pkgname = gimp-light
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..813afc18b052
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = gimp-light
+ pkgdesc = A trimmed down install of the GNU Image Manipulation Program
+ pkgver = 2.8.10
+ pkgrel = 4
+ url = http://www.gimp.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = pkgconfig
+ makedepends = intltool
+ depends = gtk2
+ depends = babl
+ depends = gegl
+ depends = libexif
+ depends = libxpm
+ depends = libjpeg
+ depends = libpng
+ provides = gimp
+ conflicts = gimp-devel
+ conflicts = gimp
+ options = strip
+ options = !docs
+ options = !libtool
+ options = !staticlibs
+ options = emptydirs
+ source = http://download.gimp.org/pub/gimp/v2.8/gimp-2.8.10.tar.bz2
+ source = gimp-2.8.10-freetype.patch
+ source = gimp-2.8.10-device_info.patch
+ source = sessionrc
+ md5sums = 84c964aab7044489af69f7319bb59b47
+ md5sums = 1697c634d69cb77f75f6db84f49222d6
+ md5sums = 39737fc47ee4556740790e9d3a243bf1
+ md5sums = 37996178b9a5854b89db6d518cfd23fc
+
+pkgname = gimp-light
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc10569dd317
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Steven Honeyman <stevenhoneyman at gmail com>
+
+pkgname=gimp-light
+pkgver=2.8.10
+pkgrel=4
+pkgdesc="A trimmed down install of the GNU Image Manipulation Program"
+arch=('i686' 'x86_64')
+url="http://www.gimp.org/"
+license=('GPL')
+depends=('gtk2' 'babl' 'gegl' 'libexif' 'libxpm' 'libjpeg' 'libpng')
+makedepends=('pkgconfig' 'intltool')
+provides=(gimp)
+conflicts=('gimp-devel' 'gimp')
+options=(strip !docs !libtool !staticlibs emptydirs)
+source=(http://download.gimp.org/pub/gimp/v${pkgver%.*}/gimp-${pkgver}.tar.bz2
+ gimp-2.8.10-freetype.patch
+ gimp-2.8.10-device_info.patch
+ sessionrc
+ )
+md5sums=('84c964aab7044489af69f7319bb59b47'
+ '1697c634d69cb77f75f6db84f49222d6'
+ '39737fc47ee4556740790e9d3a243bf1'
+ '37996178b9a5854b89db6d518cfd23fc')
+
+prepare() {
+ cd "$srcdir/gimp-$pkgver"
+ patch -p1 -i "$srcdir/gimp-2.8.10-freetype.patch"
+ patch -p1 -i "$srcdir/gimp-2.8.10-device_info.patch"
+}
+
+build() {
+ cd "$srcdir/gimp-$pkgver"
+ ALL_LINGUAS="en en_GB" ./configure --prefix=/usr --sysconfdir=/etc \
+ --enable-shared --disable-debug --disable-python \
+ --disable-gimp-console --without-aa --without-libxpm \
+ --without-libmng --without-wmf --without-webkit \
+ --without-poppler --without-gvfs --without-lcms \
+ --without-alsa --without-libcurl --without-dbus \
+ --without-linux-input --without-mac-twain --without-xmc
+ make
+}
+
+package() {
+ cd "$srcdir/gimp-$pkgver"
+ make DESTDIR="$pkgdir" install-strip
+ sed -i 's/# (theme "Default")/(theme "Small")/' $pkgdir/etc/gimp/2.0/gimprc
+ sed -i 's/# (save-document-history yes)/(save-document-history no)/' $pkgdir/etc/gimp/2.0/gimprc
+ install -D -m644 $srcdir/sessionrc $pkgdir/etc/gimp/2.0/sessionrc
+ rm $pkgdir/usr/bin/gimptool-2.0
+ rm $pkgdir/usr/share/locale/en_GB/LC_MESSAGES/gimp20-{python,tips}.mo
+ rm -r $pkgdir/usr/include $pkgdir/usr/lib/gimp/2.0/{environ,interpreters,modules}
+ rm -r $pkgdir/usr/share/{aclocal,appdata,gtk-doc,man}
+ rm -r $pkgdir/usr/share/icons/hicolor/256x256 $pkgdir/usr/share/gimp/2.0/tips
+ find $pkgdir/usr/share/locale -mindepth 1 -maxdepth 1 ! -name "en_GB" -exec rm -r '{}' \;
+}
diff --git a/gimp-2.8.10-device_info.patch b/gimp-2.8.10-device_info.patch
new file mode 100644
index 000000000000..1fb2c15db268
--- /dev/null
+++ b/gimp-2.8.10-device_info.patch
@@ -0,0 +1,33 @@
+Submitted By: Fernando de Oliveira <famobr at yahoo dot com dot br>
+Date: 2013-11-30
+Initial Package Version: 2.8.10
+Upstream Status: Unknown
+Origin: ubuntuforums
+URL: http://ubuntuforums.org/showthread.php?t=1984743&page=8&p=12273558#post12273558
+Description: Fixes "Gimp-Widgets-CRITICAL **: gimp_device_info_set_device ..." annoying message by making "sure the configure input device dialog displays all of the devices" and fixes tests
+
+--- gimp-2.8.10/app/widgets/gimpdevicemanager.c.orig 2012-11-22 21:21:24.000000000 -0300
++++ gimp-2.8.10/app/widgets/gimpdevicemanager.c 2013-11-30 11:54:30.275906582 -0300
+@@ -321,19 +321,19 @@
+ GIMP_DEVICE_INFO (gimp_container_get_child_by_name (GIMP_CONTAINER (manager),
+ device->name));
+
+- if (device_info)
++ /* if (device_info)
+ {
+ gimp_device_info_set_device (device_info, device, gdk_display);
+ }
+ else
+- {
++ {*/
+ device_info = gimp_device_info_new (private->gimp, device, gdk_display);
+
+ gimp_device_info_set_default_tool (device_info);
+
+ gimp_container_add (GIMP_CONTAINER (manager), GIMP_OBJECT (device_info));
+ g_object_unref (device_info);
+- }
++ //}
+ }
+
+ static void
diff --git a/gimp-2.8.10-freetype.patch b/gimp-2.8.10-freetype.patch
new file mode 100644
index 000000000000..7f2c3940533e
--- /dev/null
+++ b/gimp-2.8.10-freetype.patch
@@ -0,0 +1,22 @@
+Submitted By: Fernando de Oliveira <famobr at yahoo dot com dot br>
+Date: 2013-11-30
+Initial Package Version: 2.8.10
+Upstream Status: Committed
+Origin: gnome
+URL: http://osdir.com/ml/commits.gnome/2013-11/msg07247.html
+Description: Fixes build with FreeType-2.5.1
+
+diff -Naur gimp-2.8.10/app/text/gimpfont.c.orig gimp-2.8.10/app/text/gimpfont.c
+--- gimp-2.8.10/app/text/gimpfont.c.orig 2012-05-08 03:05:46.000000000 -0300
++++ gimp-2.8.10/app/text/gimpfont.c 2013-11-30 10:44:21.996609469 -0300
+@@ -27,7 +27,9 @@
+
+ #define PANGO_ENABLE_ENGINE 1 /* Argh */
+ #include <pango/pango-ot.h>
+-#include <freetype/tttables.h>
++
++#include <ft2build.h>
++#include FT_TRUETYPE_TABLES_H
+
+ #include "text-types.h"
+
diff --git a/sessionrc b/sessionrc
new file mode 100644
index 000000000000..77473eae5092
--- /dev/null
+++ b/sessionrc
@@ -0,0 +1,74 @@
+# GIMP sessionrc
+#
+# This file takes session-specific info (that is info, you want to keep
+# between two GIMP sessions). You are not supposed to edit it manually, but
+# of course you can do. The sessionrc will be entirely rewritten every time
+# you quit GIMP. If this file isn't found, defaults are used.
+
+(session-info "toplevel"
+ (factory-entry "gimp-empty-image-window")
+ (position 410 370)
+ (size 620 200)
+ (open-on-exit))
+(session-info "toplevel"
+ (factory-entry "gimp-single-image-window")
+ (open-on-exit)
+ (aux-info
+ (left-docks-width "150")
+ (right-docks-width "205")
+ (maximized "yes"))
+ (gimp-toolbox
+ (side left)
+ (book
+ (current-page 0)
+ (dockable "gimp-tool-options"
+ (tab-style automatic)
+ (aux-info
+ (show-button-bar "true")))))
+ (gimp-dock
+ (side right)
+ (book
+ (current-page 0)
+ (dockable "gimp-layer-list"
+ (tab-style automatic)
+ (preview-size 32)
+ (aux-info
+ (show-button-bar "true")))
+ (dockable "gimp-channel-list"
+ (tab-style automatic)
+ (preview-size 32)
+ (aux-info
+ (show-button-bar "true")))
+ (dockable "gimp-vectors-list"
+ (tab-style automatic)
+ (preview-size 32)
+ (aux-info
+ (show-button-bar "true")))
+ (dockable "gimp-undo-history"
+ (tab-style automatic)
+ (aux-info
+ (show-button-bar "true"))))
+ (book
+ (position 521)
+ (current-page 0)
+ (dockable "gimp-brush-grid"
+ (tab-style automatic)
+ (aux-info
+ (show-button-bar "true")))
+ (dockable "gimp-pattern-grid"
+ (tab-style automatic)
+ (aux-info
+ (show-button-bar "true")))
+ (dockable "gimp-gradient-list"
+ (tab-style automatic)
+ (aux-info
+ (show-button-bar "true"))))))
+(session-info "toplevel"
+ (factory-entry "gimp-preferences-dialog")
+ (position 0 128))
+
+(hide-docks no)
+(single-window-mode yes)
+(last-tip-shown 0)
+
+# end of sessionrc