summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXiretza2023-09-24 12:56:26 +0000
committerXiretza2023-09-24 12:56:26 +0000
commit829c6e4dc8d124d099926def98eec75ea3f438c2 (patch)
tree8d8fa31ec9f1799e7cb6aa8201679da5386a70d3
parentb4aa36c94e43aaf6a0e3be89ccd622e17b59b1a2 (diff)
downloadaur-829c6e4dc8d124d099926def98eec75ea3f438c2.tar.gz
Remove outdated patch
-rw-r--r--.SRCINFO2
-rw-r--r--0001-fix-set-C-standard-to-14.patch30
-rw-r--r--PKGBUILD7
3 files changed, 1 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e44dc686fdf..1015980bf9bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,7 +24,6 @@ pkgbase = prjxray-git
source = git+https://github.com/google/cctz
source = git+https://github.com/abseil/abseil-cpp
source = git+https://github.com/jbeder/yaml-cpp
- source = 0001-fix-set-C-standard-to-14.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
@@ -32,7 +31,6 @@ pkgbase = prjxray-git
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 5f47ffb9b89b976046588968f9a5038da7612211c1a85b396d62a24973941730
pkgname = prjxray-tools-git
depends = gcc-libs
diff --git a/0001-fix-set-C-standard-to-14.patch b/0001-fix-set-C-standard-to-14.patch
deleted file mode 100644
index 3009702c4ca8..000000000000
--- a/0001-fix-set-C-standard-to-14.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 10e2d2c8fc16de6eac4579bb022a36b16b8f1b69 Mon Sep 17 00:00:00 2001
-From: Xiretza <xiretza@xiretza.xyz>
-Date: Sun, 29 May 2022 20:31:49 +0200
-Subject: [PATCH] fix: set C++ standard to 14
-
-GCC >= 11 defaults to C++17, but abseil needs to be compiled with the
-same standard as the rest of the codebase, which sets CMAKE_CXX_STANDARD
-to 14.
-
-https://github.com/f4pga/prjxray/issues/1950
----
- CMakeLists.txt | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8a20d04a..029fc1f5 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -21,6 +21,8 @@
- # and then issuing `yum install cmake3` on the command line.
- cmake_minimum_required(VERSION 3.5)
-
-+set(CMAKE_CXX_STANDARD 14)
-+
- # Compiler id for Apple Clang is now AppleClang.
- if (POLICY CMP0025)
- cmake_policy(SET CMP0025 NEW)
---
-2.36.1
-
diff --git a/PKGBUILD b/PKGBUILD
index f25a3b6d0fe6..8bb8180a7810 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,6 @@ source=("git+$url"
"git+https://github.com/google/cctz"
"git+https://github.com/abseil/abseil-cpp"
"git+https://github.com/jbeder/yaml-cpp"
- '0001-fix-set-C-standard-to-14.patch'
)
sha256sums=('SKIP'
'SKIP'
@@ -31,8 +30,7 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '5f47ffb9b89b976046588968f9a5038da7612211c1a85b396d62a24973941730')
+ 'SKIP')
pkgver() {
cd "$_pkgbase"
@@ -55,9 +53,6 @@ prepare() {
cd third_party
git submodule update "${_mods[@]}"
-
- cd abseil-cpp
- patch -p1 < "$srcdir/0001-fix-set-C-standard-to-14.patch"
}
build() {