summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSampson Crowley2021-02-16 17:17:52 -0700
committerSampson Crowley2021-02-16 17:17:52 -0700
commit82dfae64260437e89c183cb16b77d011fd581258 (patch)
treeca55f89cb84ac2a3163b5e481e65690dbc1c55ef
downloadaur-82dfae64260437e89c183cb16b77d011fd581258.tar.gz
Initial upload: php-version 0.13.0-1
add php-version package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD27
-rw-r--r--php-version.install13
4 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31638fd1ec48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = php-version
+ pkgdesc = Chruby-like (a.k.a. simple) script for switching between PHP versions
+ pkgver = 0.13.0
+ pkgrel = 1
+ url = https://github.com/wilmoore/php-version/wiki/Installing
+ install = php-version.install
+ arch = any
+ license = MIT
+ provides = php-version
+ conflicts = phpenv
+ source = https://github.com/wilmoore/php-version/archive/0.13.0.tar.gz
+ sha256sums = 5ca48f1e478b691072f4c2c62827f3cc063687cb54fe7c8eb6168a9924991ac5
+ sha512sums = ef79a63c66b79d23b85f3d6140ccca8c3b6329c733c94ad01a0595c118107e9e6c74678e1629b3e2e7e289ba6ac7b9c3535e3e4fe3895e7430fc1cfdf91c1ee6
+
+pkgname = php-version
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..588282de316c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg
+*.pkg.tar*
+/*.*.*.tar.gz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99e054068ae6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Sampson Crowley <sampsonsprojects@gmail.com>
+# Contributor: Rhys Kenwell <redrield+aur@gmail.com>
+# Github Contributor: Michael Herold <https://github.com/michaelherold>
+
+pkgname=php-version
+pkgver=0.13.0
+pkgrel=1
+_builddir="php-version-$pkgver-$pkgrel"
+pkgdesc="Chruby-like (a.k.a. simple) script for switching between PHP versions"
+arch=('any')
+url="https://github.com/wilmoore/php-version/wiki/Installing"
+license=('MIT')
+conflicts=('phpenv')
+source=("https://github.com/wilmoore/php-version/archive/$pkgver.tar.gz")
+sha256sums=('5ca48f1e478b691072f4c2c62827f3cc063687cb54fe7c8eb6168a9924991ac5')
+sha512sums=('ef79a63c66b79d23b85f3d6140ccca8c3b6329c733c94ad01a0595c118107e9e6c74678e1629b3e2e7e289ba6ac7b9c3535e3e4fe3895e7430fc1cfdf91c1ee6')
+provides=('php-version')
+install="$pkgname.install"
+
+package() {
+ install -dm755 "$pkgdir/usr/lib/$pkgname"
+
+ install -D -m755 "$srcdir/$pkgname-$pkgver/php-version.sh" "$pkgdir/usr/lib/$pkgname/php-version.sh"
+ install -D -m755 "$srcdir/$pkgname-$pkgver/bug-report.sh" "$pkgdir/usr/lib/$pkgname/bug-report.sh"
+ install -D -m644 "$srcdir/$pkgname-$pkgver/changelog.md" "$pkgdir/usr/lib/$pkgname/changelog.md"
+ install -D -m644 "$srcdir/$pkgname-$pkgver/README.md" "$pkgdir/usr/lib/$pkgname/README.md"
+}
diff --git a/php-version.install b/php-version.install
new file mode 100644
index 000000000000..9235ff569f29
--- /dev/null
+++ b/php-version.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo 'To Enable "php-version" source the shell script:'
+ echo 'source /usr/lib/php-version/php-version.sh'
+ echo ""
+
+ echo 'To Select a specific PHP version with "php-version" call the "php-version" function:'
+ echo 'php-version 7.2.0'
+ echo ""
+
+ echo "For detailed instructions on building PHP Versions visit:"
+ echo "https://github.com/wilmoore/php-version/wiki/Building-PHP-Versions"
+ echo ""
+}