summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRhinoceros2023-01-10 22:19:28 +1100
committerRhinoceros2023-01-10 22:19:28 +1100
commit82e75a13bf501cc5ef41966d3000378a9ce8dce8 (patch)
tree6dae7ec2a20024ac2bdb3de6b48ac1cb2c55a829
parent4c0b581c071737531ba7ede3d21261f4e8de0d51 (diff)
downloadaur-82e75a13bf501cc5ef41966d3000378a9ce8dce8.tar.gz
Update to 9.3-1
* Upstream changelog: "Improved to follow the 'wincolor' option. Fixed to work on some color scheme." * Upstream added a license
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18e69ba3bd1f..5e34f4936d0e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = vim-diffchar
pkgdesc = Improve vim's diff mode, by finding exact differences between lines, character by character
- pkgver = 9.2
+ pkgver = 9.3
pkgrel = 1
url = http://www.vim.org/scripts/script.php?script_id=4932
arch = any
groups = vim-plugins
- license = unknown
+ license = MIT
depends = vim
- source = vim-diffchar-9.2.zip::https://www.vim.org/scripts/download_script.php?src_id=28304
- sha256sums = abf1c939d9800420f869fa92965b5ddf7cf0bf75fbd937bed2b851ce1137ae13
+ source = vim-diffchar-9.3.zip::https://www.vim.org/scripts/download_script.php?src_id=28342
+ source = vim-diffchar-LICENSE::https://raw.githubusercontent.com/rickhowe/diffchar.vim/master/LICENSE
+ sha256sums = 1c8c8e9d49fd3167bbe8b06af148f618ffb8de36081b23f7778dca7f640ac9da
+ sha256sums = 8f786990b7611d1208eb9b27c107e3f7c2b25da8d83f48488be63097bc7f529d
pkgname = vim-diffchar
diff --git a/PKGBUILD b/PKGBUILD
index d3a575acffdd..172f80d4e756 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
pkgname=vim-diffchar
-pkgver=9.2
+pkgver=9.3
pkgrel=1
pkgdesc="Improve vim's diff mode, by finding exact differences between lines, character by character"
arch=('any')
url='http://www.vim.org/scripts/script.php?script_id=4932'
-license=('unknown') # no licence https://github.com/rickhowe/diffchar.vim/issues/3
+license=('MIT')
depends=('vim')
groups=('vim-plugins')
-source=("$pkgname-$pkgver.zip::https://www.vim.org/scripts/download_script.php?src_id=28304")
-sha256sums=('abf1c939d9800420f869fa92965b5ddf7cf0bf75fbd937bed2b851ce1137ae13')
+source=("$pkgname-$pkgver.zip::https://www.vim.org/scripts/download_script.php?src_id=28342"
+ "${pkgname}-LICENSE::https://raw.githubusercontent.com/rickhowe/diffchar.vim/master/LICENSE")
+sha256sums=('1c8c8e9d49fd3167bbe8b06af148f618ffb8de36081b23f7778dca7f640ac9da'
+ '8f786990b7611d1208eb9b27c107e3f7c2b25da8d83f48488be63097bc7f529d')
prepare() {
rm doc/tags
@@ -20,4 +22,6 @@ package() {
_installpath="${pkgdir}/usr/share/vim/vimfiles"
mkdir -p "${_installpath}"
cp -r autoload doc plugin "${_installpath}"
+
+ install -Dm644 "${pkgname}-LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}