summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2018-03-16 10:19:52 -0400
committerJames An2018-03-16 10:32:24 -0400
commit82f51f5fa3a9f3ecd8af20c7587ede697d361ccd (patch)
treeb7a31626b573f5eb63200f2d4795316d945b3f93
parentc4e9f67483589e575631b6b298e7f770ef995f67 (diff)
downloadaur-82f51f5fa3a9f3ecd8af20c7587ede697d361ccd.tar.gz
Updated to latest upstream version and patched for updated libfvalue.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD9
-rw-r--r--libfvalue_string.patch31
3 files changed, 41 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39388068ba7e..4379fdbb4c3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Feb 23 17:05:17 UTC 2016
pkgbase = libfvde-git
pkgdesc = Library and tools to access FileVault Drive Encryption (FVDE) encrypted volumes
- pkgver = 20151013.r6.g82c2461
+ pkgver = 20180108.r0.g3584a32
pkgrel = 1
url = https://github.com/libyal/libfvde/wiki
arch = i686
@@ -12,10 +10,12 @@ pkgbase = libfvde-git
makedepends = git
depends = libxml2
depends = openssl
- provides = libfvde=20151013.r6.g82c2461
+ provides = libfvde=20180108.r0.g3584a32
conflicts = libfvde
source = libfvde::git+https://github.com/libyal/libfvde.git
+ source = libfvalue_string.patch
md5sums = SKIP
+ md5sums = 7dd39c62a7dc74dc757935c2a669bbb6
pkgname = libfvde-git
diff --git a/PKGBUILD b/PKGBUILD
index edc7db62462d..a9f48841de9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libfvde-git
_pkgname=${pkgname%-git}
-pkgver=20151013.r6.g82c2461
+pkgver=20180108.r0.g3584a32
pkgrel=1
pkgdesc='Library and tools to access FileVault Drive Encryption (FVDE) encrypted volumes'
arch=('i686' 'x86_64' 'any')
@@ -14,8 +14,10 @@ provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
options=()
install=
-source=("$_pkgname"::"git+https://github.com/libyal/$_pkgname.git")
-md5sums=('SKIP')
+source=("$_pkgname"::"git+https://github.com/libyal/$_pkgname.git"
+ 'libfvalue_string.patch')
+md5sums=('SKIP'
+ '7dd39c62a7dc74dc757935c2a669bbb6')
pkgver() {
cd "$_pkgname"
@@ -30,6 +32,7 @@ prepare() {
cd "$_pkgname"
./synclibs.sh
+ patch -p1 < ../libfvalue_string.patch
}
build() {
diff --git a/libfvalue_string.patch b/libfvalue_string.patch
new file mode 100644
index 000000000000..a2a79fcd04c9
--- /dev/null
+++ b/libfvalue_string.patch
@@ -0,0 +1,31 @@
+diff --git a/libfvde/libfvde_libfvalue.h b/libfvde/libfvde_libfvalue.h
+index 6b1e87e..264552a 100644
+--- a/libfvde/libfvde_libfvalue.h
++++ b/libfvde/libfvde_libfvalue.h
+@@ -33,12 +33,15 @@
+ #include <libfvalue_definitions.h>
+ #include <libfvalue_floating_point.h>
+ #include <libfvalue_integer.h>
+-#include <libfvalue_split_string.h>
++#include <libfvalue_split_utf16_string.h>
++#include <libfvalue_split_utf8_string.h>
+ #include <libfvalue_string.h>
+ #include <libfvalue_table.h>
+ #include <libfvalue_types.h>
+ #include <libfvalue_value.h>
+ #include <libfvalue_value_type.h>
++#include <libfvalue_utf16_string.h>
++#include <libfvalue_utf8_string.h>
+
+ #else
+
+@@ -51,7 +54,7 @@
+
+ #include <libfvalue.h>
+
+-#endif
++#endif /* defined( HAVE_LOCAL_LIBFVALUE ) */
+
+-#endif
++#endif /* !defined( _LIBFVDE_LIBFVALUE_H ) */
+