summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsaac Freund2020-03-17 16:01:43 +0100
committerIsaac Freund2020-03-17 16:01:43 +0100
commit832499aebf1609d6ed2d1d35712f20f8a6327c19 (patch)
tree4fd8f163c1ee8b8387d5120f31428770d4ed53f9
downloadaur-832499aebf1609d6ed2d1d35712f20f8a6327c19.tar.gz
Create package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD32
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..902816a25fb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = waylock
+ pkgdesc = A simple screenlocker for wayland compositors.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/ifreund/waylock
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ depends = cairo
+ depends = wayland
+ source = waylock-0.1.0.tar.gz::https://github.com/ifreund/waylock/archive/v0.1.0.tar.gz
+ sha256sums = 88f05571a7f151693f1b2ebc44c5d9d1a0a29807e2192e92f69efe9584562274
+
+pkgname = waylock
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0b996ca7c09
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: ifreund <ifreund@ifreund.xyz>
+
+pkgname=waylock
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A simple screenlocker for wayland compositors.'
+arch=('x86_64')
+url="https://github.com/ifreund/${pkgname}"
+license=('MIT')
+depends=('cairo' 'wayland')
+makedepends=('rust')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('88f05571a7f151693f1b2ebc44c5d9d1a0a29807e2192e92f69efe9584562274')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cargo build --release --locked
+}
+
+check() {
+ cd "${pkgname}-${pkgver}"
+ cargo test --release --locked
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ install -Dm 755 "target/release/${pkgname}" -t "${pkgdir}/usr/bin"
+
+ install -Dm 644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
+ install -Dm 644 "LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}