summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoritz Kiefer2015-06-08 22:31:28 +0200
committerMoritz Kiefer2015-06-08 22:31:28 +0200
commit835abe644f80ea2850162be181515e1da66edf59 (patch)
tree26f98a83caf7f699d449e336cd7d5e5770c76488
downloadaur-835abe644f80ea2850162be181515e1da66edf59.tar.gz
Initial commit
-rw-r--r--.AURINFO25
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD52
-rw-r--r--license.txt7
5 files changed, 117 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..30d04533cab1
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,25 @@
+pkgbase = linuxsampler-svn
+ pkgdesc = Sampler backend, including sampler engine, audio and MIDI drivers, network layer (LSCP) API and native C++ API
+ pkgver = r2580
+ pkgrel = 1
+ url = http://www.linuxsampler.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = subversion
+ makedepends = ladspa
+ makedepends = dssi
+ depends = libgig-svn
+ depends = jack
+ depends = sqlite
+ depends = util-linux
+ depends = perl-xml-parser
+ provides = linuxsampler
+ conflicts = linuxsampler
+ source = linuxsampler-svn::svn+https://svn.linuxsampler.org/svn/linuxsampler/trunk
+ source = license.txt
+ options = libtool
+
+pkgname = linuxsampler-svn
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce4e7f9e7508
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = linuxsampler-svn
+ pkgdesc = Sampler backend, including sampler engine, audio and MIDI drivers, network layer (LSCP) API and native C++ API
+ pkgver = r2729
+ pkgrel = 1
+ url = http://www.linuxsampler.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = subversion
+ makedepends = ladspa
+ makedepends = dssi
+ depends = libgig-svn
+ depends = jack
+ depends = sqlite
+ depends = util-linux
+ depends = perl-xml-parser
+ provides = linuxsampler
+ conflicts = linuxsampler
+ options = libtool
+ source = linuxsampler-svn::svn+https://svn.linuxsampler.org/svn/linuxsampler/trunk
+ source = license.txt
+ sha256sums = SKIP
+ sha256sums = fe9613dc00d4dafdbe9132ba00e82b0c6f333c53dffe02e29a8dfe1753c7b622
+
+pkgname = linuxsampler-svn
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..02cd995a53e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+/linuxsampler-svn/
+/pkg/
+/src/
+*~
+*.gz
+*.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..242b249afa7b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Moritz Kiefer <moritz.kiefer at gmail dot com>
+# Contributor: Jiri Prochazka <ojirio at gmail dot com>
+# Contributor: orbisvicis <orbisvicis at gmail dot com>
+# Contributor: Tom Vincent <http://tlvince.com/contact/>
+
+pkgname=linuxsampler-svn
+_pkgname="${pkgname%-svn}"
+pkgver=r2729
+pkgrel=1
+pkgdesc="Sampler backend, including sampler engine, audio and MIDI drivers, network layer (LSCP) API and native C++ API"
+arch=("i686" "x86_64")
+url="http://www.linuxsampler.org/"
+license=("GPL" "custom")
+depends=("libgig-svn" "jack" "sqlite" "util-linux" "perl-xml-parser")
+makedepends=("subversion" "ladspa" "dssi")
+optdepends=()
+provides=('linuxsampler')
+conflicts=('linuxsampler')
+options=("libtool")
+source=("$pkgname"::"svn+https://svn.linuxsampler.org/svn/$_pkgname/trunk"
+ "license.txt")
+sha256sums=('SKIP'
+ 'fe9613dc00d4dafdbe9132ba00e82b0c6f333c53dffe02e29a8dfe1753c7b622')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make -f Makefile.cvs
+ ./configure --prefix=/usr --enable-vst-sdk=../vstsdk2.4
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR=$pkgdir install
+
+ # rename lscp to lscpsh
+ mv "$pkgdir/usr/bin/lscp" "$pkgdir/usr/bin/lscpsh"
+ mv "$pkgdir/usr/share/man/man1/lscp.1" "$pkgdir/usr/share/man/man1/lscpsh.1"
+
+ # install GPL exception statement
+ install -Dm0644 ../license.txt "${pkgdir}/usr/share/licenses/$pkgname/GPL-EXCEPTION"
+
+ # add linuxsampler library path to ld.so.conf.d
+ install -m0755 -d "$pkgdir/etc/ld.so.conf.d"
+ echo "/usr/lib/$_pkgname" > "$pkgdir/etc/ld.so.conf.d/$_pkgname.conf"
+}
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..98031bc952ea
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,7 @@
+LinuxSampler is licensed under the GNU GPL with the exception that
+USAGE of the source code, libraries and applications
+FOR COMMERCIAL HARDWARE OR SOFTWARE PRODUCTS IS NOT ALLOWED without
+prior written permission by the LinuxSampler authors.
+
+If you have questions on the subject, that are not yet covered by
+the FAQ, please contact us.