summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoran7oine2017-04-14 12:12:15 +0300
committeran7oine2017-04-14 12:27:20 +0300
commit836020b9960182419e83ac0eb7f2093f46f29987 (patch)
tree60fcf4215b35ea2bcb013c471a7eafe3768f04cd
downloadaur-836020b9960182419e83ac0eb7f2093f46f29987.tar.gz
Upstream v3.0.3
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
-rw-r--r--acestream-engine.install15
-rw-r--r--acestream-engine.service12
4 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e09f561fcb64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = acestream-engine-i686
+ pkgdesc = ACE Stream engine
+ pkgver = 3.0.3
+ pkgrel = 1
+ url = http://acestream.org/
+ install = acestream-engine.install
+ arch = i686
+ license = unknown
+ depends = python2-setuptools
+ depends = python2-xlib
+ depends = python2-m2crypto
+ depends = python2-apsw
+ optdepends = libappindicator-gtk2: GTK+ gui support
+ provides = acestream-engine
+ conflicts = acestream-engine
+ source = acestream-engine.service
+ source = http://dl.acestream.org/ubuntu/14/acestream_3.0.3_ubuntu_14.04_i686.tar.gz
+ sha256sums = b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0
+ sha256sums = 06f329915273c3adbc2d7c2c23bbeddd3d244c837d0817acaa8c90bd648b6753
+
+pkgname = acestream-engine-i686
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..35ad28302240
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jan Magnus Brevik <janmbrevik at gmail dot com>
+# Contributor: Rubén Fdes Moreira <tmp-meteque@openmailbox.com>
+# Contributor: Sigmund Vestergaard <sigmundv at gmail dot com>
+# Contributor: MacCyber <jonas.enge at gmail dot com>
+# Contributor: Doug Newgard <scimmia22 at outlook dot com>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Antti Hautaniemi <an7oine at me com>
+
+pkgname=acestream-engine-i686
+pkgver=3.0.3
+pkgrel=1
+_ubuntuver=14.04
+pkgdesc="ACE Stream engine"
+arch=('i686')
+url="http://acestream.org/"
+license=('unknown')
+provides=('acestream-engine')
+conflicts=('acestream-engine')
+depends=('python2-setuptools' 'python2-xlib' 'python2-m2crypto' 'python2-apsw')
+optdepends=('libappindicator-gtk2: GTK+ gui support')
+install='acestream-engine.install'
+
+source=("acestream-engine.service"
+ "http://dl.acestream.org/ubuntu/14/acestream_${pkgver}_ubuntu_${_ubuntuver}_${CARCH}.tar.gz")
+sha256sums=('b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0'
+ '06f329915273c3adbc2d7c2c23bbeddd3d244c837d0817acaa8c90bd648b6753')
+
+package() {
+ cd "$srcdir/acestream_${pkgver}_ubuntu_${_ubuntuver}_$CARCH"
+ install -Dm755 acestreamengine "$pkgdir/usr/bin/acestreamengine"
+ install -d "$pkgdir/usr/share/acestream/"
+ cp -a data lib "$pkgdir/usr/share/acestream/"
+ install -Dm644 "$srcdir/acestream-engine.service" "$pkgdir/usr/lib/systemd/system/acestream-engine.service"
+}
diff --git a/acestream-engine.install b/acestream-engine.install
new file mode 100644
index 000000000000..38fe9eecc240
--- /dev/null
+++ b/acestream-engine.install
@@ -0,0 +1,15 @@
+post_install() {
+ if ! getent passwd acestream &> /dev/null; then
+ useradd -u 4035 -g video -m -s /usr/bin/nologin acestream
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ if getent passwd acestream &>/dev/null; then
+ userdel acestream
+ fi
+}
diff --git a/acestream-engine.service b/acestream-engine.service
new file mode 100644
index 000000000000..a5c6bc9c2fa2
--- /dev/null
+++ b/acestream-engine.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=AceStream Engine (console)
+After=network.target
+
+[Service]
+Type=simple
+User=acestream
+Group=video
+ExecStart=/usr/bin/acestreamengine --client-console --bind-all
+
+[Install]
+WantedBy=multi-user.target