summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-08-14 14:57:30 +0800
committerUniversebenzene2019-08-14 14:57:30 +0800
commit836849f226017eb8a89f4c6a3ee42191e4cfec0c (patch)
tree159a911aaa0f9ae69eecebbc81e355b5ac793124
parent873dc6d44d14f7ac77ca7d496f2cee38b4d9831f (diff)
downloadaur-836849f226017eb8a89f4c6a3ee42191e4cfec0c.tar.gz
Update to version 1.2.16
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD27
-rw-r--r--fix_doc_warning.patch11
4 files changed, 33 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c94003c4eed0..4a052e401aac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,29 @@
pkgbase = python-spherical_geometry
pkgdesc = Python based tools for spherical geometry
- pkgver = 1.2.11
+ pkgver = 1.2.16
pkgrel = 1
url = http://www.stsci.edu/resources/software_hardware/stsci_python
arch = i686
arch = x86_64
license = BSD
makedepends = python-setuptools
+ makedepends = python-numpy
makedepends = qd>=2.3.7
- makedepends = python-astropy>=3.1
- makedepends = python-astropy-helpers
- makedepends = python-sphinx-astropy
- source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.11.tar.gz
+ makedepends = python-sphinx-automodapi
+ makedepends = python-numpydoc
+ makedepends = wcslib<6.3
+ source = https://files.pythonhosted.org/packages/source/s/spherical_geometry/spherical_geometry-1.2.16.tar.gz
source = fix_doc_warning.patch
- md5sums = ecec9cc8b3ec35199ebac6c7bf6b2b15
- md5sums = 4cffeb20c8e88870eae7188104308a35
+ md5sums = 9c3b00d6936bcd6c3a0e3ac007974740
+ md5sums = fed5395d45a2275ccd5e0d63956ecddf
pkgname = python-spherical_geometry
depends = python>=3.5
depends = python-numpy>=1.10.0
depends = qd>=2.3.7
depends = python-astropy>=0.4
+ depends = wcslib<6.3
optdepends = python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit
- optdepends = python-pytest-astropy: For testing suite
- optdepends = python-astropy<3.2: For testing
pkgname = python-spherical_geometry-doc
pkgdesc = Documentation for Python Spherical Geometry Toolkit
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1df7b618a7b3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 1d4e67904041..2fc6978c72a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,52 +2,49 @@
pkgbase=python-spherical_geometry
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python-${_pyname}-doc")
-pkgver=1.2.11
+pkgver=1.2.16
pkgrel=1
pkgdesc="Python based tools for spherical geometry"
arch=('i686' 'x86_64')
url="http://www.stsci.edu/resources/software_hardware/stsci_python"
license=('BSD')
-makedepends=('python-setuptools' 'qd>=2.3.7' 'python-astropy>=3.1' 'python-astropy-helpers' 'python-sphinx-astropy')
-#checkdepends=('python-pytest-astropy')
+makedepends=('python-setuptools' 'python-numpy' 'qd>=2.3.7' 'python-sphinx-automodapi' 'python-numpydoc' 'wcslib<6.3')
+#checkdepends=('python-pytest' 'python-astropy')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'fix_doc_warning.patch')
-md5sums=('ecec9cc8b3ec35199ebac6c7bf6b2b15'
- '4cffeb20c8e88870eae7188104308a35')
+md5sums=('9c3b00d6936bcd6c3a0e3ac007974740'
+ 'fed5395d45a2275ccd5e0d63956ecddf')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
- sed -i -e '/[pytest]/s/pytest/tool:pytest/' setup.cfg
- sed -i -e '/auto_use/s/True/False/' setup.cfg
patch -Np1 -i "${srcdir}/fix_doc_warning.patch"
+ export USE_SYSTEM_QD=1
}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build --use-system-libraries --offline
+ python setup.py build
msg "Building Docs"
- python setup.py build_docs
+ python setup.py build_sphinx
}
#check() {
# cd ${srcdir}/${_pyname}-${pkgver}
#
-# python setup.py test
+# pytest
#}
package_python-spherical_geometry() {
- depends=('python>=3.5' 'python-numpy>=1.10.0' 'qd>=2.3.7' 'python-astropy>=0.4')
- optdepends=('python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit'
- 'python-pytest-astropy: For testing suite'
- 'python-astropy<3.2: For testing')
+ depends=('python>=3.5' 'python-numpy>=1.10.0' 'qd>=2.3.7' 'python-astropy>=0.4' 'wcslib<6.3')
+ optdepends=('python-spherical_geometry-doc: Documentation for Spherical Geometry Toolkit')
cd ${srcdir}/${_pyname}-${pkgver}
install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}/"
install -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}/" licenses/*
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1 --use-system-libraries --offline
+ python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
}
package_python-spherical_geometry-doc() {
diff --git a/fix_doc_warning.patch b/fix_doc_warning.patch
index 378986c5129d..ccbd808217a8 100644
--- a/fix_doc_warning.patch
+++ b/fix_doc_warning.patch
@@ -1,6 +1,6 @@
---- a/README.rst 2019-02-22 12:38:47.000000000 +0800
-+++ b/README.rst 2019-02-24 15:06:53.785650230 +0800
-@@ -93,12 +93,14 @@
+--- a/README.rst 2019-08-14 09:29:42.000000000 +0800
++++ b/README.rst 2019-08-14 14:12:09.437040500 +0800
+@@ -105,12 +105,14 @@
What is the orientation?
^^^^^^^^^^^^^^^^^^^^^^^^
@@ -10,14 +10,13 @@
a consistent orientation of the points defining it. That is, the points
should have a clockwise order. When creating a new spherical polygon,
the order of the points defining a polygon will be reversed if they are
--not in clockwise order. The method `SphericalPolygon.is_clockwise`is
+ not in clockwise order. The method `SphericalPolygon.is_clockwise` is
-used to est if the points are in clockwise order. It takes two
-+not in clockwise order. The method `SphericalPolygon.is_clockwise` is
+used to test if the points are in clockwise order. It takes two
successive sides and computes the normal vector to the sides. If the
normal vector points inward towards the center of the sphere, the two
sides are counter clockwise. If the normal vector points outward, the
-@@ -170,7 +172,7 @@
+@@ -183,7 +185,7 @@
`~SphericalPolygon.multi_intersection`: Return a new polygon that
is the intersection of two or more polygons.