summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-01-18 15:57:50 -0500
committerCarlos Aznarán2024-01-18 15:57:50 -0500
commit836f2468a46dbeea57153386f673f221aefa9c06 (patch)
tree608ffa77aac972296211cd28a21486650fa3440e
parentff0f25bed5656091169d40e8f25cb9e653083eda (diff)
downloadaur-836f2468a46dbeea57153386f673f221aefa9c06.tar.gz
Bump version to 0.7.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91e2a15990ff..a31bca1051ab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-uqbar
pkgdesc = Tools for building documentation with Sphinx, Graphviz and LaTeX
- pkgver = 0.7.0
+ pkgver = 0.7.1
pkgrel = 1
url = https://github.com/josiah-wolf-oberholtzer/uqbar
arch = any
@@ -14,7 +14,7 @@ pkgbase = python-uqbar
depends = python-sphinx
depends = python-unidecode
depends = python-black
- source = python-uqbar-7.0.0.tar.gz::https://github.com/josiah-wolf-oberholtzer/uqbar/archive/v7.0.0.tar.gz
- sha512sums = a63e9d6c805e77d98b2dd971b89d6d63f1dd80c4ce67a7df418246614348c5f9fa7361eb10acb983ca05357c51c637a4dd384b3789cbeddad3d8bf85ae9439aa
+ source = python-uqbar-0.7.1.tar.gz::https://github.com/josiah-wolf-oberholtzer/uqbar/archive/v0.7.1.tar.gz
+ sha512sums = 78023f79d793763723203f056476181cf2cfe4bd93ceda60efafbc975635c8023d2323c4e7be2fc6700d3b30381c79aa7683f36991d0da6947776f219e0fdfe8
pkgname = python-uqbar
diff --git a/PKGBUILD b/PKGBUILD
index 618a954e0360..e48c4d85135a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,7 @@
# Contributor: Robert Kubosz <kubosz.robert@gmail.com>
_base=uqbar
pkgname=python-${_base}
-_pkgver=7.0.0
-pkgver=0.7.0
+pkgver=0.7.1
pkgrel=1
pkgdesc="Tools for building documentation with Sphinx, Graphviz and LaTeX"
arch=(any)
@@ -13,29 +12,29 @@ license=(MIT)
depends=(python-sphinx python-unidecode python-black)
makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(python-pytest-cov graphviz)
-source=(${pkgname}-${_pkgver}.tar.gz::${url}/archive/v${_pkgver}.tar.gz)
-sha512sums=('a63e9d6c805e77d98b2dd971b89d6d63f1dd80c4ce67a7df418246614348c5f9fa7361eb10acb983ca05357c51c637a4dd384b3789cbeddad3d8bf85ae9439aa')
+source=(${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
+sha512sums=('78023f79d793763723203f056476181cf2cfe4bd93ceda60efafbc975635c8023d2323c4e7be2fc6700d3b30381c79aa7683f36991d0da6947776f219e0fdfe8')
prepare() {
- cd ${_base}-${_pkgver}
+ cd ${_base}-${pkgver}
sed -i '/sphinx_immaterial/d' docs/source/conf.py
}
build() {
- cd ${_base}-${_pkgver}
+ cd ${_base}-${pkgver}
python -m build --wheel --skip-dependency-check --no-isolation
PYTHONPATH="$PWD" make -C docs man
}
check() {
- cd ${_base}-${_pkgver}
+ cd ${_base}-${pkgver}
python -m venv --system-site-packages test-env
test-env/bin/python -m installer dist/*.whl
test-env/bin/python -m pytest tests -k 'not find_executable'
}
package() {
- cd ${_base}-${_pkgver}
+ cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 "docs/build/man/${_base}.1" -t "${pkgdir}/usr/share/man/man1/"
install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"