summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2020-08-22 23:29:05 -0400
committeracxz2020-08-22 23:29:05 -0400
commit8382aa9333cac2f962fb59502d04c91685e5e8dc (patch)
tree1e0ab378a2d9becf4e8d80f04eae815392da915a
parent1b75e079ca308bbf616afd42bd23f3fc220f26fd (diff)
downloadaur-8382aa9333cac2f962fb59502d04c91685e5e8dc.tar.gz
[rocm-smi] updpkg 3.7.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--python2_fix.patch70
3 files changed, 7 insertions, 86 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cbe382369a6..b4be00eb7339 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = rocm-smi
pkgdesc = Utility to manage and monitor AMDGPU / ROCm systems
- pkgver = 3.5.0
+ pkgver = 3.7.0
pkgrel = 1
url = https://github.com/RadeonOpenCompute/ROC-smi
arch = any
license = MIT
depends = python
- source = rocm-smi-3.5.0::https://github.com/RadeonOpenCompute/ROC-smi/archive/rocm-3.5.0.tar.gz
- source = python2_fix.patch
- sha256sums = 4f46e947c415a4ac12b9f6989f15a42afe32551706b4f48476fba3abf92e8e7c
- sha256sums = acff646a9ffdd338f25c8fcdc2282cbd7039ef80f215f4a5ab2fbfdde2705781
+ source = rocm-smi-3.7.0::https://github.com/RadeonOpenCompute/ROC-smi/archive/rocm-3.7.0.tar.gz
+ sha256sums = 4e34b3b4e409bb89677882f47d9988d56bc2d9bb9893f0712c22a4b73789e06a
pkgname = rocm-smi
diff --git a/PKGBUILD b/PKGBUILD
index 396ef1dab84c..8bddc36cd597 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,17 @@
# Contributor: acxz <akashpatel2008 at yahoo dot com>
pkgname=rocm-smi
-pkgver=3.5.0
+pkgver=3.7.0
pkgrel=1
pkgdesc='Utility to manage and monitor AMDGPU / ROCm systems'
arch=('any')
url='https://github.com/RadeonOpenCompute/ROC-smi'
license=('MIT')
-depends=(python)
-source=("$pkgname-$pkgver::$url/archive/rocm-$pkgver.tar.gz"
- "python2_fix.patch")
-sha256sums=('4f46e947c415a4ac12b9f6989f15a42afe32551706b4f48476fba3abf92e8e7c'
- 'acff646a9ffdd338f25c8fcdc2282cbd7039ef80f215f4a5ab2fbfdde2705781')
+depends=('python')
+source=("$pkgname-$pkgver::$url/archive/rocm-$pkgver.tar.gz")
+sha256sums=('4e34b3b4e409bb89677882f47d9988d56bc2d9bb9893f0712c22a4b73789e06a')
_dirname="$(basename "$url")-$(basename "${source[0]}" .tar.gz)"
-prepare() {
- cd "$_dirname"
- patch -Np1 -i "$srcdir/python2_fix.patch"
-}
-
package() {
install -Dm644 "$_dirname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 "$_dirname/README.md" "$pkgdir/usr/share/doc/$pkgname/README"
diff --git a/python2_fix.patch b/python2_fix.patch
deleted file mode 100644
index 0b37cce72cac..000000000000
--- a/python2_fix.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-diff --git a/rocm_smi.py b/rocm_smi.py
-index 7b36028..8ba2bd0 100755
---- a/rocm_smi.py
-+++ b/rocm_smi.py
-@@ -739,7 +739,7 @@ def getCurrentClock(device, clock, clocktype):
- # Hack: In the kernel, FCLK doesn't have an * at all if DPM is disabled.
- # If there is only 1 speed (1 line total, meaning 0 levels), just print it
- if len(currClocks.splitlines()) == 1 and len(currClocks) > 1:
-- if clocktype is 'freq':
-+ if clocktype == 'freq':
- if currClocks.find('DPM disabled'):
- logging.debug('Only 1 level for clock %s; DPM is disabled for this specific clock' % clock)
- return currClocks.split(' *')[0][3:]
-@@ -824,7 +824,7 @@ def getVersion(deviceList, component):
- deviceList -- List of DRM devices (can be a single-item list)
- component - Component (currently only driver)
- """
-- if component is 'driver':
-+ if component == 'driver':
- # Only 1 version, so report it for GPU 0
- driver = getSysfsValue(None, 'driver')
- if driver is None:
-@@ -846,10 +846,10 @@ def getRetiredPages(device, retiredType):
- return None
- for line in pages.split('\n'):
- pgType = line.split(' : ')[-1]
-- if (retiredType is 'all' or \
-- retiredType is 'retired' and pgType is 'R' or \
-- retiredType is 'pending' and pgType is 'P' or \
-- retiredType is 'unreservable' and pgType is 'F'):
-+ if (retiredType == 'all' or \
-+ retiredType == 'retired' and pgType == 'R' or \
-+ retiredType == 'pending' and pgType == 'P' or \
-+ retiredType == 'unreservable' and pgType == 'F'):
- returnPages += '\n%s' % line
- return returnPages.lstrip('\n')
-
-@@ -1424,7 +1424,7 @@ def showVersion(deviceList, component):
- if component not in validVersionComponents:
- printLog(device, 'Unable to display version information for unsupported component %s' % component)
- return
-- if component is 'driver':
-+ if component == 'driver':
- driver = getVersion(deviceList, component)
- printSysLog('%s version: %s' % (component.capitalize(), driver))
-
-@@ -1824,9 +1824,9 @@ def showRetiredPages(deviceList, retiredType='all'):
- addr = line.split(' : ')[0]
- size = line.split(' : ')[1]
- ptype = line.split(' : ')[2]
-- if ptype is 'R':
-+ if ptype == 'R':
- pgType = 'Retired'
-- elif ptype is 'P':
-+ elif ptype == 'P':
- pgType = 'Pending'
- else:
- pgType = 'Unreservable'
-@@ -2281,9 +2281,9 @@ def setClockRange(deviceList, clktype, level, value, autoRespond):
- logging.error('Non-integer characters are present in %s', value)
- RETCODE = 1
- return
-- if clkType is 'sclk':
-+ if clkType == 'sclk':
- sysvalue = 's %s %s' % (level, value)
-- elif clkType is 'mclk':
-+ elif clkType == 'mclk':
- sysvalue = 'm %s %s' % (level, value)
- else:
- printLogNoDev('Invalid clock type %s' % clkType)