summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKr1ss2021-10-14 00:46:24 +0200
committerKr1ss2021-10-14 00:46:24 +0200
commit838a9a7774f366fc7f9331cc2ddbee3d7e231a65 (patch)
tree2af06ead727570c70a68aa24582f68a4531b8363
parent16009ec480d91e4339e498e39a3163faac1acb4f (diff)
downloadaur-838a9a7774f366fc7f9331cc2ddbee3d7e231a65.tar.gz
remove windows specific files, fix permissions
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6da41d319ac2..7d6a9f25a5e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = maltego
pkgdesc = Information gathering software by Paterva
pkgver = 4.2.19.13940
- pkgrel = 2
+ pkgrel = 3
url = https://www.maltego.com
install = maltego.install
arch = any
license = custom
depends = java-runtime<=15
depends = sh
+ options = !emptydirs
source = https://maltego-downloads.s3.us-east-2.amazonaws.com/linux/Maltego.v4.2.19.13940.deb
source = LICENSE.pdf::https://www.maltego.com/pdf/legal/Maltego%20Technologies_TermsandConditions_2020-11.pdf
sha256sums = 8cb8094366b9eaf4bb60d436ad48afd84cc54a73442de5f850ecc9d877643ba6
diff --git a/PKGBUILD b/PKGBUILD
index 41385e19725f..cef7f0289b12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=maltego
pkgver=4.2.19.13940
-pkgrel=2
+pkgrel=3
pkgdesc='Information gathering software by Paterva'
url="https://www.$pkgname.com"
@@ -20,15 +20,19 @@ source=("https://$pkgname-downloads.s3.us-east-2.amazonaws.com/linux/Maltego.v$p
sha256sums=('8cb8094366b9eaf4bb60d436ad48afd84cc54a73442de5f850ecc9d877643ba6'
'5295b55e0da0a7aaa733032bf6d508dd149d66b379f71c4b15271729c3aa5500')
+options=('!emptydirs')
+
package() {
bsdtar -xf data.tar.gz -C "$pkgdir"
sed -i 's|\(Exec=\)x-www-browser|\1xdg-open|g;s|^\(Version=\).*|\11.0|' \
"$pkgdir/usr/share/applications/$pkgname.desktop"
- # maltego_memory_config is defined as action in maltego.desktop, don't need that twice
- rm "$pkgdir/usr/share/applications/${pkgname}_config.desktop"
sed -i '1s|bash|sh|' "$pkgdir/usr/bin/$pkgname"
- chmod g-w "$pkgdir"/usr{,/bin,/share{,/applications,"/$pkgname",/pixmaps}}
+ # maltego_memory_config is defined as action in maltego.desktop, don't need that twice
+ rm "$pkgdir/usr/share/applications/${pkgname}_config.desktop"
+ # remove Windows assets
+ find "$pkgdir" -type f -regex '.*\.\(exe\|dll\)$' -delete
+ chmod -R go-w "$pkgdir"
install -Dm644 LICENSE.pdf -t"$pkgdir/usr/share/licenses/$pkgname/"
}