summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Witkowski2015-06-08 10:31:50 -0600
committerAlan Witkowski2015-06-08 10:31:50 -0600
commit839c69dc339482c0d0f3d524f3f9be0b547bc8aa (patch)
tree1897e98086c8331f5edaff51d73b700dfd933227
downloadaur-839c69dc339482c0d0f3d524f3f9be0b547bc8aa.tar.gz
import
-rw-r--r--.SRCINFO18
-rw-r--r--Changelog5
-rw-r--r--PKGBUILD40
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e069c45f7fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = choria
+ pkgdesc = 2D MMORPG that's all about grinding and doing chores
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = http://code.google.com/p/choria/
+ changelog = Changelog
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ depends = gcc-libs
+ depends = irrlicht
+ depends = sqlite
+ source = http://choria.googlecode.com/files/choria-0.4.1-src.tar.gz
+ sha256sums = 6d1e568ccaf1678a3be9aba4000112d01c2a6f1320f72968ad6ba17043077713
+
+pkgname = choria
+
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..3c097a7287e4
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,5 @@
+2013-06-20 Alan Witkowski <alan.witkowski@gmail.com>
+
+ 0.4.1-1:
+ * Used Mariusz Libera's PKGBUILD as basis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e687508e120
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Alan Witkowski <alan dot witkowski at gmail dot com>
+pkgname=choria
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="2D MMORPG that's all about grinding and doing chores"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/choria/"
+license=('GPL3')
+depends=('gcc-libs' 'irrlicht' 'sqlite')
+makedepends=('cmake')
+changelog=Changelog
+source=("http://choria.googlecode.com/files/$pkgname-$pkgver-src.tar.gz")
+sha256sums=('6d1e568ccaf1678a3be9aba4000112d01c2a6f1320f72968ad6ba17043077713')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver-src
+
+ # script fix
+ sed -i 's|/local||' deployment/choria
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver-src
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver-src
+
+ make DESTDIR=$pkgdir install
+
+ # it's a standard license, rm it
+ rm $pkgdir/usr/share/doc/$pkgname/license.txt
+
+ # place starting script where it's supposed to be
+ install -dm755 $pkgdir/usr/bin
+ mv $pkgdir/usr/games/$pkgname $pkgdir/usr/bin/$pkgname
+ rmdir $pkgdir/usr/games
+}